Sou advogado e consegui instalar Certificado Digital para PJe

Descrevo experiência pessoal de instalação de Certificado Digital ICP Brasil para acesso de sistemas Judiciais (TJMG, TRT3, TST, STJ, STF, Receita Federal, TCEMG).

[ Hits: 17.532 ]

Por: Marcos Moraes em 15/09/2016


Introdução



Instalando Linux do zero com objetivo de configurar para Assinatura Digital.

Comecei do zero e foquei em instalar a Certificação Digital e testar nos principais tribunais.

Inicialmente baixei a última versão do Ubuntu 16.04 Desktop.

Instalado o Ubuntu, procedi logo a instalação indicada.

Primeiro instalei o Java. Não instale pelo sistema gráfico. Use modo terminal.

Todas as tentativas de instalar o Java via gráfica não tiveram sucesso real na hora de fazer reconhecer no Firefox. Sugiro usar o terminal.

Então vá no modo terminal e entre modo superusuário.

sudo su

Entrando no modo root. Instale o Java e todos os aplicativos que serão solicitados:

sudo add-apt-repository ppa:webupd8team/java
$ sudo apt-get update
$ sudo apt-get install oracle-java8-installer oracle-java8-set-default
$ sudo apt-get update


Verifique a instalação:

# java -version

Caso de dúvidas no java, sugestão de manual:

Dispositivo de Token ou Leitora de Cartão

Usei primeiramente o site oficial da Valid, um dos certificados digitais que uso no link, ele funcionou para os dois dispositivos que tenho.

Como dito, não clique duas vezes e instale pelo sistema gráfico. Use modo terminal.

Custei a entender que quando tentava usar o modo gráfico da central clicando duas vezes, não funcionava, e pior, não explica porque, não conseguia mais instalar no modo gráfico. É o Ubuntu.

O que você deve fazer é baixar para um diretório para que no modo super-usuário, chegue lá.

Importante que você deixe um diretório somente com estes arquivos.

Eu fiz o seguinte... Deixei no diretório Downloads mesmo e criei um subdiretório valid.

Vá no diretório onde baixou os arquivos da valid. No meu caso, como dito, deixei no diretório valid. No terminal, vá até lá:

# cd ~/Downloads/Valid

Importante, no Linux letras maiúsculas e minúsculas são diferentes, então tem que acertar.

A seguir usei o comando para instalar:

# apt-get update
# apt-get install *.deb


Execute novamente:

# apt-get update

Próximo comando faz atualização do sistema:

# apt-get upgrade

Feito isto, vamos instalar o cliente do token:

Apesar do valid ter o cliente, eu usei este especifico:

64bits: http://www.iti.gov.br/images/middlewares/safesignidentityclient_3.0.77-Ubuntu_amd64.deb

32bits: http://www.iti.gov.br/images/middlewares/safesignidentityclient_3.0.77-Ubuntu_i386.deb

IMPORTANTE: você tem que saber onde instalar o pacote, baixe no diretório e vá onde ele foi baixado:

# dpkg -i nome_do_pacote.deb

Exemplo no caso de 64 bits:

# dpkg -i safesignidentityclient_3.0.77-Ubuntu_amd64.deb

Digite novamente:

# apt-get update
# apt-get upgrade


Teste sua leitora:

# pcsc_scan

Feito isto, passei instalar as cadeias de certificados da ICP-BRASIL.

Para instalar a cadeia de certificados vá no link:
e clique no certificado um a um.

Ou neste link mais específico: http://www.iti.gov.br/icp-brasil/certificados/188-atualizacao/4530-ac-raiz

Clique em cada certificado e instale.

Vá no site da valid onde tem certificados dos tribunais:
Não deixe de instalar os certificados dos tribunais.

Também baixe este certificado da Certsign:
Finalmente vá em:
Falta somente agora conferir no Firefox se foi instalado o Java e o dispositivo do token lá. É mais chato de tudo, mas vamos lá.

Primeiro vamos inserir o token no Firefox.

Abra o navegador web. Vá em:

Editar > Preferências >Avançado > Certificados

Selecione dispositivos de segurança

Clique em "load" para carregar um novo módulo.

Clique em procurar ou digite o caminho /usr/lib/libaetpkss.so.3, assinale "ok" e feche o navegador.

Reinicie o seu sistema operacional.

Insira seu certificado digital na leitora e abra o seu navegador.

Vá em:

Editar > Preferências >Avançado > Certificados e selecione Dispositivos de Segurança. É possível ver informações do seu certificado.

Clique sobre o novo módulo criado e em seguida sobre Logar. Informe sua senha PIN e confirme. Veja seu certificado selecionando Certificados.
  • Ubuntu 16.04
  • Java JDK 8
  • Mozila Firefox 46
  • SafeSignCliente 7

   

Páginas do artigo
   1. Introdução
Outros artigos deste autor

Atualização do PJeOffice via Terminal no Ubuntu 19.04

Certificação Eletrônica no Linux para PJe - Relato de minha experiência como advogado

Leitura recomendada

Assistindo vídeos no XMMS

Instalando e configurando o SSH

Manejando contas de usuários

Redimencionando SWAP sem reinstalar o Linux

Instalando Gentoo Linux através da sua distribuição

  
Comentários
[1] Comentário enviado por fabio em 15/09/2016 - 22:50h

Você não faz ideia de como eu estava precisando deste artigo. Vou tentar instalar ainda hoje aqui.

[2] Comentário enviado por Mc.Eagle em 15/09/2016 - 23:07h

De qual certificados estamos falando? GD Starting? SafeNet? Qual Certificadora?

[3] Comentário enviado por mineirobr em 16/09/2016 - 01:02h

Parabéns, eu tentei fazer isso, mas o leitor de cartão do cliente não tinha driver para Linux.

[4] Comentário enviado por mebelin em 16/09/2016 - 13:17h

Obrigado por compartilhar.
Sobre instalar o token no Firefox, no tokenadmin tem opção para instalar clicando no menu integração.

[5] Comentário enviado por erixtech em 16/09/2016 - 13:23h

Legal o artigo.

*Bacana ver alguem de TI atuando tambem com direito.

------------------------------------------------------
KISS principle, RTFM and STFW = 42

[6] Comentário enviado por mamp em 16/09/2016 - 14:08h

Olha estou fazendo uma atualização do artigo e comunicando as autoridades desenvolvedores de falhas.

Na semana passada ITI corrigiu a cadeia de certificados e soltou alterações de instruções.
Estou conversando CNJ e TJMG.

Vou refazer meu artigo com revisão mais detalhada com critica de cada um aqui no site e publicar nova versão do artigo, portanto podem fazer suas criticas e observações para compartilhar o conhecimento.


Vou tentar responder cada um dos itens acima, vamos la.:
1. Fabio, obrigado, mas vamos la, este desafio com espirito coletivo, aberto a criticas e as continuas alterações do sistema pelo CNJ.
2. Mc.Eagle - uso dois certificados, com isto que fiz acima funcionou para StarSign Cripto usb Token da Valid (convenio da OAB com valid) e o Leitora de Cartão GenPc Twin da Certisign (convenio OAB co Certising). Uso os dois. Inclusive por questão de contingencia.
3.Mineiro BR me fale qual é seu leitor de cartao, porque como dito acima consegui configurar o token e leitora de Cartao, ambos com convenio da OAB.
4. Mobelin, obrigado pela ponderação, vou refazer em breve a instalação do zero, pois Valid insistiu que devo usar Ubuntu 12.04 lite para dar suporte. Então vou remover atual versão e refazer o artigo, vou conferir sua dica. Obrigado.
5.erisrjr obrigado, solto em breve nova versão e estou a disposição para gente fazer esta comunidade linux ter resultados reais.

[7] Comentário enviado por teccert em 16/09/2016 - 20:56h

Consegui instalar e usar perfeitamente o Token Aladim da certsign instalando o Java Sun, o drive e seguindo a manual para ubuntu 16.04 - 64bit deste site https://site.solutinet.com.br/2015/manuais/instaladores e as cadeias da OAB do site da certsign, como também preciso emitir DANFE, instalei também as cadeias para CNPJ.

[8] Comentário enviado por teccert em 16/09/2016 - 21:08h

Este é um tema muito importante, pois sempre acontece de surgir dificuldades para as pessoas que são usuário LINUX e que precisam fazer uso do Certificado Digital, pois não se tem muitas informações na rede. Um outro problema que estou enfrentando, é que o software da NFe mantido pelo Governo de São Paulo, não receberá mais atualizações e até o momento nenhuma alternativa open source. Portanto se alguém tiver uma solução neste sentido, poderia compartilhar aqui.

[9] Comentário enviado por bendjouya em 19/09/2016 - 15:42h

Estou fazendo tentativas desde o ano passado, logo vou testar desta forma, mas tem uns poréns:

Quando tu fala pra instalar as cadeias, é todas? pois são muitas.

Nas outras tentativas eu chegava até o PIN e depois dizia que tinha problemas.

Não consegui nenhum suporte ao acesso por linux de nenhuma entidade que usa o pje, como conseguiu? gostaria de contribuir com o refinamento do artigo quando estiver 100%.

Sou de TI com especialização em Direito, tenho uma empresa que atende vários advogados com linux, mas o PJE, STJ e STF são um problema.

Obrigado pelo artigo

[10] Comentário enviado por teccert em 20/09/2016 - 15:50h

No caso das cadeias, dependendo do uso do certificado, devemos instalar o de nosso interesse, tipo: OAB, eCNPJ, NFE, eCPF etc... Não é necessário instalar todos.
Link para os driver:
https://www.dropbox.com/sh/yvm8p9a9f9xivpu/AAB1JJJA7wITud2LF39PSMMKa?dl=0
Link para um simples video de como proceder para o uso do Token Aladim da certisign no Ubuntu 16.04 c/ Firefox 48:
https://www.dropbox.com/s/u4hbg2y2riq13p7/MAH00135.MP4?dl=0

[11] Comentário enviado por mamp em 20/09/2016 - 21:40h

Eu tenho entrado no site de Nota fiscal do Estado de SP;
Mas acho que não e isto?



[8] Comentário enviado por teccert em 16/09/2016 - 21:08h

Este é um tema muito importante, pois sempre acontece de surgir dificuldades para as pessoas que são usuário LINUX e que precisam fazer uso do Certificado Digital, pois não se tem muitas informações na rede. Um outro problema que estou enfrentando, é que o software da NFe mantido pelo Governo de São Paulo, não receberá mais atualizações e até o momento nenhuma alternativa open source. Portanto se alguém tiver uma solução neste sentido, poderia compartilhar aqui.



[12] Comentário enviado por mamp em 20/09/2016 - 21:42h


[10] Comentário enviado por teccert em 20/09/2016 - 15:50h

No caso das cadeias, dependendo do uso do certificado, devemos instalar o de nosso interesse, tipo: OAB, eCNPJ, NFE, eCPF etc... Não é necessário instalar todos.






vou analisar os links pois em breve solto nova versao do artigo.
Link para os driver:
https://www.dropbox.com/sh/yvm8p9a9f9xivpu/AAB1JJJA7wITud2LF39PSMMKa?dl=0
Link para um simples video de como proceder para o uso do Token Aladim da certisign no Ubuntu 16.04 c/ Firefox 48:
https://www.dropbox.com/s/u4hbg2y2riq13p7/MAH00135.MP4?dl=0




[13] Comentário enviado por mamp em 20/09/2016 - 21:45h


[9] Comentário enviado por bendjouya em 19/09/2016 - 15:42h

Estou fazendo tentativas desde o ano passado, logo vou testar desta forma, mas tem uns poréns:

Quando tu fala pra instalar as cadeias, é todas? pois são muitas.

Nas outras tentativas eu chegava até o PIN e depois dizia que tinha problemas.

Não consegui nenhum suporte ao acesso por linux de nenhuma entidade que usa o pje, como conseguiu? gostaria de contribuir com o refinamento do artigo quando estiver 100%.

sim acho que respondi antes.
Fiz a reclamação para desenvolverdores da ITI da cadeia de certificado. Fiz tela a tela.

Eles revisaram a orientação e soltaram nova nota tecnica.

O Key solicitado: icpbrasilkey

mas veja o artigo completo.

http://www.iti.gov.br/icp-brasil/navegadores/188-atualizacao/4735-cadeia-icpbrasil-java-windows




Sou de TI com especialização em Direito, tenho uma empresa que atende vários advogados com linux, mas o PJE, STJ e STF são um problema.

Obrigado pelo artigo



[14] Comentário enviado por mamp em 27/09/2016 - 11:13h

Este artigo versao 1 eu enviei para viva linux a versao 2 com telas, so que não foi publicado.
Acabei de fazer versao 3 do artigo mais detalhado e com PJE-Office e passo a passo. Eu reisntalei ubuntu e fui testando.

Fiz modo pdf, alguem tem alguma sugestao para publicar, ou onde publicar? porque aqui versao 2 com tela nao foi publicado.

Agora estou fazendo o mesmo artigo para Fedora, tive ideia de instalar 3 boot, 1. Ubuntu 2. Fedora 3. Windows.

[15] Comentário enviado por mamp em 28/10/2016 - 13:43h

Custei atualizar o site por causa do programa de HTML que mudou completamente a forma de lidar com as paginas.

Mas o artigo atualizado com telas pagina a pagina esta no link abaixo:

http://www.piresdemoraes.com/Artigos2.html

[16] Comentário enviado por mamp em 01/11/2016 - 11:56h

Pedi autorização ao administrador para criar comunidade Pje.
Caso aprovado posso inserir quem tiver participado aqui neste artigo?

[17] Comentário enviado por mamp em 07/11/2016 - 16:18h

Ao ler e relar a pagina da ITI descobri dois erros na pagina segundo meu ponto de vista;

http://www.iti.gov.br/icp-brasil/certificados/188-atualizacao/4735-cadeia-icpbrasihttp://www.iti.gov...



Custei a entender.
Mas 2 equivocos seria:
1. a linha keystore digita está com algumas letras em maiusculas, e no linux e tudo minusculas.
2. o que era para ser 2.1 JDK esta na linha JRE e trocado vice e versa:
assim esta no site.

2.1 - Para importar a cadeia de certificação ICP-Brasil no Java Runtime Environment(JRE):

2.1.1 - No diretório contendo a Keystore ICP-Brasil descompactada, execute:

$ keytool -importkeystore -srckeystore keystore_ICP_Brasil.jks -srcstorepass 12345678 -destkeystore /usr/lib/jvm/java-1.7.0-openjdk-amd64/jre/lib/security/cacerts -deststorepass changeit

mas correto e contrario,
opnjdk é no 2.2 .

[18] Comentário enviado por bendjouya em 10/11/2016 - 00:48h

Ainda estamos com problemas no TRT4 e TJRS nenhum desses funciona em nenhuma situação;

TRT4(PJe), vai até onde pede o PIN do Token e depois só fica "Aguardando a inicialização do certificado digital";
TJRS, carrega mas informa que não há certificado.

Alguma luz? Abraços a todos, achando a solução publico todos os detalhes

[19] Comentário enviado por RafaelMatos em 05/12/2016 - 22:16h

Fiz tudo aí, foi o site que mais gostei, porém ao tentar utilizar no TJMG o assinador não carregou, a tela do firefox escureceu. Disse ainda que o plugin do java travou. Alguém pode ajudar?
Obrigado

[20] Comentário enviado por mamp em 06/12/2016 - 09:45h

Rafael primeiramente gerei versao mais recente do artigo em cada rotina por resolver algo problema ate mesmo no windows. http://www.piresdemoraes.com/Artigos2.html


Mas preciso conferir o estagio que chegou.
Java funciona? No site do Java esta rodando?
Parece algo da integração com Java.
Qual versão do Firefox esta usando?

Bem sugiro que no java vc vai em configurações e ative depuração e vc vai poder ver linha a linha o que esta processando, ai vc pode descobrir onde esta o erro.

[21] Comentário enviado por mamp em 06/12/2016 - 09:47h


[18] Comentário enviado por bendjouya em 10/11/2016 - 00:48h

Ainda estamos com problemas no TRT4 e TJRS nenhum desses funciona em nenhuma situação;
bendjouya, depois que houve mudanca da cadeia de certificados pela ITI, ideal e ir la ITI e baixar a cadeia de certificados mais recentes e validas. confere la. Ja reportei ao suporte da ITI e CNJ sobre a mudanca de cadeia de certificados e dos problemas.

TRT4(PJe), vai até onde pede o PIN do Token e depois só fica "Aguardando a inicialização do certificado digital";
TJRS, carrega mas informa que não há certificado.

Alguma luz? Abraços a todos, achando a solução publico todos os detalhes




[22] Comentário enviado por Mc.Eagle em 09/01/2017 - 00:40h

Só uma observação colega, onde se lê: "Clique em procurar ou digite o caminho /usr/lib/libaetpkss.so.3, assinale "ok" e feche o navegador." eu setei para "/usr/lib/libeTPkcs11.so" conforme arquivo de texto localizado dentro da própria pasta sac_9.0.43_Debian_Ubuntu_Linux baixado da empresa SolutionNet (https://site.solutinet.com.br/2015/manuais/instaladores/%20ou%20direto:%20http://site.solutinet.com.br/2014/images/files/instaladores-e-manuais/sac_9.0.43_Debian_Ubuntu_Linux.zip) talvez seja essa uma forma de resolver os problemas dos outros companheiros, qua ainda não conseguiram. De onde tirei? https://diadialinux.wordpress.com/2015/12/22/usando-token-aladdin-azul-no-ubuntu-12-04-e-14-04-32-ou...

[23] Comentário enviado por Mc.Eagle em 09/01/2017 - 00:41h


[21] Comentário enviado por mamp em 06/12/2016 - 09:47h


[18] Comentário enviado por bendjouya em 10/11/2016 - 00:48h

Ainda estamos com problemas no TRT4 e TJRS nenhum desses funciona em nenhuma situação;
bendjouya, depois que houve mudanca da cadeia de certificados pela ITI, ideal e ir la ITI e baixar a cadeia de certificados mais recentes e validas. confere la. Ja reportei ao suporte da ITI e CNJ sobre a mudanca de cadeia de certificados e dos problemas.

TRT4(PJe), vai até onde pede o PIN do Token e depois só fica "Aguardando a inicialização do certificado digital";
TJRS, carrega mas informa que não há certificado.

Alguma luz? Abraços a todos, achando a solução publico todos os detalhes






Só uma observação colega, onde se lê: "Clique em procurar ou digite o caminho /usr/lib/libaetpkss.so.3, assinale "ok" e feche o navegador." eu setei para "/usr/lib/libeTPkcs11.so" conforme arquivo de texto localizado dentro da própria pasta sac_9.0.43_Debian_Ubuntu_Linux baixado da empresa SolutionNet (https://site.solutinet.com.br/2015/manuais/instaladores/%20ou%20direto:%20http://site.solutinet.com.br/2014/images/files/instaladores-e-manuais/sac_9.0.43_Debian_Ubuntu_Linux.zip) talvez seja essa uma forma de resolver os problemas dos outros companheiros, qua ainda não conseguiram. De onde tirei? https://diadialinux.wordpress.com/2015/12/22/usando-token-aladdin-azul-no-ubuntu-12-04-e-14-04-32-ou...

[24] Comentário enviado por mamp em 20/01/2017 - 12:10h

Mc.Egle obrigado pela sugestao.
Na proxima vez que for rever artigo vou tentar.
Confesso que tentei uma outra biblioteca e nao funcionou no meu caso. Mas na proxima revisao vou tentar sua sugestao.

Mas comunico a todos, que acabei de acessar no dia 20.01.2017 com meu cartao Certsign e entrei corretamente. Estou usando Pj-e corretamente.



[23] Comentário enviado por Mc.Eagle em 09/01/2017 - 00:41h


[21] Comentário enviado por mamp em 06/12/2016 - 09:47h


[18] Comentário enviado por bendjouya em 10/11/2016 - 00:48h

Ainda estamos com problemas no TRT4 e TJRS nenhum desses funciona em nenhuma situação;
bendjouya, depois que houve mudanca da cadeia de certificados pela ITI, ideal e ir la ITI e baixar a cadeia de certificados mais recentes e validas. confere la. Ja reportei ao suporte da ITI e CNJ sobre a mudanca de cadeia de certificados e dos problemas.

TRT4(PJe), vai até onde pede o PIN do Token e depois só fica "Aguardando a inicialização do certificado digital";
TJRS, carrega mas informa que não há certificado.

Alguma luz? Abraços a todos, achando a solução publico todos os detalhes






Só uma observação colega, onde se lê: "Clique em procurar ou digite o caminho /usr/lib/libaetpkss.so.3, assinale "ok" e feche o navegador." eu setei para "/usr/lib/libeTPkcs11.so" conforme arquivo de texto localizado dentro da própria pasta sac_9.0.43_Debian_Ubuntu_Linux baixado da empresa SolutionNet (https://site.solutinet.com.br/2015/manuais/instaladores/%20ou%20direto:%20http://site.solutinet.com.br/2014/images/files/instaladores-e-manuais/sac_9.0.43_Debian_Ubuntu_Linux.zip) talvez seja essa uma forma de resolver os problemas dos outros companheiros, qua ainda não conseguiram. De onde tirei? https://diadialinux.wordpress.com/2015/12/22/usando-token-aladdin-azul-no-ubuntu-12-04-e-14-04-32-ou....



[25] Comentário enviado por mamp em 27/01/2017 - 14:52h

Atualizei o Java e Firefox estou acessando normalmente pelo linux. Jan2017
vou enviar copoias das telas quando possivel.


[26] Comentário enviado por d4nrc em 28/02/2017 - 21:24h

Obrigado pelo artigo, Marcos Moraes! Me ajudou muito aqui.
Uso habitualmente o Antergos e, infelizmente, não consegui rodar o tokenadmin nele. Dá erro na versão da ABI.
Por isso, agora no carnaval, instalei uma máquina virtual com o Ubuntu 14.04. Consegui instalar tudo. Acesso o e-cac perfeitamente.
Porém, na página do pje (tanto no tjmg quanto do cnj) ele verifica o sistema e dá tudo ok, mas na hora em que tento autenticar para fazer login, após digitar o PIN do token, dá o seguinte erro: "Não foi possível realizar a autenticação. Verifique se o cartão ou token estão conectados".
Como meu certificado é reconhecido no site da receita, o problema está no sistema do pje. Assim presumo. Mas a página de suporte do pje não cuida dessa situação.
Alguém me ajuda nisso?

[27] Comentário enviado por mamp em 01/03/2017 - 13:20h


[26] Comentário enviado por d4nrc em 28/02/2017 - 21:24h

Obrigado pelo artigo, Marcos Moraes! Me ajudou muito aqui.
Uso habitualmente o Antergos e, infelizmente, não consegui rodar o tokenadmin nele. Dá erro na versão da ABI.
Por isso, agora no carnaval, instalei uma máquina virtual com o Ubuntu 14.04. Consegui instalar tudo. Acesso o e-cac perfeitamente.
Porém, na página do pje (tanto no tjmg quanto do cnj) ele verifica o sistema e dá tudo ok, mas na hora em que tento autenticar para fazer login, após digitar o PIN do token, dá o seguinte erro: "Não foi possível realizar a autenticação. Verifique se o cartão ou token estão conectados".
Como meu certificado é reconhecido no site da receita, o problema está no sistema do pje. Assim presumo. Mas a página de suporte do pje não cuida dessa situação.
Alguém me ajuda nisso?


Sim claro, eu tive mesmo problema.
Acredto que resolve atualizando a cadeia de certificados dentro da ITI.gov.br

Mas se quiser maior detalhamento veja em
http://piresdemoraesadv.blogspot.com.br/2016/10/pje-e-direito-digital-configurando.html

no artigo que montei V3 que ultima, consta item somente sobre isto. Veja atualizando certificados.


[28] Comentário enviado por mamp em 01/03/2017 - 13:27h

Para contribuir mais de forma mais atualizada, montei um blog com noticias e comentarios mais recentes sobre PJE e Linux e PJE

http://piresdemoraesadv.blogspot.com.br/2016/10/pje-e-direito-digital-configurando.html

[29] Comentário enviado por mamp em 15/03/2017 - 11:43h


bendjouya vi agora seu comentario. vou tentar responder.
1. "Quando tu fala pra instalar as cadeias, é todas?" que forem possiveis. Eu instalo da VALID (inclusive juridica) e todos do certificado, no meu caso Certisign e Valid. Mas todas, da trabalho.

2. "Nas outras tentativas eu chegava até o PIN e depois dizia que tinha problemas." é por causa das constantes atualizações da cadeias de certificados. Faco que sugeri no item.
3. "Não consegui nenhum suporte ao acesso por linux de nenhuma entidade que usa o pje, como conseguiu?" - Não tem, mas eu uso o que descrevi no blog http://piresdemoraesadv.blogspot.com.br/2017/02/pj-e-e-codigo-aberto-lei-11.html
4. "gostaria de contribuir com o refinamento do artigo quando estiver 100%". sim estou aberto a versao atual V3 e deixei no meu site
http://piresdemoraesadv.blogspot.com.br/2016/10/pje-e-direito-digital-configurando.html
5."Sou de TI com especialização em Direito, tenho uma empresa que atende vários advogados com linux" estou disposicao para contruibuir. mande email para conversarmos mais mamp@piresdemoraes.com

[9] Comentário enviado por bendjouya em 19/09/2016 - 15:42h

Estou fazendo tentativas desde o ano passado, logo vou testar desta forma, mas tem uns poréns:

Quando tu fala pra instalar as cadeias, é todas? pois são muitas.

Nas outras tentativas eu chegava até o PIN e depois dizia que tinha problemas.

Não consegui nenhum suporte ao acesso por linux de nenhuma entidade que usa o pje, como conseguiu? gostaria de contribuir com o refinamento do artigo quando estiver 100%.

Sou de TI com especialização em Direito, tenho uma empresa que atende vários advogados com linux, mas o PJE, STJ e STF são um problema.

Obrigado pelo artigo



[30] Comentário enviado por mamp em 15/03/2017 - 11:44h

Uso Valid e Certisign. E os que uso e são os convênios da OAB


[2] Comentário enviado por Mc.Eagle em 15/09/2016 - 23:07h

De qual certificados estamos falando? GD Starting? SafeNet? Qual Certificadora?



[31] Comentário enviado por mamp em 15/03/2017 - 11:45h

Perdão, sou do direito agora, com crise de TI. Afinal trabalhei muito antes.



[5] Comentário enviado por erisrjr em 16/09/2016 - 13:23h

Legal o artigo.

*Bacana ver alguem de TI atuando tambem com direito.

------------------------------------------------------
KISS principle, RTFM and STFW = 42



[32] Comentário enviado por mamp em 15/03/2017 - 11:48h

Ja que tem 6 meses que solicitei a criação da comunidade e nunca foi respondido, eu criei blog e podem participar.

http://piresdemoraesadv.blogspot.com.br/2016/10/pje-e-direito-digital-configurando.html



[16] Comentário enviado por mamp em 01/11/2016 - 11:56h

Pedi autorização ao administrador para criar comunidade Pje.
Caso aprovado posso inserir quem tiver participado aqui neste artigo?



[33] Comentário enviado por mamp em 15/03/2017 - 11:50h

Olha atualiza a cadeia de certificados. Tem que fazer forma constante, em março 2017 houve atulizacao.
e de forma especifica meu artigo atual trata-se disto
http://piresdemoraesadv.blogspot.com.br/2016/10/pje-e-direito-digital-configurando.html


[18] Comentário enviado por bendjouya em 10/11/2016 - 00:48h

Ainda estamos com problemas no TRT4 e TJRS nenhum desses funciona em nenhuma situação;

TRT4(PJe), vai até onde pede o PIN do Token e depois só fica "Aguardando a inicialização do certificado digital";
TJRS, carrega mas informa que não há certificado.

Alguma luz? Abraços a todos, achando a solução publico todos os detalhes




[34] Comentário enviado por mamp em 15/03/2017 - 11:52h

Rafael estou usando regularmente no Ubuntu. veja
ultima versao do meu artigo, e atualize a cadeia de certificados. Faca sempre que der bloqueio

http://piresdemoraesadv.blogspot.com.br/2016/10/pje-e-direito-digital-configurando.html


[19] Comentário enviado por RafaelMatos em 05/12/2016 - 22:16h

Fiz tudo aí, foi o site que mais gostei, porém ao tentar utilizar no TJMG o assinador não carregou, a tela do firefox escureceu. Disse ainda que o plugin do java travou. Alguém pode ajudar?
Obrigado



[35] Comentário enviado por mamp em 15/03/2017 - 11:57h


Tentei mas nao consegui. Se conseguir me avise, que tento refazer.
Estou tentando configurar agora no Fedora, minha distribuição favor
favorita

[23] Comentário enviado por Mc.Eagle em 09/01/2017 - 00:41h


[21] Comentário enviado por mamp em 06/12/2016 - 09:47h


[18] Comentário enviado por bendjouya em 10/11/2016 - 00:48h

Ainda estamos com problemas no TRT4 e TJRS nenhum desses funciona em nenhuma situação;
bendjouya, depois que houve mudanca da cadeia de certificados pela ITI, ideal e ir la ITI e baixar a cadeia de certificados mais recentes e validas. confere la. Ja reportei ao suporte da ITI e CNJ sobre a mudanca de cadeia de certificados e dos problemas.

TRT4(PJe), vai até onde pede o PIN do Token e depois só fica "Aguardando a inicialização do certificado digital";
TJRS, carrega mas informa que não há certificado.

Alguma luz? Abraços a todos, achando a solução publico todos os detalhes






Só uma observação colega, onde se lê: "Clique em procurar ou digite o caminho /usr/lib/libaetpkss.so.3, assinale "ok" e feche o navegador." eu setei para "/usr/lib/libeTPkcs11.so" conforme arquivo de texto localizado dentro da própria pasta sac_9.0.43_Debian_Ubuntu_Linux baixado da empresa SolutionNet (https://site.solutinet.com.br/2015/manuais/instaladores/%20ou%20direto:%20http://site.solutinet.com.br/2014/images/files/instaladores-e-manuais/sac_9.0.43_Debian_Ubuntu_Linux.zip) talvez seja essa uma forma de resolver os problemas dos outros companheiros, qua ainda não conseguiram. De onde tirei? https://diadialinux.wordpress.com/2015/12/22/usando-token-aladdin-azul-no-ubuntu-12-04-e-14-04-32-ou....



[36] Comentário enviado por mamp em 26/04/2017 - 12:17h

Acabei de receber confirmação da criação da Comunidade PJe-Linux.
Agora temos um espaço especifico para debates.
https://www.vivaolinux.com.br/comunidade/PJe/

[37] Comentário enviado por Francisco Ortiz em 09/06/2017 - 18:17h

Olá Marcos! Muito obrigado pelas informações detalhadas.

Embora sua mensagem seja para o PJe creio que serão um guia precioso para a instalação de Ecnpj que pretendo obter na Valid. Eu entrei em contato com o pessoal da Valid e os mesmos me disseram que os pacotes do Ecnpj eram para Ubuntu versão 12.04. Expliquei para eles que o 12.04 não era mais suportado. Eles te passaram alguma informação similar quando voce adquiriu seu PJe? Como você procedeu? Comprou o produto na raça e depois resolveu as dores de cabeça ou já tinha mais ou menos um roteiro?

Muito Obrigado!

Francisco

[38] Comentário enviado por mamp em 15/06/2017 - 13:26h

Caro Francisco Ortiz,
Sim a Valid parou no suporte Ubuntu 12.04, mas todas as versões seguintes melhorou muito mais o suporte a assinatura digital. Não vale a pena usar esta versao. Pode usar a nova mesmo, esta bem melhor.

Atualmente uso: Description: Ubuntu 17.04 Release: 17.04 Codename: zesty

Pje (Processo Eletronico). Eu nao adquiri Pje eu adquiri dois certificados digitais (Certsign e Valid).
Ambos deixei funcional no Linux e rodam no Pje, Receita Federal e sites que exigem certificado eletronico.
Como procedi
lei melhor no meu blog que esta ultima versao do artigo mais atualizado
http://piresdemoraesadv.blogspot.com.br/2016/10/pje-e-direito-digital-configurando.html
Foi na raca e escrevi o artigo na raca....olhe la.
E no blog pode mandar recedo, dicas e sugestao de pauta que eu pesquiso e escrevo.


[39] Comentário enviado por Francisco Ortiz em 25/06/2017 - 17:24h

Muitíssimo Obrigado @Mamp!

Bati o martelo aqui e adquiri o eCNPJ modelo A3 na Valid ("Token" / pen drive di mierda). A instalação em Win 7 + Chrome foi automática para mim, mas detesto ter de depender do Windows.

Bora pra partição Linux fazer este treco rodar no lugar certo. Assim que tiver tempo e conseguir volto a postar aqui.
Já li o manual da Valid com mais atenção e nele está escrito que o eCNPJ funciona no Ubuntu 12.04 OU SUPERIOR, coisa que o pessoal do atendimento digital não havia mencionado. Vou ver se descubro se é verdade para o meu caso o que tá neste manual ;)

Eu sou mais conservador que você, ainda estou no Ubuntu 14.04. Enfim... Assim que der certo aqui eu volto a postar. Mais uma vez desculpe o aspecto offtopic de minhas postagens. Muito obrigado mesmo por sua atenção.

[40] Comentário enviado por oscarcosta em 08/10/2017 - 10:53h

Para o pessoal que esta com dificuldades de instalar no certificado A3 no Fedora, eu consegui utilizando o pacote para centOS. Os detalhes estão no meu blog:
http://blog.openarch.com.br/2017/09/21/certificado-digital-a3-token-gd-starsign-no-fedora-26/

Espero ajudar, e qualquer dúvida pode me contactar! :)

[41] Comentário enviado por geovanafl@outloo em 09/10/2017 - 14:00h

o meu token é o feitian (epass2003 castle)
não estou conseguindo instalar o drive do token

geovana@geovana-Inspiron-N5010:~/Área de Trabalho/ePass2003-Castle-20141128/i386
/config$ sudo -s
root@geovana-Inspiron-N5010:~/Área de Trabalho/ePass2003-Castle-20141128/i386/co
nfig# ./config.sh
Service udev restarted!
run finished!
root@geovana-Inspiron-N5010:~/Área de Trabalho/ePass2003-Castle-20141128/i386/co
nfig# make
make: *** Nenhum alvo indicado e nenhum arquivo make encontrado. Pare.

[42] Comentário enviado por juaor em 10/05/2018 - 10:28h

Certificado Digital para o Ubuntu 18.04 LTS, inclusive e-Saj, consegui por esse link: https://ubuntuforum-pt.org/index.php?topic=123004.msg675398#msg675398

[43] Comentário enviado por inesambrosioadv em 23/06/2019 - 20:09h

Finalmente, 22/06/2019, consegui logar no PJe (TRF3, 2ª instância) e E-saj utilizando o certificado digital OAB SP A3, navegadores Chrome e Firefox

Primeiro, quero agradecer todas as informações. Valeu muito!!

E agora deixar aqui o caminho que segui para conseguir utilizar o processo eletrônico (site PJe e site E-saj) com o certificado digital (advogados)

O que eu tenho comigo?
Ubuntu 18.04.2 LTS;
Sistema de 64 bits;
Chrome Versão 75.0.3770.100 (Versão oficial) 64 bits
Firefox Quantum 67.0.3 (64-bits)
Token GD - Giesecke & Devrient Starsign* Crypto USB

Depois de ter problemas e formatar o computador, pesquisei várias fontes (que vou indicando abaixo) e segui alguns dos procedimentos:

PREPARAÇÃO: a) dentro da pasta Downloads, criei uma subpasta para salvar os pacotes baixados; b) no terminal, entrei como usuário root (sudo su); verifiquei atualizações (apt-get update) e upgrades (apt-get upgrade)

***1ª Fonte-Guicolândia: http://www.guicolandia.net/peticionamento-eletronico-no-ubuntu-18-04.html

1.1. Criei grupo "scard"

sudo addgroup scard

1.2. Adicionei meu usuário ao grupo

sudo adduser "seu-usuário" scard

1.3. Instalei pacotes indicados por essa Fonte-Guicolândia

sudo apt install libengine-pkcs11-openssl libp11-3 libpcsc-perl libccid libpcsclite1 pcscd pcsc-tools libasedrive-usb opensc libssl1.0.0 openssl libopensc-openssl

1.4. Instalei nessa ordem as dependências específicas (as oferecidas pela Fonte-Guicolândia mesmo), via download, descompactação, etc.

libgdbm3
libwxbase2.8-0
libwxgtk2.8-0
Dependências da libwxgtk2.8-0:
libpng12-0
libjpeg62-turbo

1.5. Testei o token

pcsc_scan

1.6. Instalei o gerenciador criptográfico SafeSign fornecido pela Valid Certificadora, conforme indicação dessa 1ª Fonte-Guicolândia (safesignidentityclient_3.0.77-Ubuntu_amd64.deb)

a) mas o fiz via terminal: caminhei até a minha subspasta que criei em Downloads

b) para download: comando wget

para não dar erro, revirei o site da Valid até encontrar (https://www.validcertificadora.com.br/SafeSignLinux) os links do download, com o botão direito do mouse, copiei o endereço do link do pacote deb e montei o comando no terminal

sudo wget https://s3-sa-east-1.amazonaws.com/shared-www.validcertificadora.com.br/safesignidentityclient_3.0.7...

c) para instalação: comando dpkg -i

sudo dpkg -i safesignidentityclient_3.0.77-Ubuntu_amd64.deb

1.7. Linkei o token com o Firefox

a) abri o administrador de token, que reconheceu meu certificado digital
b) cliquei em integração
c) segui os passos do programa

***2ª Fonte: https://esaj.tjsp.jus.br/petpg/abrirVerificacaoRequisitosPet.do

2.1. na verificação de requisitos do e-saj, logo recomendou a instalação do plug-in "Web Signer", que foi feita clicando lá mesmo e direcionando para o endereço da softplan

(https://websigner.softplan.com.br/Setup?brand=&jslib=&browser=Chrome&returnUrl=)

no e-saj, então, problema resolvido

****3ª Fonte: http://www.pje.jus.br/wiki/index.php/PJeOffice#PJeOffice_no_Linux

3.1. Baixei via terminal o programa PJeOficial (tenho rodando o Ubuntu, mas arrisquei instalar o pacote deb para Debian 64 bits)

sudo wget http://ftp.pje.jus.br/pje/programs/pje-office/pje-office_amd64.deb

3.2. Instalei o pacote pelo terminal

sudo dpkg -i pje-office_amd64.deb

3.3. cf. orientação na mesma página mais em baixo, no subtítulo "PJeOffice no Linux", pelo terminal, executei o comando

./pjeOffice.sh &


OBS: a) feito isso, notei que acessando o site do PJe e tentando logar com certificado digital, o programa PJeOffice não inicializava, ou seja, não fazia a ponte entre o site PJe e o meu certificado digital

b) foi aí que percebi que executando esse arquivo "pjeOffice.sh" no terminal através daquele comando (./pjeOffice.sh &), e acessando o site PJe logo em seguida, era possível fazer essa ponte

c) daí que surgiu outro problema: meu certificado digital não estava sendo reconhecido pelo PJeOffice

***4ª Fonte: http://www.pje.jus.br/wiki/index.php/Configura%C3%A7%C3%A3o_do_Ambiente#Observa.C3.A7.C3.B5es_para_L...

4.1. cf. orientação dessa página, mais embaixo, no subtítulo "Observações para Linux e Mac OS X", é necessário criar na pasta home/"usuário" uma subpasta ".pje", e dentro dela criar um arquivo de texto com nome "pkcs11.conf"

esse arquivo de texto deve conter:

library=<caminho_do_driver>/<nome_do_driver_pkcs11>

name=PersonalProvider


****5ª Fonte-Viva o Linux: https://www.vivaolinux.com.br/dica/Fazendo-o-Processo-Judicial-Eletronico-PJe-funcionar-no-Linux/

5.1. pesquisando no google que driver seria esse "pkcs11", encontrei essa 5ª Fonte-Viva o Linux, exemplificando como fazer e preencher esser arquivo de texto, que então criei com o driver "libaetpkss.so.3.0.2528"

5.2. o PJeOffice ainda não conseguia reconhecer meu certificado digital, então lendo um pouco mais, segui o link indicado no comentário nº 7 da mesma página

****6ª Fonte: http://www.pje.jus.br/wiki/index.php/Desenvolvedor#Ubuntu_64_bits

segui totalmente esses procedimentos:

6.1. "Roteiro para Instalação do Java (Sistema Linux 64 bits)" (NÃO SEI SE IRIA AJUDAR EM ALGUMA COISA, MAS FIZ)

6.2. "Roteiro para Instalação e Configuração do Cliente para Certificados Digitais"

6.2.1. "Ubuntu 64 bits"

****Por fim, inconformada por ter que abrir o terminal e executar aquele comando ./pjeOffice.sh & (3.3.) sempre que fosse usar o PJe, comecei a pesquisar sobre system tray e desisti.

Mas reinstalando os programas que eu costumava utilizar, vi por acaso no "Software Ubuntu" que o computador já tinha um programa: "aplicativos iniciais de sessão"

Abrindo esse programa, o PJeOffice estava lá, mas não inicializava sozinho

Nas configurações, ele apontava para um caminho e arquivo que deu erro quando testei no nautilus

Então, arrisquei substituir pelo caminho e arquivo "pjeOffice.sh" do item 3.3.

Foi então que ele começou a funcionar sozinho, sem eu ter que executar no terminal

Agora basta para mim entrar no site do PJe, clicar para logar com certificado digital, que o resto acontece, tanto no Firefox quanto no Chrome

Apenas no Firefox ele me pede para escolher o certificado antes de digitar o PIN.

Boa sorte para todos!

Inês Ambrósio


[44] Comentário enviado por mamp em 24/06/2019 - 12:46h

Pelo que vi é resumo do meu artigo publicao 2017.
e conteudo acima.
Que bom que esta replicando o mesmo conteudo.
Informo que ja estou usando Ubuntu 19.10 e fazendo atualizacao com scripts de comando automatizando.
Se nao for o servico de advocacia com prazos e obrigacoes, volto a publicar as atualizacoes.



[43] Comentário enviado por inesambrosioadv em 23/06/2019 - 20:09h

Finalmente, 22/06/2019, consegui logar no PJe (TRF3, 2ª instância) e E-saj utilizando o certificado digital OAB SP A3, navegadores Chrome e Firefox

Primeiro, quero agradecer todas as informações. Valeu muito!!

E agora deixar aqui o caminho que segui para conseguir utilizar o processo eletrônico (site PJe e site E-saj) com o certificado digital (advogados)

O que eu tenho comigo?
Ubuntu 18.04.2 LTS;
Sistema de 64 bits;
Chrome Versão 75.0.3770.100 (Versão oficial) 64 bits
Firefox Quantum 67.0.3 (64-bits)
Token GD - Giesecke &amp; Devrient Starsign* Crypto USB

Depois de ter problemas e formatar o computador, pesquisei várias fontes (que vou indicando abaixo) e segui alguns dos procedimentos:

PREPARAÇÃO: a) dentro da pasta Downloads, criei uma subpasta para salvar os pacotes baixados; b) no terminal, entrei como usuário root (sudo su); verifiquei atualizações (apt-get update) e upgrades (apt-get upgrade)

***1ª Fonte-Guicolândia: http://www.guicolandia.net/peticionamento-eletronico-no-ubuntu-18-04.html

1.1. Criei grupo "scard"

sudo addgroup scard

1.2. Adicionei meu usuário ao grupo

sudo adduser "seu-usuário" scard

1.3. Instalei pacotes indicados por essa Fonte-Guicolândia

sudo apt install libengine-pkcs11-openssl libp11-3 libpcsc-perl libccid libpcsclite1 pcscd pcsc-tools libasedrive-usb opensc libssl1.0.0 openssl libopensc-openssl

1.4. Instalei nessa ordem as dependências específicas (as oferecidas pela Fonte-Guicolândia mesmo), via download, descompactação, etc.

libgdbm3
libwxbase2.8-0
libwxgtk2.8-0
Dependências da libwxgtk2.8-0:
libpng12-0
libjpeg62-turbo

1.5. Testei o token

pcsc_scan

1.6. Instalei o gerenciador criptográfico SafeSign fornecido pela Valid Certificadora, conforme indicação dessa 1ª Fonte-Guicolândia (safesignidentityclient_3.0.77-Ubuntu_amd64.deb)

a) mas o fiz via terminal: caminhei até a minha subspasta que criei em Downloads

b) para download: comando wget

para não dar erro, revirei o site da Valid até encontrar (https://www.validcertificadora.com.br/SafeSignLinux) os links do download, com o botão direito do mouse, copiei o endereço do link do pacote deb e montei o comando no terminal

sudo wget https://s3-sa-east-1.amazonaws.com/shared-www.validcertificadora.com.br/safesignidentityclient_3.0.7....

c) para instalação: comando dpkg -i

sudo dpkg -i safesignidentityclient_3.0.77-Ubuntu_amd64.deb

1.7. Linkei o token com o Firefox

a) abri o administrador de token, que reconheceu meu certificado digital
b) cliquei em integração
c) segui os passos do programa

***2ª Fonte: https://esaj.tjsp.jus.br/petpg/abrirVerificacaoRequisitosPet.do

2.1. na verificação de requisitos do e-saj, logo recomendou a instalação do plug-in "Web Signer", que foi feita clicando lá mesmo e direcionando para o endereço da softplan

(https://websigner.softplan.com.br/Setup?brand=&amp;jslib=&amp;browser=Chrome&amp;returnUrl=)

no e-saj, então, problema resolvido

****3ª Fonte: http://www.pje.jus.br/wiki/index.php/PJeOffice#PJeOffice_no_Linux

3.1. Baixei via terminal o programa PJeOficial (tenho rodando o Ubuntu, mas arrisquei instalar o pacote deb para Debian 64 bits)

sudo wget http://ftp.pje.jus.br/pje/programs/pje-office/pje-office_amd64.deb

3.2. Instalei o pacote pelo terminal

sudo dpkg -i pje-office_amd64.deb

3.3. cf. orientação na mesma página mais em baixo, no subtítulo "PJeOffice no Linux", pelo terminal, executei o comando

./pjeOffice.sh &amp;


OBS: a) feito isso, notei que acessando o site do PJe e tentando logar com certificado digital, o programa PJeOffice não inicializava, ou seja, não fazia a ponte entre o site PJe e o meu certificado digital

b) foi aí que percebi que executando esse arquivo "pjeOffice.sh" no terminal através daquele comando (./pjeOffice.sh &amp;), e acessando o site PJe logo em seguida, era possível fazer essa ponte

c) daí que surgiu outro problema: meu certificado digital não estava sendo reconhecido pelo PJeOffice

***4ª Fonte: http://www.pje.jus.br/wiki/index.php/Configura%C3%A7%C3%A3o_do_Ambiente#Observa.C3.A7.C3.B5es_para_L....

4.1. cf. orientação dessa página, mais embaixo, no subtítulo "Observações para Linux e Mac OS X", é necessário criar na pasta home/"usuário" uma subpasta ".pje", e dentro dela criar um arquivo de texto com nome "pkcs11.conf"

esse arquivo de texto deve conter:

library=&lt;caminho_do_driver&gt;/&lt;nome_do_driver_pkcs11&gt;

name=PersonalProvider


****5ª Fonte-Viva o Linux: https://www.vivaolinux.com.br/dica/Fazendo-o-Processo-Judicial-Eletronico-PJe-funcionar-no-Linux/

5.1. pesquisando no google que driver seria esse "pkcs11", encontrei essa 5ª Fonte-Viva o Linux, exemplificando como fazer e preencher esser arquivo de texto, que então criei com o driver "libaetpkss.so.3.0.2528"

5.2. o PJeOffice ainda não conseguia reconhecer meu certificado digital, então lendo um pouco mais, segui o link indicado no comentário nº 7 da mesma página

****6ª Fonte: http://www.pje.jus.br/wiki/index.php/Desenvolvedor#Ubuntu_64_bits

segui totalmente esses procedimentos:

6.1. "Roteiro para Instalação do Java (Sistema Linux 64 bits)" (NÃO SEI SE IRIA AJUDAR EM ALGUMA COISA, MAS FIZ)

6.2. "Roteiro para Instalação e Configuração do Cliente para Certificados Digitais"

6.2.1. "Ubuntu 64 bits"

****Por fim, inconformada por ter que abrir o terminal e executar aquele comando ./pjeOffice.sh &amp; (3.3.) sempre que fosse usar o PJe, comecei a pesquisar sobre system tray e desisti.

Mas reinstalando os programas que eu costumava utilizar, vi por acaso no "Software Ubuntu" que o computador já tinha um programa: "aplicativos iniciais de sessão"

Abrindo esse programa, o PJeOffice estava lá, mas não inicializava sozinho

Nas configurações, ele apontava para um caminho e arquivo que deu erro quando testei no nautilus

Então, arrisquei substituir pelo caminho e arquivo "pjeOffice.sh" do item 3.3.

Foi então que ele começou a funcionar sozinho, sem eu ter que executar no terminal

Agora basta para mim entrar no site do PJe, clicar para logar com certificado digital, que o resto acontece, tanto no Firefox quanto no Chrome

Apenas no Firefox ele me pede para escolher o certificado antes de digitar o PIN.

Boa sorte para todos!

Inês Ambrósio





[45] Comentário enviado por mamp em 24/06/2019 - 12:47h

Quem quiser todo conteudo completo e detalhado basta ir no link
http://www.pje.blog.br/2016/10/pje-e-direito-digital-configurando.html


[46] Comentário enviado por mamp em 28/06/2019 - 12:08h

Novidade Jun2019 - Ubuntu 19 e Valid versão 03
As versoes novas da Valid pede para atualizar a biblioteca libgdbm3
Estou usando Ubuntu 19.04 com novo cliente de assinatura do TOken da Valid versao 03
Mas o Pjeoffice nao esta estavel com esta nova versao da Valid. Deveremos ter novas correcoes.


[47] Comentário enviado por mamp em 02/09/2019 - 17:13h

Acabei de reinstalar novamente UBUNTU 19 e refiz usando meu proprio artigo, com uma poucos atualizacoes conseguir com sucesso instalar PJE e PJEoffice que agora e obrigatorio.
TAmbem consegui SHADO.

Ja enviei o artigo para moderador como fazer PJEOffice publicar, feito coloco no meu blog tambem.
Consegui poucas linhas mas com muito esforco. Mas deu certo.

[48] Comentário enviado por mamp em 02/09/2019 - 17:14h


[44] Comentário enviado por mamp em 24/06/2019 - 12:46h

Pelo que vi é resumo do meu artigo publicao 2017.
e conteudo acima.
Que bom que esta replicando o mesmo conteudo.
Informo que ja estou usando Ubuntu 19.10 e fazendo atualizacao com scripts de comando automatizando.
Se nao for o servico de advocacia com prazos e obrigacoes, volto a publicar as atualizacoes.



[43] Comentário enviado por inesambrosioadv em 23/06/2019 - 20:09h

Finalmente, 22/06/2019, consegui logar no PJe (TRF3, 2ª instância) e E-saj utilizando o certificado digital OAB SP A3, navegadores Chrome e Firefox

Primeiro, quero agradecer todas as informações. Valeu muito!!

E agora deixar aqui o caminho que segui para conseguir utilizar o processo eletrônico (site PJe e site E-saj) com o certificado digital (advogados)

O que eu tenho comigo?
Ubuntu 18.04.2 LTS;
Sistema de 64 bits;
Chrome Versão 75.0.3770.100 (Versão oficial) 64 bits
Firefox Quantum 67.0.3 (64-bits)
Token GD - Giesecke &amp;amp; Devrient Starsign* Crypto USB

Depois de ter problemas e formatar o computador, pesquisei várias fontes (que vou indicando abaixo) e segui alguns dos procedimentos:

PREPARAÇÃO: a) dentro da pasta Downloads, criei uma subpasta para salvar os pacotes baixados; b) no terminal, entrei como usuário root (sudo su); verifiquei atualizações (apt-get update) e upgrades (apt-get upgrade)

***1ª Fonte-Guicolândia: http://www.guicolandia.net/peticionamento-eletronico-no-ubuntu-18-04.html

1.1. Criei grupo "scard"

sudo addgroup scard

1.2. Adicionei meu usuário ao grupo

sudo adduser "seu-usuário" scard

1.3. Instalei pacotes indicados por essa Fonte-Guicolândia

sudo apt install libengine-pkcs11-openssl libp11-3 libpcsc-perl libccid libpcsclite1 pcscd pcsc-tools libasedrive-usb opensc libssl1.0.0 openssl libopensc-openssl

1.4. Instalei nessa ordem as dependências específicas (as oferecidas pela Fonte-Guicolândia mesmo), via download, descompactação, etc.

libgdbm3
libwxbase2.8-0
libwxgtk2.8-0
Dependências da libwxgtk2.8-0:
libpng12-0
libjpeg62-turbo

1.5. Testei o token

pcsc_scan

1.6. Instalei o gerenciador criptográfico SafeSign fornecido pela Valid Certificadora, conforme indicação dessa 1ª Fonte-Guicolândia (safesignidentityclient_3.0.77-Ubuntu_amd64.deb)

a) mas o fiz via terminal: caminhei até a minha subspasta que criei em Downloads

b) para download: comando wget

para não dar erro, revirei o site da Valid até encontrar (https://www.validcertificadora.com.br/SafeSignLinux) os links do download, com o botão direito do mouse, copiei o endereço do link do pacote deb e montei o comando no terminal

sudo wget https://s3-sa-east-1.amazonaws.com/shared-www.validcertificadora.com.br/safesignidentityclient_3.0.7....

c) para instalação: comando dpkg -i

sudo dpkg -i safesignidentityclient_3.0.77-Ubuntu_amd64.deb

1.7. Linkei o token com o Firefox

a) abri o administrador de token, que reconheceu meu certificado digital
b) cliquei em integração
c) segui os passos do programa

***2ª Fonte: https://esaj.tjsp.jus.br/petpg/abrirVerificacaoRequisitosPet.do

2.1. na verificação de requisitos do e-saj, logo recomendou a instalação do plug-in "Web Signer", que foi feita clicando lá mesmo e direcionando para o endereço da softplan

(https://websigner.softplan.com.br/Setup?brand=&amp;amp;jslib=&amp;amp;browser=Chrome&amp;amp;returnUrl=)

no e-saj, então, problema resolvido

****3ª Fonte: http://www.pje.jus.br/wiki/index.php/PJeOffice#PJeOffice_no_Linux

3.1. Baixei via terminal o programa PJeOficial (tenho rodando o Ubuntu, mas arrisquei instalar o pacote deb para Debian 64 bits)

sudo wget http://ftp.pje.jus.br/pje/programs/pje-office/pje-office_amd64.deb

3.2. Instalei o pacote pelo terminal

sudo dpkg -i pje-office_amd64.deb

3.3. cf. orientação na mesma página mais em baixo, no subtítulo "PJeOffice no Linux", pelo terminal, executei o comando

./pjeOffice.sh &amp;amp;


OBS: a) feito isso, notei que acessando o site do PJe e tentando logar com certificado digital, o programa PJeOffice não inicializava, ou seja, não fazia a ponte entre o site PJe e o meu certificado digital

b) foi aí que percebi que executando esse arquivo "pjeOffice.sh" no terminal através daquele comando (./pjeOffice.sh &amp;amp;), e acessando o site PJe logo em seguida, era possível fazer essa ponte

c) daí que surgiu outro problema: meu certificado digital não estava sendo reconhecido pelo PJeOffice

***4ª Fonte: http://www.pje.jus.br/wiki/index.php/Configura%C3%A7%C3%A3o_do_Ambiente#Observa.C3.A7.C3.B5es_para_L....

4.1. cf. orientação dessa página, mais embaixo, no subtítulo "Observações para Linux e Mac OS X", é necessário criar na pasta home/"usuário" uma subpasta ".pje", e dentro dela criar um arquivo de texto com nome "pkcs11.conf"

esse arquivo de texto deve conter:

library=&amp;lt;caminho_do_driver&amp;gt;/&amp;lt;nome_do_driver_pkcs11&amp;gt;

name=PersonalProvider


****5ª Fonte-Viva o Linux: https://www.vivaolinux.com.br/dica/Fazendo-o-Processo-Judicial-Eletronico-PJe-funcionar-no-Linux/

5.1. pesquisando no google que driver seria esse "pkcs11", encontrei essa 5ª Fonte-Viva o Linux, exemplificando como fazer e preencher esser arquivo de texto, que então criei com o driver "libaetpkss.so.3.0.2528"

5.2. o PJeOffice ainda não conseguia reconhecer meu certificado digital, então lendo um pouco mais, segui o link indicado no comentário nº 7 da mesma página

****6ª Fonte: http://www.pje.jus.br/wiki/index.php/Desenvolvedor#Ubuntu_64_bits

segui totalmente esses procedimentos:

6.1. "Roteiro para Instalação do Java (Sistema Linux 64 bits)" (NÃO SEI SE IRIA AJUDAR EM ALGUMA COISA, MAS FIZ)

6.2. "Roteiro para Instalação e Configuração do Cliente para Certificados Digitais"

6.2.1. "Ubuntu 64 bits"

****Por fim, inconformada por ter que abrir o terminal e executar aquele comando ./pjeOffice.sh &amp;amp; (3.3.) sempre que fosse usar o PJe, comecei a pesquisar sobre system tray e desisti.

Mas reinstalando os programas que eu costumava utilizar, vi por acaso no "Software Ubuntu" que o computador já tinha um programa: "aplicativos iniciais de sessão"

Abrindo esse programa, o PJeOffice estava lá, mas não inicializava sozinho

Nas configurações, ele apontava para um caminho e arquivo que deu erro quando testei no nautilus

Então, arrisquei substituir pelo caminho e arquivo "pjeOffice.sh" do item 3.3.

Foi então que ele começou a funcionar sozinho, sem eu ter que executar no terminal

Agora basta para mim entrar no site do PJe, clicar para logar com certificado digital, que o resto acontece, tanto no Firefox quanto no Chrome

Apenas no Firefox ele me pede para escolher o certificado antes de digitar o PIN.

Boa sorte para todos!

Inês Ambrósio
Consegui resolver problema do PJoffice, instalar e funcionar, posto aqui quando moderador vivalinux liberar.







[49] Comentário enviado por mamp em 08/10/2019 - 09:52h

Para Atualização.
1. Este é o primeiro artigo com Ubuntu 16. Detalhado e passo a passo.
https://www.vivaolinux.com.br/artigo/Sou-advogado-e-consegui-instalar-Certificado-Digital-para-PJe/

Soltei
2. https://www.vivaolinux.com.br/artigo/Certificacao-Eletronica-no-Linux-para-PJe-Relato-de-minha-exper...

3. Soltei esta dica sobre Instalação do PjeOffice
https://www.vivaolinux.com.br/dica/PJEOffice-rodando-corretamente-no-Ubuntu-19-como-fazer-via-termin...

4, Se quiser tirar mais duvidas e curiosidades, montei blog
www.pje.blog.br
podem contribuir com sugestões e pautas. Tendo tempo eu escrevo.

Ps. Artigo mais detlhado sobre instalacao do PjeOffice para LInux foi aprovado em breve ser publicado.

[50] Comentário enviado por mamp em 14/10/2019 - 19:39h

Publicado o Artigo sobre instalação do PjeOffice para Linux como já havia dito:

http://www.pje.blog.br/2019/10/pjeoffice-instalando-no-linux-versao-de.html
ou
https://www.vivaolinux.com.br/artigo/Certificacao-Eletronica-no-Linux-para-PJe-Relato-de-minha-exper...



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts