Solução completa com o sendmail (segunda edição)

Quase 2 anos após ter escrito a primeira versão deste artigo, chegou a hora de rescrevê-lo com informações adicionais e atualizadas. Dentre seus recursos podemos citar o suporte a SMTP TLS e POP SSL (criptografado), antivírus, antiSPAM, autenticação SMTP e sistema de quota de usuário.

[ Hits: 74.516 ]

Por: João Paulo de Oliveira Faria em 24/08/2006 | Blog: http://www.jpfaria.com


Testando



Sem dar o boot, vamos iniciar todos os serviços e entendendo que nenhum serviço foi iniciado, daremos os seguintes comandos:

# /etc/rc.d/rc.saslauthd start
# /etc/rc.d/rc.spamd start
# /etc/rc.d/rc.clamav start
# /etc/rc.d/rc.sendmail start


Agora vamos usar o telnet na porta 25 e usar o EHLO para o servidor retornar todas as opções.

# telnet localhost 25

Tem que aparecer exatamente isso se você seguiu todas as minhas confs.:

Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 lua.solar ESMTP
EHLO localhost
250-lua.solar Hello localhost [127.0.0.1], pleased to meet you
250-ENHANCEDSTATUSCODES
250-PIPELINING
250-8BITMIME
250-SIZE 7168000
250-DSN
250-ETRN
250-STARTTLS
250-DELIVERBY
250 HELP

Vamos verificar o log do email também para verificar se não houve nenhum erro. Vou repetir que se você instalou seguindo todos os passos, você deverá ver isso aqui.

# tail /var/log/maillog

Dec 9 17:35:10 lua spamd[7609]: spamd starting
Dec 9 17:35:10 lua sm-mta[7621]: starting daemon (8.13.1): [email protected]:25:00
Dec 9 17:35:10 lua sm-msp-queue[7623]: starting daemon (8.13.1): [email protected]:25:00
Dec 9 17:35:12 lua spamd[7613]: server started on port 783/tcp (running version 3.0.1)
Dec 9 17:35:12 lua spamd[7613]: server successfully spawned child process, pid 7626
Dec 9 17:35:12 lua spamd[7613]: server successfully spawned child process, pid 7627
Dec 9 17:35:12 lua spamd[7613]: server successfully spawned child process, pid 7628
Dec 9 17:35:12 lua spamd[7613]: server successfully spawned child process, pid 7629
Dec 9 17:35:12 lua spamd[7613]: server successfully spawned child process, pid 7630

Verificar o log de mensagem do servidor:

# tail /var/log/messages

Dec 9 17:35:02 lua saslauthd[7527]: server_exit : master exited: 7527
Dec 9 17:35:06 lua saslauthd[7589]: detach_tty : master pid is: 7589
Dec 9 17:35:06 lua saslauthd[7589]: ipc_init : listening on socket: /var/state/saslauthd/mux

Página anterior     Próxima página

Páginas do artigo
   1. Introdução
   2. Cyrus-SASL2, saslauthd e Qpopper
   3. Clamav
   4. SpamAssassin
   5. Sendmail
   6. Usando os arquivos .db
   7. Colocando todos os recursos para iniciar automaticamente no servidor
   8. Testando
   9. Desabilitando o POP inseguro (porta 110)
   10. Quota de disco
Outros artigos deste autor

SpamAssassin no Sendmail usando o Procmail

Instalando e configurando um servidor DNS (Bind)

Instalando o AWSTATS no Slackware

Usando Spammer e SpamDomains no sendmail

Configurando a placa de som C-MEDIA (CM8738) no Slackware

Leitura recomendada

Servidor de email com SMTP, POP, IMAP, quota e MySQL

Instalação e configuração do Spamassassin

Enviando e-mail pelo shell com smtp remoto

Configurando o KMail

Bloqueando SPAM no Kmail com o SpamAssassin

  
Comentários
[1] Comentário enviado por jpfaria em 24/08/2006 - 19:56h

Alteração:
Os arquivos para ativação de quota no slackware mudaram!

# touch /aquota.user
# touch /aquota.group
# chmod 600 /aquota.user
# chmod 600 /aquota.group

[2] Comentário enviado por gr4ph1x em 25/08/2006 - 08:00h

mano, na hora que fui dar um boot aparece isso no sendmail

Starting sendmail MTA daemon: /usr/sbin/sendmail -L sm-mta -bd -q25m
WARNING: Xclmilter: local socket name /var/run/clamav/milter.sock missing
Starting sendmail MSP queue runner: /usr/sbin/sendmail -L sm-msp-queue -Ac -q25m

O que seria : WARNING: Xclmilter: local socket name /var/run/clamav/milter.sock missing ???

[3] Comentário enviado por gr4ph1x em 25/08/2006 - 09:33h

Ja arrumei aqui, era o local do socket que não estava correto

[4] Comentário enviado por jpfaria em 25/08/2006 - 09:35h

Eu ja estava aqui vendo o que podia ser!

[5] Comentário enviado por thelinux em 25/08/2006 - 11:21h

jpfaria,

Parabéns pelo artigo. Nota 10.

[6] Comentário enviado por wrlima em 27/08/2006 - 21:10h

Artigo é bom, porem o MTA sendmail já era... nada como Qmail ou Postfix.

Abs,

[7] Comentário enviado por fsoliveira em 28/08/2006 - 11:40h

fala paulinho !

nota 10.0 o artigo...

abraçao leki

Fred.

[8] Comentário enviado por gr4ph1x em 10/11/2006 - 15:56h

Mano

Tudo esta funcionando beleza aqui...

Só que quando configuro o Outlook fica aperecendo a msg:

"Uma cadeia de certificação foi processada, mas terminou em um certificado raiz que não é de confiança do fornecedor" Deseja continuar? Sim - Não

Tem como tirar esse aviso??

[9] Comentário enviado por metall em 04/12/2006 - 17:45h

Dai fio!! blz!!
seguinte Joao Paulo to com problema assim usei seus passos como caminho instalei isso no CL10 blz tudo funcionando certinho ate agora! soh um probleminha nao tem um lugar nem um o milter.sock e esta instaldo tudo certinho clamav!! o que poderia ser como faco pra resolver este problema!!
Abraco[] Velho!! Fico no Aguardo

[10] Comentário enviado por metall em 04/12/2006 - 18:07h

Boa Tarde foi instalar a autenticao em outro cliente hj usando o cl10 mesmo to com o seguinte problema segui suas instrucoes...
quando uso o database.sh me retorna isso
sh databese.sh
WARNING: World writable directory /etc
WARNING: World writable directory /etc
WARNING: World writable directory /etc
WARNING: World writable directory /etc
WARNING: World writable directory /etc
WARNING: World writable directory /etc

e quando vou usar o m4 me retorna isso tambem

m4 sendmail.mc > /etc/mail/sendmail.cf
*** WARNING: missing -T<TMPF> in argument of FEATURE(`access_db', hash -T /etc/mail/access)

poderia me dar uma mao eh urgente! tao me cobrando isso e nao consegui resolver
Abraco!!
Fico no Aguardo!!

[11] Comentário enviado por metall em 04/12/2006 - 21:51h

bom soh pra dar um parecer ai consegui resolver o problema nao sei q cargas dagua o etc tinha muda as permisao do diretorio! ai se tei para chmod 755 acabou todos os problemas!! funciono tudo tranquilo...

Pra quem tiver este problema! ta ai eh soh permisao usei
#chmod 755 /etc


Soh fiquei com o problema do milter.sock q nao tem nesta distribuicao Cl10 poderia me passar alguma possicao?
Abraco[]s

[12] Comentário enviado por metall em 21/12/2006 - 14:39h

Dai Bruxo do Sendmail!!
Seguinte velho nunca implemento o sendmail para usar o ip-reverso!
tipow ele soh aceita email quem tiver com ip-reverso configurado!
se nao ele recusa! como hj muito servidores! utilizao isso! tu nao sabe como implementa isso?

poderia passar uma dica algo assim se souber! ou ate mesmo da uma pesquisada!! ja q o senhor!! eh o Kara no Sendmail!!

Aquele Abraco!!
Fico No Aguardo!!

[13] Comentário enviado por makleod em 13/02/2008 - 15:45h

jpfaria,

como posso configurar o sendmail para enviar um aviso automatico que a senha do usuario esta expirando em X data?

[14] Comentário enviado por msinformatica em 22/03/2009 - 17:55h

tenho o slackware 12.1 instalado ja com os pacotes Sendmail sasl 8.13 , tenho o clamav e tenho o Cyrus-sals. Alguem poderia me ajudar ,como configurar a autenticacao smtp.

[15] Comentário enviado por adilsom em 29/10/2010 - 14:55h

ola, cinfigurei o sendmail com imap, e ja consigo enviar e receber email prfeitamente com a conta addfone que criei no linux.

So que queria ter outros email para o mesmo dominio "addfone.com.br"

ex:
[email protected]
[email protected]

tenho que adicionar cada usuario no linux, ou tem alguma outra forma.


e tambem nao consegui enviar email com a funçao MAIL do php.



obrigado


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts