Resolvendo problemas na rede do Slackware

Escrevi este artigo por notar que na internet havia uma grande quantidade de pessoas que tinham problemas com a rede local no Slackware. Passei pela mesma situação, porém descobri a solução. Neste artigo descreverei como fazer para que sua rede esteja sempre "on" após a reinicialização do sistema operacional.

[ Hits: 11.621 ]

Por: Thiago Teles em 13/08/2004


Introdução



Quantas pessoas não já configuraram seu Slackware, fizeram todas as configurações de rede e no instante em que reiniciam o computador, a rede simplesmente não se comunica com os demais computadores da rede local, muito menos com o roteador?

Aqui será então descrito a causa e a solução deste problema que vem dando dor de cabeça para muitos usuários desta versão. Comigo tive problemas com o Slackware 9, não sei quais outras versões tem esse mesmo problema.

Causa


Não sei bem ao certo o porque que isso acontece, porém quando você reinicia o seu Linux, ele faz a execução do inet1 e inet2 e sua rede fica aparentemente up, você pode constatar isso dando um "ifconfig", que mostrará que seu ip de rede está certo e especificado de maneira coerente.

Porém quando o boot é terminado, você se loga e nota que não tem respostas de ping de nenhum computador da rede. Vê também que o seu ip, gateway e servidores DNS estão especificados como sempre e ainda sim não funcionam.

Derrubar, depois dar up na rede também não resolve, especificar outro ip não acaba com o problema, então agora o próximo passo é solucionar isso.

Solução


Bom, a melhor solução que encontrei nesse caso foi derrubar a rede, primeiramente é necessário que você digite:

# ifconfig eth0 down

Feito isso, reinicialize sua máquina, espere a conclusão do boot, entre com seu usuário e senha e faça a tentativa de pingar em algum PC. O que você vai ver agora, se sua rede estiver perfeitamente configurada é que o seu computador recebe respostas.

Isso acontece porque quando o Slack inicia ele reconhece novamente tudo o que há na rede uma vez que a rede foi derrubada no processo feito antes do reboot.

Então o que fazer para que seus problemas acabem?
Adicione ao arquivo /etc/rc.d/rc.6 a seguinte linha:

/sbin/ifconfig eth0 down

Pronto agora sempre que você reinicializar seu Slack a rede será derrubada e reconhecida após o boot novamente.

   

Páginas do artigo
   1. Introdução
Outros artigos deste autor
Nenhum artigo encontrado.
Leitura recomendada

Incrementando o visual do KDE 4

Gerenciamento de pacotes RPM (parte 1)

Instalando o Beryl + Drivers NVIDIA no Ubuntu 6.10 (Edgy)

Instalando NSClient++ e NC_net

ALSA, Debian e Intel8x0

  
Comentários
[1] Comentário enviado por y2h4ck em 13/08/2004 - 10:40h

Podia ter dando uma expandida melhor no artigo neh ... abordando alguns pontos mais avançados.

Bom todo caso ... []s.

Fica a critica construtiva.

[2] Comentário enviado por flaviomm69 em 13/08/2004 - 12:56h

legal artigo, tbm tenho percebido que o pessal tem tido problemas com a rede do slack (eu sou um deles) eu estava tendo um problema parecido, o slack não reconhecia a configuração de rede especificada na inicialização do inet1, inet2, mesmo estando tudo em ordem, então eu pus o comando direto no rc.local e ele funcionou normalmente.




[3] Comentário enviado por lordello em 13/08/2004 - 17:52h

Eu nunca vi esse problema no Slackware...
Aliás, visto a a]falta de informações, acho que esse texto deveria apenas constar na área de dicas, o que me parece mais justo.
Talvez esse problema seja algo relacionado com a sua rede em específico, ou relacionado ao seu hardware, sei-lá, mas eu nunca, nunca vi isso acontecer mesmo... uso Slackware já tem uns anos..
Falou ae...

[4] Comentário enviado por LOMAX em 13/08/2004 - 18:00h

Bom, como foi visto anteriormente, algumas pessoas ja relataram nos forums e no meu proprio email que foi realmente constatado que este artigo ajudou na configuração da rede no slackware. Se esse não foi seu problema, ignore esses procedimentos.

agradeço.

Thiago Teles (LoMaX)
www.ircontro.net & irc.ircontro.net

[5] Comentário enviado por naoexistemais em 13/08/2004 - 21:53h

Eu tmb nunca vi esse problema, você deveria ter relatado a configuração do seu micro, dependendo pode ser problema de hardware, bug e etc..

Não foi claro esse artigo e faltou um pouco de conhecimento do problema.

sem mais,

[6] Comentário enviado por jeziel em 18/08/2004 - 17:44h

Trabalho com o Slackware desde a versão 7.0 e nunca vi isto acontecer, todas as vezes que uma rede que eu configurei não funcionou foi porque não configurei direito. E também o Slack derruba a rede ante de desligar.

[7] Comentário enviado por mnc em 19/08/2004 - 08:51h

Realmente poderia ser uma dica e não artigo... mas enfim.
Meu irmão teve problemas com a rede no slack 10, e o que ele tem feito até hoje é bootar no (argh) windows antes, e depois entrar no linux.
Até onde eu vi, é um problema específico das placas de rede onboard nforce (ele tem uma asus com nforce).
Vou passar pra ele a ideia de derrubar a interface antes do boot e ver se funciona. Se der certo, matamos a charada!

[8] Comentário enviado por chiiimera em 23/01/2009 - 09:16h

Cara, to com um problema muito parecido (mas muito mesmo) com o seu, porém no Kurumin.


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts