Nagios Core 4.0.8 com Debian 7 e Client Windows Server

Escrevo esse artigo para auxiliar os colegas na implementação de um servidor Nagios Core 4.0.8 com a finalidade de monitorar um ambiente de TI constituído por Servidores Linux, Windows, Impressoras, Switchs e qualquer outra coisa que contenha um IP.

[ Hits: 9.942 ]

Por: Erik Pinheiro em 01/10/2015


Instalação e Configuração do Client Windows Server



Chegamos ao final da configuração de monitoração de nosso ambiente, vamos agora configurar nosso servidor para "enxergar" nosso clientes Windows Server.

Atenção: no meu ambiente atual utilizo em todos os servidores o MS Windows Server 2008 R2. Não testei em outras versões.

Primeiramente, vamos definir uma senha para nossos clientes Windows, em seguida vamos modificar no servidor Nagios o arquivo d commands.cfg, conforme abaixo:

# 'check_local_disk' command definition
define command{
        command_name    check_local_disk
        command_line    $USER1$/check_disk -w $ARG1$ -c $ARG2$ -p $ARG3$ -s senha
        }

define command{
        command_name    check_nt
        command_line    $USER1$/check_nt -H $HOSTADDRESS$ -p 12489 -s senha -v $ARG1$ $ARG2$
        }

Vamos fazer agora o download do Client, acesse a página:
e faça o download correspondente a versão do seu sistema Windows (32 ou 64).

A instalação em si, não tem segredo, são os famosos Next, Next, Finish da MS.

Porém é necessário se atentar em clicar em Typical na terceira tela, colocarmos o IP do servidor Nagios, a senha que criamos acima na quarta tela e escolher as todas as opções de "Modules to load" na quarta tela.

Ao fim da instalação, verifique na serviços se o serviço NSClient está em execução.

Obs.: assegura-se que o firewall do Windows esteja configurado para permitir acesso na porta 12489.

Reinicie o Nagios:

# service nagios restart

Pronto, em alguns instantes o Nagios irá começar a monitorar nossos clientes Windows Server.

Página anterior    

Páginas do artigo
   1. Instalação
   2. Configuração do Servidor Nagios
   3. Instalação e Configuração do Client Windows Server
Outros artigos deste autor
Nenhum artigo encontrado.
Leitura recomendada

Configurando serviço DHCP (Debian)

Instalando Servidor RackTables para Documentação de Rede

IPv6, DNSv6 e DHCPv6

Redes de Computadores · IPtables · Endereços IPs - Explicações básicas

Conexão do Vindula com o Active Directory Server 2008 R2

  
Comentários
[1] Comentário enviado por xclaudin em 08/10/2015 - 16:43h


Cara você caiu como um anjo na minha vida UHASHUAUHSUHAS
Eu ia instalar o nagios 3.4.4 porque tenho um backup antigo aqui e tava com uma mega preguiça de atualizar, porque mudou muita coisa desde então,

Agora vou seguir seu artigo e instalar usando a versão mais nova!

Parabéns está ótimo o artigo.

Assim que estiver rodando posto meu feedback!

Muito obrigado!

[2] Comentário enviado por erikpinheiro em 09/10/2015 - 08:00h


[1] Comentário enviado por xclaudin em 08/10/2015 - 16:43h


Cara você caiu como um anjo na minha vida UHASHUAUHSUHAS
Eu ia instalar o nagios 3.4.4 porque tenho um backup antigo aqui e tava com uma mega preguiça de atualizar, porque mudou muita coisa desde então,

Agora vou seguir seu artigo e instalar usando a versão mais nova!

Parabéns está ótimo o artigo.

Assim que estiver rodando posto meu feedback!

Muito obrigado!


Obrigado,

Faça passo a passo que não tem como errar. Qualquer dúvida, só perguntar.

[3] Comentário enviado por xclaudin em 09/10/2015 - 12:45h


Brother, até agora deparei com um erro :

"root@DebianLinux:/usr/src/nagios-4.0.8# make install-webconf
/usr/bin/install -c -m 644 sample-config/httpd.conf /etc/httpd/conf.d/nagios.conf
/usr/bin/install: não foi possível criar arquivo comum “/etc/httpd/conf.d/nagios.conf”: Arquivo ou diretório não encontrado
Makefile:296: recipe for target 'install-webconf' failed
make: *** [install-webconf] Error 1
"

Porém to usando o Debian 8, com interface gráfica, no artigo vc usa o 7 pode ser o motivo do erro ?

[4] Comentário enviado por xclaudin em 09/10/2015 - 12:51h

Está com um erro na ortografia na hora de extrair os plugins
Baixamos o 2.1.1 e na hora de extrair você colocou 2.0.3


[5] Comentário enviado por xclaudin em 09/10/2015 - 12:53h


Após concluir tudo da primeira página, usando o Debian 8
Só tive aquele erro do Webconf e quando fui startar o Nagios

service nagios start = Failed to start nagios.service: Unit nagios.service failed to load: No such file or directory.

[6] Comentário enviado por erikpinheiro em 09/10/2015 - 12:59h


[3] Comentário enviado por xclaudin em 09/10/2015 - 12:45h


Brother, até agora deparei com um erro :

"root@DebianLinux:/usr/src/nagios-4.0.8# make install-webconf
/usr/bin/install -c -m 644 sample-config/httpd.conf /etc/httpd/conf.d/nagios.conf
/usr/bin/install: não foi possível criar arquivo comum “/etc/httpd/conf.d/nagios.conf”: Arquivo ou diretório não encontrado
Makefile:296: recipe for target 'install-webconf' failed
make: *** [install-webconf] Error 1
"

Porém to usando o Debian 8, com interface gráfica, no artigo vc usa o 7 pode ser o motivo do erro ?


Vi problemas semelhantes no Ubuntu, e segundo informações resolveu com esse comando:

# /usr/bin/install -c -m 644 sample-config/httpd.conf /etc/apache2/sites-enabled/nagios.conf

Sim, meu ambiente é Debian7, não testei no 8, veja se com esse comando vai...

[7] Comentário enviado por erikpinheiro em 09/10/2015 - 13:05h


[4] Comentário enviado por xclaudin em 09/10/2015 - 12:51h

Está com um erro na ortografia na hora de extrair os plugins
Baixamos o 2.1.1 e na hora de extrair você colocou 2.0.3



ops!!!
Obrigado pela correção!!

[8] Comentário enviado por erikpinheiro em 09/10/2015 - 13:06h


[5] Comentário enviado por xclaudin em 09/10/2015 - 12:53h


Após concluir tudo da primeira página, usando o Debian 8
Só tive aquele erro do Webconf e quando fui startar o Nagios

service nagios start = Failed to start nagios.service: Unit nagios.service failed to load: No such file or directory.


Use esse comando aqui: /usr/bin/install -c -m 644 sample-config/httpd.conf /etc/apache2/sites-enabled/nagios.conf
Faltou algo na compilação do Apache ai...

[9] Comentário enviado por xclaudin em 09/10/2015 - 15:12h

root@DebianLinux:/usr/src/nagios-4.0.8# /usr/bin/install -c -m 644 sample-config/httpd.conf /etc/apache2/sites-enabled/nagios.conf

root@DebianLinux:/usr/src/nagios-4.0.8# make install-webconf
/usr/bin/install: não foi possível criar arquivo comum “/etc/httpd/conf.d/nagios.conf”: Arquivo ou diretório não encontrado
Makefile:296: recipe for target 'install-webconf' failed
make: *** [install-webconf] Error 1
root@DebianLinux:/usr/src/nagios-4.0.8#

Rodei o comando q me passou ele não me retornou nada, ai rodei de novo o make install-webconf


e deu isso

[10] Comentário enviado por xclaudin em 09/10/2015 - 15:41h

Parece que deu certinho manolo!

Só que agora não to conseguindo acessar o Nagios

QNd coloco meu IP local/nagios no navegador ta caindo na pagina do Apache


[11] Comentário enviado por erikpinheiro em 09/10/2015 - 15:46h


[9] Comentário enviado por xclaudin em 09/10/2015 - 15:12h

root@DebianLinux:/usr/src/nagios-4.0.8# /usr/bin/install -c -m 644 sample-config/httpd.conf /etc/apache2/sites-enabled/nagios.conf

root@DebianLinux:/usr/src/nagios-4.0.8# make install-webconf
/usr/bin/install: não foi possível criar arquivo comum “/etc/httpd/conf.d/nagios.conf”: Arquivo ou diretório não encontrado
Makefile:296: recipe for target 'install-webconf' failed
make: *** [install-webconf] Error 1
root@DebianLinux:/usr/src/nagios-4.0.8#

Rodei o comando q me passou ele não me retornou nada, ai rodei de novo o make install-webconf


e deu isso


Veja se o arquivo nagios.conf ta lá:
#ls /etc/httpd/conf.d

[12] Comentário enviado por erikpinheiro em 09/10/2015 - 15:47h


[10] Comentário enviado por xclaudin em 09/10/2015 - 15:41h

Parece que deu certinho manolo!

Só que agora não to conseguindo acessar o Nagios

QNd coloco meu IP local/nagios no navegador ta caindo na pagina do Apache



Inicia o serviço do Nagios
#service nagios start

[13] Comentário enviado por xclaudin em 09/10/2015 - 16:09h


ls /etc/httpd/conf.d
ls: não é possível acessar /etc/httpd/conf.d: Arquivo ou diretório não encontrado
root@DebianLinux:/usr/src/nagios-4.0.8#


O arquivo não ta lá =/ pensei que tinha dado certo T_T


[14] Comentário enviado por erikpinheiro em 09/10/2015 - 16:21h


[13] Comentário enviado por xclaudin em 09/10/2015 - 16:09h


ls /etc/httpd/conf.d
ls: não é possível acessar /etc/httpd/conf.d: Arquivo ou diretório não encontrado
root@DebianLinux:/usr/src/nagios-4.0.8#


O arquivo não ta lá =/ pensei que tinha dado certo T_T



Cria na mão, veja se funciona:
OBS: Não estou testando aqui, vai testando e veja se funciona, acredito que o caminha seja esse...

# mkdir / etc / httpd
# mkdir /etc/httpd/conf.d
#vim /etc/httpd/conf.d/nagios.conf (Salve o arquivo em branco)
# make install-webconf


[15] Comentário enviado por xclaudin em 13/10/2015 - 08:30h


Criei manual como você falou e deu certo!

root@DebianLinux:/usr/src/nagios-4.0.8# make install-webconf
/usr/bin/install -c -m 644 sample-config/httpd.conf /etc/httpd/conf.d/nagios.conf

*** Nagios/Apache conf file installed ***

root@DebianLinux:/usr/src/nagios-4.0.8#


:D

vou prosseguir a instalação!

[16] Comentário enviado por xclaudin em 13/10/2015 - 08:35h


Parei nessa parte

root@DebianLinux:/usr/src/nagios-4.0.8# htpasswd /usr/local/nagios/etc/htpasswd.users nagiosadmin
htpasswd: cannot modify file /usr/local/nagios/etc/htpasswd.users; use '-c' to create it

Tentei dar permissão chmod 777 na pasta mas não resolveu,
O arquivo está em branco.

[17] Comentário enviado por xclaudin em 13/10/2015 - 11:21h


Mesmo assim acabei de fazer as outras configurações!

Só no final depois de configurar o arquivo objetos e servicos

fui restartar o nagios e deu isso:

root@DebianLinux:/usr/local/nagios/etc/objects# service nagios restart
Job for nagios.service failed. See 'systemctl status nagios.service' and 'journalctl -xn' for details.


To acabando aqui rs

[18] Comentário enviado por xclaudin em 13/10/2015 - 11:27h


Meu caro é isso! Os problemas que tive agora são só esses dois!

"root@DebianLinux:/usr/src/nagios-4.0.8# htpasswd /usr/local/nagios/etc/htpasswd.users nagiosadmin
htpasswd: cannot modify file /usr/local/nagios/etc/htpasswd.users; use '-c' to create it"

e esse que não sei se é um problema:

"root@DebianLinux:/usr/local/nagios/etc/objects# service nagios restart
Job for nagios.service failed. See 'systemctl status nagios.service' and 'journalctl -xn' for details."

Agora quando tento acessar o endereço http://192.168.6.10/nagios Ele me pede a senha, é User: nagios senha: nagios ?

Ta quase la!

[19] Comentário enviado por xclaudin em 13/10/2015 - 11:41h


root@DebianLinux:/home/teletecnico# systemctl status nagios
● nagios.service - LSB: Starts and stops the Nagios monitoring server
Loaded: loaded (/etc/init.d/nagios)
Active: failed (Result: exit-code) since Ter 2015-10-13 11:30:13 BRT; 11min ago
Process: 1589 ExecStart=/etc/init.d/nagios start (code=exited, status=8)

Out 13 11:30:13 DebianLinux nagios[1589]: ***> One or more problems was enco....
Out 13 11:30:13 DebianLinux nagios[1589]: Check your configuration file(s) t...d
Out 13 11:30:13 DebianLinux nagios[1589]: directives and data defintions. I...s
Out 13 11:30:13 DebianLinux nagios[1589]: version of Nagios, you should be a...s
Out 13 11:30:13 DebianLinux nagios[1589]: may have been removed or modified ...d
Out 13 11:30:13 DebianLinux nagios[1589]: the HTML documentation regarding t...e
Out 13 11:30:13 DebianLinux nagios[1589]: 'Whats New' section to find out wh....
Out 13 11:30:13 DebianLinux systemd[1]: nagios.service: control process exit...8
Out 13 11:30:13 DebianLinux systemd[1]: Failed to start LSB: Starts and stop....
Out 13 11:30:13 DebianLinux systemd[1]: Unit nagios.service entered failed s....
Hint: Some lines were ellipsized, use -l to show in full.

[20] Comentário enviado por xclaudin em 13/10/2015 - 12:09h


Manolo!

Consegui resolver tudo

Agora ta belezinha!

Só não to conseguindo logar no x.x.x.x/nagios rs

mesmo depois do root@DebianLinux:/home/teletecnico# htpasswd /usr/local/nagios/etc/htpasswd.users nagiosadmin
New password:
Re-type new password:
htpasswd: The file /usr/local/nagios/etc/htpasswd.users does not appear to be a valid htpasswd file.


Ele diz que meu htpasswd não parece ser válido.

é com esse usuário mesmo q vou logar no nagios ?

Só esse probleminha agora .x

[21] Comentário enviado por xclaudin em 14/10/2015 - 09:12h


Up

[22] Comentário enviado por xclaudin em 14/10/2015 - 11:42h

htpasswd.users does not appear to be a valid htpasswd file.


comofass ?

[23] Comentário enviado por erikpinheiro em 14/10/2015 - 11:55h


[22] Comentário enviado por xclaudin em 14/10/2015 - 11:42h

htpasswd.users does not appear to be a valid htpasswd file.


comofass ?


Tente dar uma revisada na segunda parte do artigo, aparentemente seu usuário nagios não foi criado

# ls /usr/local/nagios/etc
Veja com o comando acima se o arquivo htpasswd.users existe.

# cat /usr/local/nagios/etc/htpasswd.users
para ver o conteúdo, veja o retorno dele se tem o usuário nagios.

Caso não exista, revise esse ponto.

[24] Comentário enviado por xclaudin em 14/10/2015 - 13:09h


O arquivo htpasswd.users existe,

Porém está vazio, foi criado manualmente x.x

Já até refiz os procedimentos, mas vou refazer tudo de novo e posto o resultado...


[25] Comentário enviado por xclaudin em 14/10/2015 - 14:27h


O Conteudo do arquivo estava "teste" apaguei a palavra e deixei em branco, ai rodei os comandos de novo deu tudo certinho!

Loguei no Nagios está beleza, porém está no alto: Nagios Core Not running mas já dei service nagios start

e dei um service nagios status e retornou : root@DebianLinux:/home/teletecnico# service nagios status
● nagios.service - LSB: Starts and stops the Nagios monitoring server
Loaded: loaded (/etc/init.d/nagios)
Active: active (running) since Qua 2015-10-14 14:25:47 BRT; 1min 9s ago
Process: 1518 ExecStart=/etc/init.d/nagios start (code=exited, status=0/SUCCESS)
CGroup: /system.slice/nagios.service
├─1538 /usr/local/nagios/bin/nagios -d /usr/local/nagios/etc/nagio...
├─1540 /usr/local/nagios/bin/nagios --worker /usr/local/nagios/var...
├─1541 /usr/local/nagios/bin/nagios --worker /usr/local/nagios/var...
├─1542 /usr/local/nagios/bin/nagios --worker /usr/local/nagios/var...
├─1543 /usr/local/nagios/bin/nagios --worker /usr/local/nagios/var...
└─1544 /usr/local/nagios/bin/nagios -d /usr/local/nagios/etc/nagio...

Out 14 14:25:47 DebianLinux nagios[1538]: nerd: Channel hostchecks registere...y
Out 14 14:25:47 DebianLinux nagios[1538]: nerd: Channel servicechecks regist...y
Out 14 14:25:47 DebianLinux nagios[1538]: nerd: Channel opathchecks register...y
Out 14 14:25:47 DebianLinux nagios[1538]: nerd: Fully initialized and ready ...!
Out 14 14:25:47 DebianLinux nagios[1538]: wproc: Successfully registered man...r
Out 14 14:25:47 DebianLinux nagios[1538]: wproc: Registry request: name=Core...1
Out 14 14:25:47 DebianLinux nagios[1538]: wproc: Registry request: name=Core...3
Out 14 14:25:47 DebianLinux nagios[1538]: wproc: Registry request: name=Core...2
Out 14 14:25:47 DebianLinux nagios[1538]: wproc: Registry request: name=Core...0
Out 14 14:25:47 DebianLinux nagios[1538]: Successfully launched command file...4
Hint: Some lines were ellipsized, use -l to show in full.


Aparentemente está rodando !

Só que quando clico em qualquer menu no canto esquerdo seja Map, Hosts, ou qualquer um ele ta baixando um arquivo .cgi

e não abre a página que eu clico, o que pode ser esse bug ?

[26] Comentário enviado por xclaudin em 15/10/2015 - 08:17h


Tipo quando clico na aba "Services" ele ta baixando um arquivo "status.cgi" em vez de entrar na pagina "services"

Tudo que eu clico ele não vai pra pagina, baixa um arquivo '-' que estranho kkk

pode me ajudar com isso ?

[27] Comentário enviado por erikpinheiro em 15/10/2015 - 08:53h


[26] Comentário enviado por xclaudin em 15/10/2015 - 08:17h


Tipo quando clico na aba "Services" ele ta baixando um arquivo "status.cgi" em vez de entrar na pagina "services"

Tudo que eu clico ele não vai pra pagina, baixa um arquivo '-' que estranho kkk

pode me ajudar com isso ?


O Nagios está em execução ou ainda aparece Nagios Core not Running?

Se tiver como Nagios Core not Running, tente isso:
https://assets.nagios.com/downloads/nagioscore/docs/nagioscore/3/en/startstop.html

Aconselho a deixar o nagios a executar na inicialização do sistema.

[28] Comentário enviado por xclaudin em 15/10/2015 - 10:23h


Já iniciei ele de várias maneiras diferentes, mas na página inicial ainda está "Not running"

Mas no terminal dei o nagios -v pra verificar as config tão tudo OK 0 erros 0 warning

service nagios status no terminal ta OK tbm : ● nagios.service - LSB: Starts and stops the Nagios monitoring server
Loaded: loaded (/etc/init.d/nagios)
Active: active (running) since Qui 2015-10-15 10:20:18 BRT; 2min 20s ago

Process: 2006 ExecStop=/etc/init.d/nagios stop (code=exited, status=0/SUCCESS)
Process: 2015 ExecStart=/etc/init.d/nagios start (code=exited, status=0/SUCCESS)

restart: [ ok ] Restarting nagios (via systemctl): nagios.service.
[ ok ] Starting nagios (via systemctl): nagios.service.

Ta falando que ta rodando pelo terminal, mas na interface gráfica ta not runing, resetei até o apache2 e ainda não consegui


[29] Comentário enviado por xclaudin em 15/10/2015 - 12:18h

o_O
Não sei que diabos aconteceu mas ta funcionando do nada " Daemon running with PID 884"

ASUHAUHSUHASUHAUHS que loucura!

cara quando clico no menu Services ainda tá baixando um arquivo status.cgi ao invés de ir pra aba Services.

[30] Comentário enviado por erikpinheiro em 16/10/2015 - 09:42h


[29] Comentário enviado por xclaudin em 15/10/2015 - 12:18h

o_O
Não sei que diabos aconteceu mas ta funcionando do nada " Daemon running with PID 884"

ASUHAUHSUHASUHAUHS que loucura!

cara quando clico no menu Services ainda tá baixando um arquivo status.cgi ao invés de ir pra aba Services.


Tenta testar de outro navegador e máquina.


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts