Linux imprimindo em Windows via rede

Se você precisa que seu computador Linux imprima em uma impressora instalada em uma máquina Windows a partir da rede, esse artigo pode te ajudar ou pelo menos dar uma luz.

[ Hits: 138.499 ]

Por: kram3r em 20/06/2006 | Blog: http://kram3r.wordpress.com


Configurando o Samba



Depois de tudo instalado, vamos configurar o Samba para que ele se comunique com a rede Windows. Edite o arquivo /etc/samba/smb.conf.

OBS: Em algumas distros como o Slackware, existe um arquivo chamado smb.conf-sample, daí basta fazer o seguinte:

# cp /etc/samba/smb.conf-sample /etc/samba/smb.conf

Modifique as seguintes opções:

WORKGROUP = Coloque aqui o nome da sua rede

Ex: WORKGROUP = DIRETORIA

SERVER STRING = Nome da sua máquina

Ex: SERVER STRING = ComputadorDoKram3r

Salve o arquivo e reinicie o Samba.

Debian:

# /etc/init.d/samba restart

RedHat/Fedora:

# service samba restart

Slackware:

# smbd stop
# smbd start


Agora vamos verificar se o Samba está funcionando corretamente:

$ smbclient -L localhost

Quando pedir a senha, digite enter (deixar em branco), deverá aparecer algo como:

Password:
Anonymous login successful
Domain=[DIRETORIA] OS=[Unix] Server=[Samba 3.0.10]

        Sharename       Type      Comment
        ---------       ----      -------
        IPC$            IPC       IPC Service (ComputadorDoKram3r)
        ADMIN$          IPC       IPC Service (ComputadorDoKram3r)
Anonymous login successful
Certo? vamos continuar!

Página anterior     Próxima página

Páginas do artigo
   1. Pré-requisitos
   2. Configurando o Samba
   3. Configurando o CUPS
Outros artigos deste autor
Nenhum artigo encontrado.
Leitura recomendada

Como instalar o driver da placa de vídeo SiS 771/671 no Ubuntu 18.04

Configurando o X.org

HOWTO Linux para Sony Playstation 2 com HDLoader e DEV2

Recuperar o grub de forma rápida

Escolhendo o melhor gerenciador de janelas

  
Comentários
[1] Comentário enviado por removido em 20/06/2006 - 13:55h

Aki n deu certo =/

uso slack, fiz do jeito que vc falow mas ñ esta dando certo, mas la na maquina win a requisição da impressão feita pelo slack aparece la mas n sai na empressora sabe oq q eh?

Description: Urbi Network
Location: Maquina da Ivayne
Printer State: idle, accepting jobs.
"CUPS v1.1.23 is ready to print."
Device URI: smb://10.0.0.51/hpLaserJ1000


HP LaserJet Series CUPS v1.1 (en) estou usando esse driver será isso o problema??

[2] Comentário enviado por timm em 20/06/2006 - 22:21h

Em minha rede, desde que perdi meu HD com tudo o que tinha dentro, faço esse procedimento - pois era o que eu fazia antes - e o meu Slackware se recusa a imprimir via Rede nos micros Windons.

A mensagem é:
Tree Connect Failed.


O problema ocorre tanto ao adicionar diretamente no Cups quando no gnome-cups-add...

[3] Comentário enviado por gilps em 20/06/2006 - 22:28h

Olá amigo, ótimo artigo!
Eu estou com problemas, em imprimir em clientes Linux , impressora compartilhada pelo windows, se poder me ajudar agradeço!
há impressora é uma hp laserjet 1150
se eu colocar smb://MAQ01/IMP01 eo driver laserjet1150, o cups diz que é para esperar 30 segundos, e tentar de novo, só q já esperei 1h e nada, dai tentei um outro driver um postscript laserjet 4m ai ela manda para impressora assim:(Obs:O sublinhado é espaço em branco)
%1
__%% %%
_______<</ManualFeed_false>>setpagedevice _________________________________________<</Duplex_false>>setpagedevice _______________________________________________________________________%!PS-Adob

E umas 9 folhas em branco.

Quando eu coloco o driver raw e mando imprimir isso:
teste1
teste2
teste3
Ele imprime isso:
teste1
______teste2
____________teste3

e alguns driver, imprimem assim:

Unsupported Personality: PCLXL

Me desculpem, qualquer coisa!
desde já agradeço!

[4] Comentário enviado por feijaoazt em 21/06/2006 - 15:24h

O artigo blz !!!

So que tenho copiadoras Ricoh 551 e 450 e na configuracao do CUPS nao existem o drive para elas....teria que instalar esse drive mesmo?...e alguem por acaso tem ou trabalha com essas impressoras ??

Valews !

[5] Comentário enviado por kram3r em 21/06/2006 - 21:02h

Pessoal, desculpem a demora mas é que tô meio emperrado com coisas do trampo.
seguinte
pelo que vi alguns de vcs esqueceram de adicionar um usuario (guest no caso) ao conectar com o cups no samba
smb://guest@ipdamaquinawindows/nomedaimpressora
tentem e mandem as respostas.

quanto as copiadoras Ricoh eu não tenho a miníma idéia :(

a HP Ljet 1150 eu tive que instalar uma versão anterior do cups pra poder colocar a bixa pra rodar. tentae e ve no que da.

"HP LaserJet Series CUPS v1.1 (en) estou usando esse driver será isso o problema??"
provavelmente não verifica se vc esquececu de colocar o user guest no uri do cups.

[6] Comentário enviado por foxdet em 22/06/2006 - 09:59h

seguinte no windows 2000 pelo menos em redes onde circulam dados muito criticos e são aplicadas diversas diretrizes de segurança é necessário criar um usuário no windows por exemplo :

usuário : imp e senha : imp e dar a ele direitos de imprimir na impressora que já estará previamente compartilhada e ao invés de usar guest na hora de configurar o cups usar esse usuário só então é possivel imprimir via linux na maquina windows.

Estou postando a dica porque já passei por isso aqui na empresa.

Espero que ajude muitos de vocÊs.


[7] Comentário enviado por alexandrebchaves em 02/07/2006 - 19:37h

Belo artigo... vou testar amanha

Depois posto o resultado

[8] Comentário enviado por kakamila em 14/07/2006 - 12:53h

Tenho uma impressora HP 1320N e também não estou conseguindo instala-la no cups fiz todos os passos citados acima e pede para que eu espere 30 segundos para imprimir novamente. Fiquei com uma duvida pois essa impressora é tcp/ip e consigo instalar porem usando socket://ipdaimpressora/nome mas não consigo acessa-la das estações windows fala que o usuario não tem acesso a impressora.

[9] Comentário enviado por goiabis em 14/03/2007 - 09:44h

estou com um problema.....preciso saber a configuração completa do smb.conf, pois um dos "meio usuarios" alteraram alguma linha, a qual nao identifico.
O problema é que quando entro no navegador e digito http://localhost:631
ele redireciona para o site do wikpedia!!??
A minha versão é Insigne.

[10] Comentário enviado por ciberman_gi em 26/03/2007 - 20:47h

achei o artigo muito intereçante, mas ele cerve também p/ outros sistemas operacionais como o Mac.

[11] Comentário enviado por mcaju em 22/05/2007 - 18:59h

Opa, valeu, era o que estava precisando!!
Vou tentar botar pra rodar.
MCaju.

[12] Comentário enviado por oxroll em 23/08/2007 - 15:28h

Pessoal, estou com um probleminha aq. Olha só: tenho 3 maquinas Debian, e que quero imprimir no XP na rede, bem, já consegue fazer com duas sem dor de cabeça, mas tem uma aq que esta pedindo uma senha do localhost no final de toda a configuração do cups, já coloquei a senha do root, com usuário root, coloquei a senha do usuário, etc. já coloquei todas as senhas possíveis, mas nada! Alguém sabe o que pode esta acontecendo???

[13] Comentário enviado por kram3r em 29/08/2007 - 13:55h

ciberman_gi, não sei se funciona com Mac não. mas testa e posta ai pra gente!
creio eu que deve funcionar.

mcaju quando testar avisa!!!

oxroll, tenta instalar ela pelo gerenciador de impressão/impressoras do Gnome ou do kde (se vc estiver usando kde, basta ir no kcontrol center e depois perifericos/impressoras)
tive o mesmo problema que foi resolvido quando usei o kcontrolCenter.

Goiabis, nao tenho ideia do que pode estar acontecendo.
tenta remover a impressora e instalar pelo gerenciador de impressao/impressora do genome no insigne. Deve funcionar.
Abs!

[14] Comentário enviado por andrellucz em 09/05/2008 - 20:18h

?comentario=kram3r, valeu pelo artigo gostei mesmo mais no meu Debian Etch nao deu certo, nao sei pq fiz exatamente o q vc ensinou, mais nao deu certo, sou leigo estou aprendendo agora e vou tentar novamente depois para ver o que pode estar acontecendo.

T+

[15] Comentário enviado por zehdias em 12/05/2008 - 18:13h

Ola amigo, lendo seu artigo consegui resolver o problema de instalação de uma LexmarkX215-Porta Paralela instalada/compartilhada em um micro com WinXp Prof, usando o cups:631, estava a meses tentando, após ler muito seu artigo dei-me conta de colocar o user "guest@" após o comando smb://, dai funcionou legal. Erro que estava me dando era: "/usr/lib/cups/backend/smb failed".
Obrigado.

[16] Comentário enviado por brenoviski em 21/07/2008 - 14:56h

Seguinte na minha empresa tem uma impressora HPdeskjet 3745 eu fiz tudo que esta escrito no artigo, so q o arquivo ate chega no spooler de impressao so win XP so q nao imprimi... alguem pode ajudar?

[17] Comentário enviado por tai em 22/07/2008 - 10:48h

Bom tentei fazendo passo a passo... e estou com o seguinte erro

root@server:/home/server# smbclient -L localhost
timeout connecting to 127.0.0.1:445
timeout connecting to 127.0.0.1:139
Error connecting to 127.0.0.1 (Operation already in progress)
Connection to localhost failed (Error NT_STATUS_ACCESS_DENIED)
root@server:/home/server#

o que devo fazer nesse caso?

[18] Comentário enviado por kram3r em 22/07/2008 - 17:39h

brenovski, verifica os logs de erros e passa pra gente para podermos te ajudar.

tai,
o seu samba está rodando? qual distro está sendo utilizada?
debian/ubuntu - /etc/init.d/samba restart
fedora/redhat - service samba restart
slackware - /etc/rc.d/smbd restart

ve ai!

[19] Comentário enviado por tai em 23/07/2008 - 08:36h

No servidor Ubuntu 8.04 server
e o terminal que utilizo é Ubuntu 8.04 desktop / e windows XP

tentei novamente e o erro é esse

server@server:~$ /etc/init.d/samba restart
* Stopping Samba daemons start-stop-daemon: warning: failed to kill 5038: Operation not permitted
start-stop-daemon: warning: failed to kill 5041: Operation not permitted
[ OK ]
* Starting Samba daemons [ OK ]
server@server:~$ smbclient -L localhost
timeout connecting to 127.0.0.1:445
timeout connecting to 127.0.0.1:139
Error connecting to 127.0.0.1 (Operation already in progress)
Connection to localhost failed (Error NT_STATUS_ACCESS_DENIED)
server@server:~$

o Samba 3.028 funciona redondo pois é por ele que é compartilhado os documentos do servidor.
o CUPS 1.3.7 consigo o acesso pelo ip de qualquer terminal da rede.

O que preciso de fato é compartilhar algumas impressoras: Epson LX300 Epson CX7300 e Lexmark X340.

Agradeço a preocupação e vlw pela ajuda!

[20] Comentário enviado por kram3r em 23/07/2008 - 17:33h

tai,
então o samba já está ok e o cups tb correto?

o que não entendi é o porque de exibir esses erros de conexão sendo que vc falou que consegue acessar o servidor samba e o cups pelos terminais.

verifica direitinho sua configuração tanto no cliente quanto no servidor e qualquer coisa posta ai para que possamos identificar.

interessante que na hora de parar o samba ele deu esse erro de nao permitido :/
o samba estava parado?

[21] Comentário enviado por tai em 24/07/2008 - 09:25h

config do samba...

[global]
workgroup = MSHOME
netbios name = Server
server string = Linux
name resolve order = lmhosts, host, wins, bcast
printcap name = lpstat
encrypt passwords = true
wins support = yes
preferred master = yes
panic action = /usr/share/samba/panic-action %d
invalid users = root
preserve case = no
short preserve case = no
default case = lower
os level = 100

#[homes]
#comment = Home Directories
#create mask = 0700
#directory mask = 0700
#browseable = No

#[printers]

[22] Comentário enviado por tai em 24/07/2008 - 09:29h

acredito que isso que vc perguntou se precisar de mais alguma informação me avise que eu disponibilizo ok!

abraço!

[23] Comentário enviado por kram3r em 24/07/2008 - 19:46h

tail,
to meio corrido
mas da uma olhada em http://www.guiadohardware.net/dicas/compartilhando-impressoras-linux.html

e depois manda comentários

[24] Comentário enviado por rodrigoam em 10/12/2008 - 11:39h

Bom dia !!

Galera,

Fiz a instalação da impressora lx300 da forma acima mas não esta rolando, quando mando uma impressão de teste fica mensagem "printing page 1,0% complete...", mas não sai nada !!!

[25] Comentário enviado por rodrigoam em 10/12/2008 - 11:41h

Alguem sabe o que pode ser ?????

Valeu !!

[26] Comentário enviado por tai em 10/12/2008 - 12:30h

cola o seu smb.conf ai no comentario....

[27] Comentário enviado por donizeteq em 17/01/2009 - 20:21h

Ola amigos Muito bom tutorial parabéns funcionou 100% aqui... Obrigado

[28] Comentário enviado por luna2008 em 06/05/2009 - 09:28h

Galera não to conseguindo configurar impressora aki.
A impressora aki do trab é uma HP Laserjet 1320 e está em uma rede windows. Eu uso o CentOS 5.
Não + o q fazer, já tentei tudo q foi postado aki e dá sempre o mesmo erro:

Inacessível

Esta partilha de impressora está inacessível.

Já tentei como o nome e senha criados p/ ela e nada o q devo fazer?

P.S.: preciso d resposta urgente!!!!

[29] Comentário enviado por kram3r em 06/05/2009 - 09:39h

luna2008,
Se vc não informar como está sua configuração, não poderemos ajudar.
Outra coisa, precisar de resposta urgente?!?!?!
A gente está aqui para contribuir e não para resolver problemas alheios e ainda por cima com urgência.

Mas de ante mão vou tentar te dar uma mãozinha
- verifique se você já tem os drivers hpijs instalado na maquina com linux;
- verificar se o grupo de trabalho (workgroup) do samba é o mesmo da rede windows;
- verificar o firewall do windows (no caso do windows xp), em alguns casos tive que desabilitar o firewall para poder funcionar;
- verifique através de alguma máquina windows, se o nome da impressora visto na rede é realmente aquele que você informou ao cups;
- Leia atentamente o tutorial.

[30] Comentário enviado por rooost em 27/09/2009 - 09:45h

Valeu !!!!!!!

Foi de muita ajuda !!!!!!!!!!!! Parabéns pelo tópico, sou iniciante no Linux. Fiz tudim como manda o editor hehe, mas tem coisa que não consegui instalar de cara por causa do pacote etc. mas dei uma lida em outros tópicos mamão com açucar. No meu caso conseguir imprimir da minha máquina windows com uma impressora multifuncional hp deskjet psc1610 pela porta usb, adicionei uma porta para ela informei o ip e já era.

Espero futuramente poder contribuir com algum topico !

[31] Comentário enviado por vagner.guidon em 16/12/2009 - 11:35h

Segui os passos do artigo e funcionou direitinho para uma impressora Brother em uma maquina sem ip fixo, na outra maquina com ip fixo e impressora hp, travou a impressora de uma tal forma que fui obrigado a reinstala-la, agora eu gostaria de saber se tem alguma maneira de acessar o programa net empresa do Bradesco ,ja liguei inclusive no suporte deles que me disseram que tem um programa para emular o windows dentro do linux (mas ja li que fazendo assim vc tem que ter a licença do windows...) Se alguem tiver alguma dica agradeço.

[32] Comentário enviado por vitormaxrocha em 15/03/2010 - 22:08h

Puxa, Legal a sua dica.

Fiquei praticamente o dia inteiro tentando encontrar uma solução para essa funcionalidade, finalmente quando ia desistindo , resolví fazer uma pesquisa na net , e veja ai, simples e funcional

Obrigado

Valeu Mesmo

Vitor

[33] Comentário enviado por mfs em 13/04/2010 - 02:28h

Estava procurando como compartilhar a impressora entre Linux e Windows e encontro este artigo explicando tudo o que fazer.
Vlw ótimo artigo.

[34] Comentário enviado por prf30 em 10/11/2010 - 21:54h

Olá pessoal, essa é minha participação no fórum, e gostaria de trazer minha contribuição. Instalei recentemente o Mandriva One, meu Asus 1000H, estava tudo perfeito, menos a impressora que estava vinculada ao desktop, usando o windows sete. Depois de ler e reler o artigo, finalmente entendi a questão de como deve ficar o endereço no URI do dispositivo. No meu caso ficou assim: smb:///192.168.1.100/epson tx115 series.
antes eu estava errando o nome da impressora, colocava "epson", aí a impressão travava em 55% e não ía adiante.
Valeu, muito bom o artigo.

[35] Comentário enviado por Rubens Luccas em 02/03/2011 - 13:29h

Olá, gostaria de informar que acabo de imprimir a página de testes a partir do Ubuntu 10.04.

É muito bacana ver como um artigo de 2006 pode continuar ajudando a todos mesmo tanto tempo depois!

Obrigado.

[36] Comentário enviado por visterine em 28/07/2012 - 23:11h

instalar impressora do Windows no Linux

Uma pequena contribuição para o fórum.

Obs: antes de realizar o procedimento, lembre-se de compartilhar a impressora no Windows.

No caso contrário, no qual a impressora está instalada no Windows, e se deseja adicioná-la ao Linux, você deve realizar o seguinte procedimento:

Selecione o menu Sistema > Administração > Impressão. Na janela que será aberta, clique sobre o ícone de adicionar nova impressora, localizado abaixo do menu “Servidor”, e selecione a opção “Windows Printer via SAMBA”, que pode ser encontrado ao expandir o menu “Impressora de Rede”.

No campo para digitar o endereço da impressora, digite o endereço conforme pode ser observado no exemplo abaixo do campo em branco para a inserção, ou clique no botão “Navegar” e tente encontrar a impressora ao navegar pela rede. Se for pedido um nome de usuário, utilize o nome “guest”, ou “convidado”.

Caso ocorra algum problema, procure alterar as opções na impressora do Windows, desmarcando a opção “Habilitar suporte bidirecional”, na aba “Portas” das propriedades da impressora no Windows.

Leia mais em: http://www.tecmundo.com.br/roteador/2473-linux-como-compartilhar-impressoras-entre-linux-e-windows.h...

[37] Comentário enviado por raulgrangeiro em 22/02/2015 - 10:36h

Muito bom. Graças a Deus funcionou aqui, mas tive de substituir o "guest" por "nome_do_usuário_windows:senha_desse_usuário" e funcionou.

Fique com Deus! Abraço!

Creia no Senhor Jesus Cristo e serás salvo!

[38] Comentário enviado por kakopierre em 14/08/2015 - 17:13h


instalei ele funcionou blza, porem ele não aparece o numero de paginas e nem o nome do arquivo, tenho um sistema de contabilidade de paginas que precisa dessas informações para funcionar.

tem com ajuda... ???

[39] Comentário enviado por ironf15 em 09/03/2017 - 10:39h

Bom dia.

Obrigado Kramer: funcionou no meu Fedora 25. Só um complemento: para instalar o Samba e o CUPs no Fedora, a partir da Release 25, ficou mais simples:

-> CUPS

# dnf install cups system-config-network kdebase
# su -c 'chkconfig cups on'
# su -c 'service cups start'

# dnf install cups
Last metadata expiration check: 0:28:44 ago on Thu Mar 9 10:04:11 2017.
Package cups-1:2.2.0-5.fc25.x86_64 is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!

-> Samba

# dnf install samba-client
# systemctl enable smb nmb

# dnf install samba samba-client
Last metadata expiration check: 0:29:21 ago on Thu Mar 9 10:04:11 2017.
Package samba-2:4.5.5-0.fc25.x86_64 is already installed, skipping.
Package samba-client-2:4.5.5-0.fc25.x86_64 is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!

Abs e mais uma vez obrigado.

José Oliveira


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts