Instalando scanners com SANE

Se você está quebrando a cabeça para instalar seu scanner, dê uma olhada nesse tutorial, que mostra a instalação do scanner de uma multifuncional da HP.

[ Hits: 77.775 ]

Por: Luis Felipe Gerhardt em 22/07/2006 | Blog: http://www.vivaolinux.com.br


Introdução



O SANE (Scanner Access Now Easy) é um projeto que engloba softwares necessários para a instalação de scanners de diversos modelos e fabricantes no Linux.

Sua instalação não é problemática, porém alguns detalhes de configuração podem dificultar o trabalho dependendo do seu scanner. Atualizações de Firmware e utilização de outros softwares juntamente com o SANE como o HPLIP são exemplos de casos que demandam mais empenho.

Como exemplo, mostrarei a instalação do scanner de uma multifuncional da HP. Tal instalação necessitará do HPLIP (HP Linux Imaging and Printing). O HPLIP é um software desenvolvido pela própria HP que fornece suporte a quase 1000 modelos de impressoras e scanners no Linux.

A instalação do HPLIP é demonstrada em outro artigo que escrevi para o VOL (Instalando impressoras HP) e não será abordada neste. Apenas indicarei em que etapa deverá ser instalado o HPLIP.

    Próxima página

Páginas do artigo
   1. Introdução
   2. Downloads
   3. Instalação
   4. Configurações
   5. Concluindo
Outros artigos deste autor

Instalando impressoras HP

Instalando e configurando o SpamAssassin

Instalando MPlayer + GUI-GMPlayer + Skin + Codecs + fonts para Linux

Leitura recomendada

Comparando desempenho de distros, arquiteturas ou ambientes gráficos - Método universal

O MP3 player e o Ogg Vorbis

Instalando sidux em pendrive para usar como "Canivete Suíço"

Instalando nVidia no Debian Lenny 5.0.1 - Kernel 2.6.26-2-686

Conexão wireless ad-hoc no Ubuntu - relato de experiência

  
Comentários
[1] Comentário enviado por marlonrdias em 26/07/2006 - 17:20h

instalei o xsane e os outros pacotes no fedora 4 ... como sitado acima mais quando chamo o xsane ou outro como o kooka ele ainda nao funciona ... meu scanner e uma Hp office jet 1175c tem alguma ideia do que seja?

[2] Comentário enviado por pedemesa em 27/07/2006 - 08:55h

Você instalou o libsane-hpaio??? Você provavelmente vai precisar...

[3] Comentário enviado por xfabi0x em 22/08/2006 - 10:17h

Só corrigindo o link do hpaio..

ftp://ftp.pbone.net/mirror/download.fedora.redhat.com/pub/fedora/linux/core/development/i386/os/Fedo...

Nota 10 esse artigo, achei várias referências p\ ele em outros sites.

Parabéns..

Abraço

[4] Comentário enviado por xfabi0x em 22/08/2006 - 16:15h

Me da uma ajuda se possivel.. Instalei TUDO e tah ok!!!

Uso o scanimage p\ lista o meu scanner, tudo blz, na hora de scannear ele me da a seguinte msg:

sane_start: Document feeder out of documents. Isso dando um scanimage...

No xsane o erro é igual, só o "sane_start" que é "subistituido" por "Failed to start scanner"

To pesquisando e não acho nada a respeito, se puder me ajudar ;)

Uso Slackware 10.2, fluxbox r0x.

Abraço

[5] Comentário enviado por pedemesa em 22/08/2006 - 18:51h

Muito obrigado pela correção xfabi0x!!!

[6] Comentário enviado por pedemesa em 22/08/2006 - 18:57h

Ahh... já ia esquecendo...
xfabi0x!!!
Cara, nunca vi esse erro, mas pelo que ele descreve me parece problema no próprio scanner... Não será? não tem como testar em outra máquina? ou ainda se for um scanner USB em outra porta, talvez seja a porta USB...
Fora isso, talvez o SANE não dê suporte ao modelo do scanner. Veja tmb a documentação no site do SANE sobre o seu scanner ou o pelo menos sobre o driver do seu scanner... algumas vezes é necessário atualizar firmware ou coisas do tipo... o primeiro scanner que instalei, só funcionou depois que eu atualizei o firmware... era um Benq S2W 4300U... Talvez você se enquadre numa dessas coisas... agora não me vem mais nada em mente... espero poder ajudar de alguma forma... se você conseguir resolver posta aqui o que era! se não conseguir, posta tmb pra gente ver o que pode ser...

[7] Comentário enviado por xfabi0x em 23/08/2006 - 10:56h

Blz cara, valeu!!!!

Me informei se o SANE suporta meu scanner, ele suporta sim, eu estou achando que é firmware mesmo, mais vou dar uma testada numa máquina ruinwindows...

Valeu, dnovo, pela atenção! :D

Abraços

[8] Comentário enviado por celsopimentel em 10/01/2007 - 17:17h

Pessoal preciso de uma ajuda. Utilizo o ubuntu 6.06, tenho um scanner HP conectado, quando vou no xsane scanner ele não localiza o scanner e sim a minha web cam. O que eu faço para configurar o scanner corretamente? agradeço muito pela dica.

[9] Comentário enviado por pedemesa em 15/01/2007 - 18:43h

E sem a web cam ele localiza alguma coisa???
Bom... e outra coisa... Antes de mais nada, apague o diretório ".sane" do seu home... cada vez que você faz isso o sane é obrigado a criar o diretório novamente com as configurações atuais... Antes de tentar alguma coisa tente apagar este diretório...
Existe também uma opção onde você passa o caminho do scanner para o xsane... só não lembro o parâmetro... acho que é "-d" e o caminho:
$ xsane -d <caminho>
Não tenho nenhum sane por aqui pra testar... mas acho que é isso...
Fora isso não tenho muita idéia do que possa ser... talvez por ser um scanner HP você precise instalar o HPLIP... para isso você pode usar um outro artigo meu que está em:
http://www.vivaolinux.com.br/artigos/verArtigo.php?codigo=5140
Abraço... espero ter ajudado... e desculpe a demora na resposta, mas estou bem compromissado por aqui!

[10] Comentário enviado por karoaux em 15/05/2007 - 12:47h

Oi Galera!!

Baixei os pacotes, mas ele me da um erro após excutar o pacote sane-backends-1.0.17.tar.gz . Após abrir e cliqcar em ./confiure ele mostra:

checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.

preciso fazer o que? Meu pc é AMD sempron com Speedy , modem D-link 500B ethernet.


Ajudem, favor!!
Alexandre

[11] Comentário enviado por Maximus77 em 15/05/2007 - 20:37h

Boa noite, amigos! Eu estou nessa situação tambem! Uso o OpenSuse 10.0 por causa das minhas aplicações que giram nele e possuo um benq s2w 3300u/4300u. Como faço pra configurar e atualizar o firmaware dele?
Obrigado e tenham uma ótima semana!
Marcelo

[12] Comentário enviado por pedemesa em 29/05/2007 - 18:46h

Maximus77,
Bom cara, eu precisei atualizar o firmawave do Benq que instalei também. Para isso eu fiz o seguinte (não sei se resolve o seu problema também...):

* Copiar o arquivo de firmware baixado (.bin) para o diretório de instalação do sane (/usr/local/etc/sane.d/)

* Alterar o arquivo "snapscan.conf" (do diretório de instalação do sane) na linha "firmware", colocando o caminho correto para o arquivo u176v046.bin (/usr/local/etc/sane.d/u176v046.bin) e descomentar a linha que fala em "bus=usb".
Obs.: Isto atualizará o firmware automaticamente.

* Incluir a entrada "scanner" no arquivo "/etc/hotplug/blacklist".
Obs.: Isto fará com que o módulo "scanner" não seja mais carregado na inicialização do sistema, o que é necessário para a biblioteca "libusb" funcionar corretamente com o scanner.

* Incluir a linha abaixo no arquivo no arquivo "/etc/fstab":
none /proc/bus/usb usbfs defaults,devmode=0666 0 0
Esta alteração fará com que os usuários comuns tenham acesso ao scanner e não só o root.

* Rebootar a máquina.

Bom, foi isso que eu fiz... testa ai e me responde o que deu.
Desculpa a demora na resposta. Eu troquei de emprego a pouco e estou muito atarefado. Tudo novo, muito a aprender... sabe como é...

Espero ter ajudado!
Abraço,

[13] Comentário enviado por felipemartinsss em 20/05/2015 - 22:21h

O artigo é de quase 10 anos atrás, mas funcionou perfeitamente para mim. Obrigado!


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts