Instalando o modem NetDragon 56K

Esse artigo mostra como instalar o softmodem NetoDragon 56k PCI no Linux de uma maneira fácil e sem complicação. Confira.

[ Hits: 20.454 ]

Por: Tiago Alves de Andrade em 16/12/2003


Instalando o modem



Para instalar o modem NetDragon 56k no Linux você irá precisar do driver slmdm-2.7.8 ou superior. Tente baixá-lo através do link: Descompacte esse arquivo em uma pasta qualquer ou crie uma pasta para salvar o arquivo:

# mkdir /modem
# cd /modem
# tar zxvf slmdm-2.7.8.tar.gz


Agora entre na pasta criada pelo arquivo:

# cd slmdm-2.7.8

Vamos instalar o modem executando os comandos:

# make
# make install


Abra o kppp ou qualquer outro discador de sua preferência, configure a sua conta com a internet e teste que estará funcionando no link do dispositivo /dev/modem, que será criado automaticamente.

Caso o seu modem não responda, tente fazer da seguinte maneira: após executar o comando "make" citado, no lugar de usar o "make install", tente usar o comando:

# make install-amr

Provavelmente seu modem estará funcionando. Fiz os testes e em algumas distros fui obrigado a usar o comando "make install-amr".

OBS: O CD de driver do modem já vem com um driver para Linux e o driver é o slmdm mas, nas distros em que fiz os testes, esse driver não funcionou.

   

Páginas do artigo
   1. Instalando o modem
Outros artigos deste autor

LimeWire - um P2P muito interessante para Linux

Criando um servidor DNS com o DJBDNS

Criando um roteador Linux com sua máquina antiga

Leitura recomendada

Instalação do Varnish + Apache + Virtual Hosts

Configuração de rede para RedHat e similares utilizando VI/Emacs/etc

Quando seria mais conveniente usar wvdial no terminal para conexões 3G ou EDGE?

Agora existem espelhos brasileiros do Sabayon Linux, use-os!

Filtrando IPs no Debian e Ubuntu com o Mobloquer

  
Comentários
[1] Comentário enviado por PoWeReD69 em 25/12/2003 - 19:08h

ae meu chapa .... tb tenhu esse modem .. i fiz igualzinhu tah dizendo aki .. mais naum deu certo não ... sera que ele funciona nu linux conectiva 8 ???
c pah .. c mi manda um email DuDu@brchat.org

[2] Comentário enviado por GnU-Linux em 29/12/2003 - 01:43h

PoWeReD69 > sim, ele funciona em qualquer GNU/Linux, existe até um pacote para o Debian, para isso basta remover qualquer link que possa haver para o modem. tipo assim:

# rm -R /dev/modem

Entra no diretorio criado pelo comando tar e fazer isso:

# make && make instal-amr && cd ~ && reboot

Quando vc entra no sistema novamente o modem vai esta funfando

teste:

# minicom ;)

[3] Comentário enviado por GnU-Linux em 29/12/2003 - 01:49h

correção::
no comando de instalação do modem eh

# make && make install-amr

e não make instal-amr como havia colocado a antes

DESCULPE!

[4] Comentário enviado por GnU-Linux em 29/12/2003 - 01:50h

correção::
no comando de instalação do modem eh

# make && make install-amr

e não make instal-amr como havia colocado a antes

DESCULPE!

[5] Comentário enviado por GnU-Linux em 29/12/2003 - 01:52h

correção::
no comando de instalação do modem eh

# make && make install-amr

e não make instal-amr como havia colocado a antes

DESCULPE!

[6] Comentário enviado por llucas18 em 08/02/2004 - 22:42h

Mas afinal onde eu digito esses comados ?????

[7] Comentário enviado por removido em 11/02/2004 - 00:36h

Fiz tudo exatamente com explica em cima, só que depois de "make" recebo uma mensagem de ERRO [sllog.o]. Alguém pode me ajudar a resolver esse problema?
Obrigado.

[8] Comentário enviado por llucas18 em 14/02/2004 - 21:02h

fiz tudo certo ate o "make" mas apareceu isso:"gcc -Wall -O3 -fomit-frame-pointer -D__KERNEL__ -DMODULE -DEXPORT_SYMTAB -I. -I/usr/src/linux/include -DMODVERSIONS --include /usr/src/linux/include/linux/modversions.h -o amrmo_init.o -c amrmo_init.c
make: gcc: Comando não encontrado
make: ** [amrmo_init.o] Erro 127"
explica ai q to perdido !!!!!!!!!!

[9] Comentário enviado por bluetooth em 10/04/2004 - 22:42h

uso o slack 9 e apareceu o mesmo erro: [amro_init.o] a q se deve o fato?

[10] Comentário enviado por cazon em 08/08/2004 - 07:33h

Ola pessoal!
Estou usando o CL10 e tentei instalar me modem lg sm-i56 com o driver slm2.9 e ao executar o comando make recebo a seguinte mensagem:
usando : /usr/src/linux/include/linux
make all KERNEL_VER=2.6.5-62218cl
make[2]: Entering directory `/root/slmodem-2.9.9/drivers'
make modules -C /usr/src/linux/include/linux SUBDIRS=/root/slmodem-2.9.9/drivers
make[3]: Entering directory `/usr/src/linux-2.6.5-63077cl/include/linux'
make[3]: *** Sem regra para processar o alvo `modules'. Pare.
make[3]: Leaving directory `/usr/src/linux-2.6.5-63077cl/include/linux'
make[2]: ** [all] Erro 2
make[2]: Leaving directory `/root/slmodem-2.9.9/drivers'
make[1]: ** [all] Erro 2
make[1]: Leaving directory `/root/slmodem-2.9.9/drivers'
make: ** [drivers] Erro 2
alguem pode me ajudar por favor?
obrigado
cazon

[11] Comentário enviado por cazon em 08/08/2004 - 16:38h

Ola pessoal eu aki de novo!!!
pra quem estiver com problemas em instalar modems lg/hsp e outros bichos no CL10 pega aki um tutorial muito massa que resolveu meu problema:
http://www.aplinux.com.br/mostraartigo.php?artigoid=94&artigocat=2
Abraços

[12] Comentário enviado por pitoche em 06/04/2005 - 18:14h

ola eu tenho um modem lg lm-i56n netodragon e utilizo o mandrake 9.1 eu não consigode jeito nenhum instalar esse modem!!!
poderiam me ajudar?
pois quero aposentar o windows mas para isso preciso fazer funcionar o modem valew
AMD seprom 2200+
RAM 512 MB
HD 80GB
placa mae asrock k7vt6
geforce fx5200 182mb


[13] Comentário enviado por korosso em 12/04/2005 - 11:55h

galera... esta dica vale tb pro mandrake 10.1??? se mudar algo me falem oq por favor!

[14] Comentário enviado por cadson em 22/05/2005 - 16:02h

Tennho CL10 com Athom XP 2000 e repeti os comandos do artigo mas os comandos:

make
make install

não foram reconhecidos como comandos do console. alguém sabe o que houve?



[15] Comentário enviado por ksandim em 08/06/2005 - 22:42h

naum consegui instalar este modem no kernel 2.6.11 ele instala de buenas, mas quando do o comando modprobe lsamr dá o erro:

modprobe slamr == Error inserting slamr /lib/modules/2.6ATA/slamr.ko Unknow symbol in module or unknow parametr (see dsmesg)
Se alguem souber me ajudar....

[16] Comentário enviado por ratodemarte em 27/12/2005 - 10:09h

tive o mesmo problema do ksandim... aqui instala na boa, mas tah o memso erro quando vai carregar o modulo. soh muda o diretorio /lib/modules/2.6.13/extra/slamr.ko, pois aqui eh kernel 2.6.13 no slack 10.2

se alguem poder ajudar... vlw mesmo

[17] Comentário enviado por container em 14/01/2006 - 16:28h

Amigo, o link não funciona....

[18] Comentário enviado por diorleip em 04/10/2006 - 19:56h

galera eu tenho o debian e esse mesmo moden o netodragon 56k e nao consigo instalar da uma mensagem de rro 1 oq faço me ajudem.


Contribuir com comentário