Instalando Apache 1.3.33 com suporte a PHP no Slackware

Este artigo mostra, de forma simples e prática, como instalar o Apache 1.3.33 com suporte a PHP no Slackware 11.

[ Hits: 22.038 ]

Por: Phylipe Venancio Soares em 28/10/2006 | Blog: http://www.energiageradores.com


Baixando e configurando o Apache



Primeiramente iremos criar uma pasta para fazermos o download do Apache.

# mkdir /tmp/apache
# cd /tmp/apache


Agora é só baixar:

# wget ftp://ftp.slackware.com/pub/slackware/
slackware-11.0/apache_1.3.33-i486-1.tgz


Depois de baixado faremos a instalação:

# installpkg apache_1.3.33-i486-1.tgz

Pronto, o Apache já está instalado.



Configurando o httpd.conf


Depois de instalado deveremos ativar o módulo para suporte ao PHP.

Edite o arquivo /etc/apache/httpd.conf, procure pela linha abaixo e descomente-a:

# Include /etc/apache/mod_php.conf

Ficando assim:

Include /etc/apache/mod_php.conf

Depois procure as linha que contém:

<IfModule mod_dir.c
    DirectoryIndex index.html
</IfModule

Adicione em frente ao index.html, index.php e main.php, ficando assim:

<IfModule mod_dir.c
    DirectoryIndex index.html index.php main.php
</IfModule

Agora é só salvar.

    Próxima página

Páginas do artigo
   1. Baixando e configurando o Apache
   2. Colocando o serviço para rodar e testando
Outros artigos deste autor

Instalando Ubuntu 7.04 Feisty Fawn

Baixando e instalando o Ubuntu 6.10

Leitura recomendada

Instalando o gerenciador de Lan House no Linux

Alinhamento em folhas de estilo - CSS

1º Fórum da Internet no Brasil

Criando VPN site-to-site, conectando diversas filiais a matriz com openVPN

Balanceamento de carga e alta disponibilidade com Bonding Driver e Iproute2

  
Comentários
[1] Comentário enviado por luiscarlos em 29/10/2006 - 19:53h

Na boa kra, eu visito o VOL a alguns anos e uma coisa que me irrita e muito é ver artigos duplicados, uma critica construtiva para todos que forem publicar artigos, primeiro, pesquise para saber se já não existe existe algo parecido com o que está disponível, por que o que estou vendo é que cada pessoa que consegue instalar o apache com php e mysql publicar um artigo dizendo como fez isso sendo que já existe pelo menos uns 3 artigos que mostrem isso e por favor, outro erro, vc diz como instalar usando para debian "# installpkg apache_1.3.33-i486-1.tgz ", eu uso fedora, se eu fosse iniciante, não serviria de nada seu artigo, por que?
eu respondo por que.... um iniciante gosta das coisas prontas, como uso fedora, o installpkg nao funciona, eu tentaria o comando e veria que nao funciona e consequentemente iria pensar que o que vc nao escreveu nao é verdade por que nao funcionou.... só mais tarde veria que nao funcionou por que é fedora e não debian ou baseado em debian....
Nada contra seu artigo, o que estou dizendo é que jah existe isso no VOL, e muito melhor que o seu, onde apenas mostra alguns comandos e configuraçõs, mas que não explica em 100 % o seu fucionamento...
Na boa, pra todos que forem publicar artigos, chega de mandar artigos dizendo "Como instalar o kernel xxxxx na distro xxxxx", isso é baboseira, isso vai fazer com que o VOL cresça até chegar aos 12 anos e depois continuar criança pro resto da vida.... parem, pensem e parem de publicar artigos duplicados, este é meu desabafo depois de ver tento espaço disponível com conteudo duplicado.
Por favor, leiam todos os artigos duplicados sobre um assunto e depois me respondam se nao estou certo ou naum.....
É claro que terá akeles que irão me dizer que tem gente que procura solução pra sua distro e que esta veio a calhar, mas pensem, quem se arrisca a aprender linux como eu, não irá se contentar em resolver o problema, irá querer saber como funciona e por que conseguiu resolver desta forma e não de outra... irá querer saber mais e isso ão ajuda em nada... resolve o problema, mas nao ajuda.......
É como dar esmola aos pobres, depois eles se acostuman a ganhar o que precisam e nunca mais irão se quer pensar em fazer alguma coisa para mudar a situação.
Isso é pra ser uma critica construtiva, quero que fique bem isso, e phylipe, seu artigo precisa de mais explicações, só mostrar como fazer edizer por cima pra que serve não basta pra quem quer aprender.
Espero que escreva mais artigos pra essa comunidade que vi crescer, mas que sejam melhores que esse, sei que vc pode ser melhor. Abraços...

0 0
[2] Comentário enviado por Dark_Avatar em 29/10/2006 - 21:55h

Deixo aqui meu protesto, concordando plenamente com o luis0101.
É cansativo ver pessoas que aprendem a instalar apache com php e postam artigo aqui, está ficando chato isso, vários artigos desse tipo já existem. Vamos inovar, vamos deixar de ficar duplicando artigos e ganhar pontos!
Oque está degenerando o VOL é isso, os moderadores aceitando artigos duplicados e também os usuparios ficarem duplicando artigos. Oque acham da idéia de tentar achar algo novo e criar um artigo? Falar sobre outros tópicos ainda não muito (bem ou não) abordados!? É isso oque eu acho, se continuar nesse rumo, o máximo que irá acontecer é o VOL morrer, para a infelicidade da comunidade linux brasileira :(

0 0
[3] Comentário enviado por shaper em 11/02/2009 - 12:27h

Luiz,

Desculpa se estou sendo intrometido, mas:

1 - Se vc não conseguiu ler, lá em cima ele fala Instalando Apache 1.3.33 com suporte a PHP no Slackware e não no DEBIAN.
2 - Essa comunidade é feita para ajudar, então, se não funcionou, o cara vai vir aqui e dizer que não funcionou.
3 - Você viu sim, 3 instalações de Apache, mas essa é a mais simplificada.

O cara tenta ajudar e ainda recebe uma crítica dessa...

Fale sério...

Quer aparecer, coloca uma melancia na cabeça e sai andando no centro da cidade.


0 0
[4] Comentário enviado por guinhomax em 29/04/2009 - 09:16h

Concordo com o SHAPER. Eu mesmo consegui colocar o PHP ra funcionar com esse tuto aqui. Procurei outro e não achei. Agente tem q incentivar, e não criticar quando alguém quer ajudar.

0 0

Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Graphics: driver: nouveau (15)

Artigos

Roubando bits - Receita para cálculo de sub-redes

Instalação Tesseract 4.1 e Apache Airflow no CENTOS 7

Usar o apt-get e o apt

Baixar posts do Instagram usando Python

Utilizando fontes de emojis no seu sistema Linux

Dicas

Definindo padrão de folha para a4 no Void Linux - LibreOffice

Gdebi + Ubuntu - Erro: FutureWarning: Possible nested set at position 1 [Resolvido]

Tmux - Instalação e Customização (Debian e Derivados)

Sistema não inicia o desktop environment? Saiba como resolver!

Vim - como executar uma linha do texto no terminal

Tópicos

Transformar Array em Variáveis (10)

VIRTUALBOX (5)

Debian 11 - Quando se loga o sistema trava (12)

Migração/ Atualização Samba 4.2 - 4.13 (2)

Formatação do CentOS 8 (1)

Top 10 do mês

Scripts

[Python] Trocar IP em Python3

[C/C++] Spieluhr - esse código pode ser considerado um vírus?

[Shell Script] Script instalador do obmenu-generator e configuração do openbox

[Shell Script] newchangelog - Script para gerar changelog.

[Shell Script] Uebevert - All in One [version 3]