Exim4 com MailScanner + Clamav

Bom dia, hoje estarei descrevendo aqui como instalar e configurar o Exim4 utilizando o mailScanner com o anti-vírus Clamav. A distribuição usada como base foi a Debian (testing ou unstable).

[ Hits: 41.178 ]

Por: Eduardo Lopes em 03/05/2005


Dependências



O Exim4 está disponível na lista "testing" da Debian. Então teremos que trocar as nossas configurações do apt:

# vi /etc/apt/sources.list

E troque todas as ocorrências de stable por testing. Agora vamos atualizar a lista:

# apt-get update

Agora vamos instalar os pacotes necessários:

# apt-get install exim4
# apt-get install mailscanner
# apt-get install clamav


Pronto, feito isso vamos passar para o próximo passo.

    Próxima página

Páginas do artigo
   1. Dependências
   2. Configurações iniciais
   3. Configuração do Exim4
   4. Configuração do MailScanner
   5. Conclusão
Outros artigos deste autor

Request Tracker 3 - Ticketing system

Instalando o SmokePing

Leitura recomendada

Instalando o Thunderbird e colocando o atalho no desktop

Post-la - Gerador de relatórios para o Postfix

Configurando servidor IMAP

Benchmark entre servidores de e-mails

Zimbra - Como rastrear um e-mail dentro do log

  
Comentários
[1] Comentário enviado por agk em 06/05/2005 - 19:12h

Parabéns, muito bem explicado o artigo. Eu prefiro utilizar o Woody e certamente não colocaria um servidor em produção com o Sarge.

Para que não sabe o Debian tem 3 versões:
Woody - Stable - Estável
Sarge - Testing - Teste
Sid - Unstable - Instável

O Woody é excelente para servidores, muito estável e quase não tem correções, já o Sarge e o Sid tem atualizações diárias e dependendo do dias as atualizações são imensas, centenas de Megabytes e os programas e configurações mudam muito.
Tenho um servidor IBM Xseries225 aqui com Debian Sarge (Testing) com kernel 2.6, não está em produção, mas estou testando LDAP, Samba 3.x, motivo: pelo suporte de hardware.

[2] Comentário enviado por molotov em 14/11/2005 - 20:36h

Parabéns, muito bem explicado. Mais tenho um problema com a seccao Configuracao do MailScanner. Na segunda ediçao cuando bem todo o referente a integraçao com o Clamav, fiz identido.

Mais cuando vou inciar o Mailscanner da erro, nao reconhece muitos dos comandos. Ex. MTA = exim4

Obrigado pela ajuda.

[3] Comentário enviado por JuNiOx em 08/03/2006 - 15:21h

amigo, saberia informar como bloquear anexos com extensões .exe ?

valeu

[4] Comentário enviado por locolinux em 09/03/2006 - 09:14h

Bom dia,
Respondendo a pergunta do JuNiOx, vc pode usar o spamassassin para bloquear spam e extensões. No arquivo de configuração do mesmo, é tem opções para bloquear extensões, essas opções vem comentadas por padrão, é só descomenta-las e pronto. Estou usando o spamassassin com o postfix aqui e está bloqueando essas extensões muito bem.

Até mais.


Contribuir com comentário