Configurando VPN com o Hamachi entre Windows e Linux Debian

O objetivo desse artigo será guiar-lhes à configuração de uma rede VPN entre Windows e Linux utilizando o Hamachi. Não vou abordar aqui a instalação do Hamachi no Windows, pois o foco é a configuração no Linux.

[ Hits: 34.298 ]

Por: Jorge Augusto Rabello Pinto em 08/12/2010


Instalando as dependências



Partindo do princípio que você já tenha instalado e configurado o Hamachi no servidor Windows, vamos a instalação de dependências no Debian GNU/Linux.

A única dependência que precisa ser instalada é o lsb. Para tanto execute:

# aptitude install lsb

Se você tentar via apt-get vai receber o seguinte erro:

# apt-get install lsb
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Você deve querer executar 'apt-get -f install' para corrigí-los:
Os pacotes a seguir têm dependências desencontradas:
  lsb: Depende: lsb-core mas não será instalado
       Depende: lsb-graphics mas não será instalado
       Depende: lsb-cxx mas não será instalado
       Depende: lsb-desktop mas não será instalado
E: Dependências desencontradas. Tente 'apt-get -f install' sem nenhum pacote (ou especifique uma solução).


Isso por que o apt-get não resolve as dependências, então faça assim:

# aptitude install lsb
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Lendo informações estendidas de estado
Inicializando estados de pacotes... Pronto
Escrevendo informações estendidas de estado... Pronto
Lendo descrições de tarefas... Pronto
Os NOVOS pacotes a seguir serão instalados:
  alien{a} at{a} bsd-mailx{a} debhelper{a} exim4{a} exim4-base{a}
  exim4-config{a} exim4-daemon-light{a} html2text{a} libbeecrypt6{a}
  libneon27{a} libqt4-assistant{a} libqt4-gui{a} libqt4-svg{a} librpm4.4{a}
  lsb lsb-core{a} lsb-cxx{a} lsb-desktop{a} lsb-graphics{a} mailx{a} pax{a}
  rpm{a} rsync{a}
Os pacotes a seguir, parcialmente instalados, serão configurados:
  logmein-hamachi
0 pacotes atualizados, 24 novos instalados, 0 a serem removidos e 0 não atualizados.
É preciso obter 5738kB de arquivos. Depois do desempacotamento, 14,4MB serão usados.
Você deseja continuar? [Y/n/?] Y
AVISO: versões não confiáveis dos seguintes pacotes serão instaladas!

Pacotes não confiáveis podem comprometer a segurança de seu sistema.
Você deveria prosseguir com a instalação somente se estiver certo de
que isso é realmente o que você deseja fazer.

  libqt4-assistant debhelper libbeecrypt6 lsb-graphics lsb-desktop at
  librpm4.4 libqt4-gui rsync lsb pax libqt4-svg rpm bsd-mailx mailx
  lsb-core alien lsb-cxx

Você deseja ignorar este aviso e continuar mesmo assim?
Para continuar, digite "Sim"; para abortar, digite "Não":Sim
Escrevendo informações estendidas de estado... Pronto
Obter:1 http://ftp.br.debian.org lenny/main exim4-config 4.69-9 [350kB]
Obter:2 http://ftp.br.debian.org lenny/main exim4-base 4.69-9 [987kB]
Obter:3 http://ftp.br.debian.org lenny/main exim4-daemon-light 4.69-9 [422kB]
Obter:4 http://ftp.br.debian.org lenny/main exim4 4.69-9 [7478B]
Obter:5 http://ftp.br.debian.org lenny/main at 3.1.10.2 [43,1kB]
Obter:6 http://ftp.br.debian.org lenny/main bsd-mailx 8.1.2-0.20071201cvs-3 [157kB]
Obter:7 http://ftp.br.debian.org lenny/main mailx 1:20071201-3 [8260B]          
Obter:8 http://ftp.br.debian.org lenny/main pax 1:1.5-16 [51,8kB]              
Obter:9 http://ftp.br.debian.org lenny/main rsync 3.0.3-2 [328kB]              
Obter:10 http://ftp.br.debian.org lenny/main html2text 1.3.2a-5 [91,5kB]        
Obter:11 http://ftp.br.debian.org lenny/main debhelper 7.0.15 [554kB]          
Obter:12 http://ftp.br.debian.org lenny/main libbeecrypt6 4.1.2-7 [107kB]      
Obter:13 http://ftp.br.debian.org lenny/main libneon27 0.28.2-6.1 [140kB]      
Obter:14 http://ftp.br.debian.org lenny/main librpm4.4 4.4.2.3-1 [948kB]        
Obter:15 http://ftp.br.debian.org lenny/main rpm 4.4.2.3-1 [1090kB]            
Obter:16 http://ftp.br.debian.org lenny/main alien 8.72 [103kB]                
Obter:17 http://ftp.br.debian.org lenny/main lsb-core 3.2-20 [37,4kB]          
Obter:18 http://ftp.br.debian.org lenny/main lsb-graphics 3.2-20 [14,4kB]      
Obter:19 http://ftp.br.debian.org lenny/main lsb-cxx 3.2-20 [14,4kB]            
Obter:20 http://ftp.br.debian.org lenny/main libqt4-svg 4.4.3-1+lenny1 [181kB]  
Obter:21 http://ftp.br.debian.org lenny/main libqt4-assistant 4.4.3-1+lenny1 [42,7kB]
Obter:22 http://ftp.br.debian.org lenny/main libqt4-gui 4.4.3-1+lenny1 [30,6kB]
Obter:23 http://ftp.br.debian.org lenny/main lsb-desktop 3.2-20 [14,5kB]        
Obter:24 http://ftp.br.debian.org lenny/main lsb 3.2-20 [14,4kB]                
Buscados 5738kB em 17s (321kB/s)                                                
Pré-configurando pacotes ...
Selecionando pacote previamente não selecionado exim4-config.
(Lendo banco de dados ... 127124 arquivos e diretórios atualmente instalados).
Desempacotando exim4-config (de .../exim4-config_4.69-9_all.deb) ...
Selecionando pacote previamente não selecionado exim4-base.
Desempacotando exim4-base (de .../exim4-base_4.69-9_i386.deb) ...
Selecionando pacote previamente não selecionado exim4-daemon-light.
Desempacotando exim4-daemon-light (de .../exim4-daemon-light_4.69-9_i386.deb) ...
Selecionando pacote previamente não selecionado exim4.
Desempacotando exim4 (de .../archives/exim4_4.69-9_all.deb) ...
Selecionando pacote previamente não selecionado at.
Desempacotando at (de .../archives/at_3.1.10.2_i386.deb) ...
Selecionando pacote previamente não selecionado bsd-mailx.
Desempacotando bsd-mailx (de .../bsd-mailx_8.1.2-0.20071201cvs-3_i386.deb) ...
Selecionando pacote previamente não selecionado mailx.
Desempacotando mailx (de .../mailx_1%3a20071201-3_all.deb) ...
Selecionando pacote previamente não selecionado pax.
Desempacotando pax (de .../pax_1%3a1.5-16_i386.deb) ...
Selecionando pacote previamente não selecionado rsync.
Desempacotando rsync (de .../rsync_3.0.3-2_i386.deb) ...
Selecionando pacote previamente não selecionado html2text.
Desempacotando html2text (de .../html2text_1.3.2a-5_i386.deb) ...
Selecionando pacote previamente não selecionado debhelper.
Desempacotando debhelper (de .../debhelper_7.0.15_all.deb) ...
Selecionando pacote previamente não selecionado libbeecrypt6.
Desempacotando libbeecrypt6 (de .../libbeecrypt6_4.1.2-7_i386.deb) ...
Selecionando pacote previamente não selecionado libneon27.
Desempacotando libneon27 (de .../libneon27_0.28.2-6.1_i386.deb) ...
Selecionando pacote previamente não selecionado librpm4.4.
Desempacotando librpm4.4 (de .../librpm4.4_4.4.2.3-1_i386.deb) ...
Selecionando pacote previamente não selecionado rpm.
Desempacotando rpm (de .../rpm_4.4.2.3-1_i386.deb) ...
Selecionando pacote previamente não selecionado alien.
Desempacotando alien (de .../archives/alien_8.72_all.deb) ...
Selecionando pacote previamente não selecionado lsb-core.
Desempacotando lsb-core (de .../lsb-core_3.2-20_i386.deb) ...
Selecionando pacote previamente não selecionado lsb-graphics.
Desempacotando lsb-graphics (de .../lsb-graphics_3.2-20_i386.deb) ...
Selecionando pacote previamente não selecionado lsb-cxx.
Desempacotando lsb-cxx (de .../lsb-cxx_3.2-20_i386.deb) ...
Selecionando pacote previamente não selecionado libqt4-svg.
Desempacotando libqt4-svg (de .../libqt4-svg_4.4.3-1+lenny1_i386.deb) ...
Selecionando pacote previamente não selecionado libqt4-assistant.
Desempacotando libqt4-assistant (de .../libqt4-assistant_4.4.3-1+lenny1_i386.deb) ...
Selecionando pacote previamente não selecionado libqt4-gui.
Desempacotando libqt4-gui (de .../libqt4-gui_4.4.3-1+lenny1_i386.deb) ...
Selecionando pacote previamente não selecionado lsb-desktop.
Desempacotando lsb-desktop (de .../lsb-desktop_3.2-20_i386.deb) ...
Selecionando pacote previamente não selecionado lsb.
Desempacotando lsb (de .../archives/lsb_3.2-20_all.deb) ...
Processando gatilhos para man-db ...
Configurando exim4-config (4.69-9) ...
Configurando exim4-base (4.69-9) ...
Configurando exim4-daemon-light (4.69-9) ...
Starting MTA: exim4.
Configurando exim4 (4.69-9) ...
Configurando at (3.1.10.2) ...
Starting deferred execution scheduler: atd.
Configurando bsd-mailx (8.1.2-0.20071201cvs-3) ...
Configurando mailx (1:20071201-3) ...
Configurando pax (1:1.5-16) ...
Configurando rsync (3.0.3-2) ...
Configurando html2text (1.3.2a-5) ...
Configurando debhelper (7.0.15) ...
Configurando libbeecrypt6 (4.1.2-7) ...
Configurando libneon27 (0.28.2-6.1) ...
Configurando librpm4.4 (4.4.2.3-1) ...
Configurando rpm (4.4.2.3-1) ...
Configurando alien (8.72) ...
Configurando lsb-core (3.2-20) ...
Configurando lsb-graphics (3.2-20) ...
Configurando lsb-cxx (3.2-20) ...
Configurando libqt4-svg (4.4.3-1+lenny1) ...
Configurando libqt4-assistant (4.4.3-1+lenny1) ...
Configurando libqt4-gui (4.4.3-1+lenny1) ...
Configurando lsb-desktop (3.2-20) ...
Configurando lsb (3.2-20) ...
Configurando logmein-hamachi (2.0.0.12-1) ...
Adding system startup for /etc/init.d/logmein-hamachi ...
   /etc/rc0.d/K49logmein-hamachi -> ../init.d/logmein-hamachi
   /etc/rc1.d/K49logmein-hamachi -> ../init.d/logmein-hamachi
   /etc/rc6.d/K49logmein-hamachi -> ../init.d/logmein-hamachi
   /etc/rc2.d/S11logmein-hamachi -> ../init.d/logmein-hamachi
   /etc/rc3.d/S11logmein-hamachi -> ../init.d/logmein-hamachi
   /etc/rc4.d/S11logmein-hamachi -> ../init.d/logmein-hamachi
   /etc/rc5.d/S11logmein-hamachi -> ../init.d/logmein-hamachi
Starting LogMeIn Hamachi VPN tunneling engine logmein-hamachi.
Lendo listas de pacotes... Pronto                      
Construindo árvore de dependências      
Lendo informação de estado... Pronto
Lendo informações estendidas de estado      
Inicializando estados de pacotes... Pronto
Escrevendo informações estendidas de estado... Pronto
Lendo descrições de tarefas... Pronto                

Estado atual: 0 quebrado [-1].


Agora vamos à instalação do Hamachi.

    Próxima página

Páginas do artigo
   1. Instalando as dependências
   2. Instalando o Hamachi
   3. Listando e conectando ao diretórios
Outros artigos deste autor
Nenhum artigo encontrado.
Leitura recomendada

Configuração de Servidor Web no FreeBSD 9

Dhcp3-server e Bind9 no Debian 4 Etch Linux

Incrementando o visual do KDE 4

Configurando o CACIC (parte 4)

Nagios + NagiosQL + PNP4Nagios

  
Comentários
[1] Comentário enviado por agk em 17/12/2010 - 17:19h

Muito bom o artigo, parabéns.

Eu particularmente só utilizei o hamachi até hoje para jogos, mas vejo que também tem muitas outras funcionalidades.

[ ]'s.

[2] Comentário enviado por jorgerabello em 20/12/2010 - 09:29h

Caro agk
Muito obrigado pelo elogio ! =)
Espero ter contribuído mesmo , e é verdade, o Hamachi é uma excelente ferramenta para várias soluções e essa particularmente é muito boa, pois perceba que você poderá ter acesso não somente aos compartilhamentos comuns mas também aos compartilhamentos administrativos e/ou ocultos (aquele com $ na frente do nome).

Em fm espero que mais pessoas tenha visto, entendido e apreciado o artigo acima, quaisquer dúvidas estarei a disposição de todos por email:

[email protected]

[3] Comentário enviado por pedro.nalin em 30/11/2011 - 18:52h

Ta de parabéns pelo topico, mto obrigado ;D

[4] Comentário enviado por llbranco em 19/06/2012 - 18:39h

mto manero
vo usa

[5] Comentário enviado por soulfire em 10/12/2014 - 10:22h

Amigo esta dando um aviso de conflito de dependencias... :


[[email protected]] /root>aptitude install lsb
Os NOVOS pacotes a seguir serão instalados: do
alien{a} cpp{ab} cpp-4.7{ab} ed{a} lib32z1{a} libaudio2{a} libc6-i386{a} libelf1{a} libfile-basedir-perl{a} libfile-desktopentry-perl{a} libfile-mimeinfo-perl{a}
libglu1-mesa{a} libjpeg62{a} libmng1{a} libmysqlclient18{a} libnet-dbus-perl{a} libnspr4{a} libnspr4-0d{a} libnss3{a} libnss3-1d{a} libpod-plainer-perl{a}
libqt4-network{a} libqt4-opengl{a} libqt4-sql{a} libqt4-sql-mysql{a} libqt4-sql-sqlite{a} libqt4-svg{a} libqtgui4{a} librpm3{a} librpmbuild3{a} librpmio3{a}
librpmsign1{a} libx11-protocol-perl{a} libxml-twig-perl{a} libxml-xpathengine-perl{a} lsb lsb-core{a} lsb-cxx{a} lsb-desktop{a} lsb-graphics{a} lsb-languages{a}
lsb-multimedia{a} lsb-printing{a} lsb-security{a} mysql-common{a} pax{a} rpm{a} rpm-common{a} rpm2cpio{a} x11-xserver-utils{a} xdg-utils{a}
Os pacotes a seguir serão atualizados:
libc-bin libc6 libc6:i386 libjpeg62:i386 libnspr4:i386 libnspr4-0d:i386 libnss3:i386 libnss3-1d:i386
8 pacotes atualizados, 51 novos instalados, 0 a serem removidos e 119 não atualizados.
à preciso obter 36,7 MB de arquivos. Depois do desempacotamento, 62,2 MB serão usados.
Os pacotes a seguir possuem dependências não satisfeitas:
libc6-i686:i386 : Pré-Depende: libc6:i386 (= 2.13-38+deb7u1) mas 2.13-38+deb7u6 será instalado.
cpp : Conflita: cpp:i386 mas 4:4.7.2-1 está instalado.
cpp:i386 : Conflita: cpp mas 4:4.7.2-1 será instalado.
libc6-dev : Depende: libc6 (= 2.13-38+deb7u1) mas 2.13-38+deb7u6 será instalado.
cpp-4.7 : Conflita: cpp-4.7:i386 mas 4.7.2-5 está instalado.
cpp-4.7:i386 : Conflita: cpp-4.7 mas 4.7.2-5 será instalado.
aberto: 17; fechado: 76; atrasado: 3; conflito: 5 .As seguintes ações resolverão estas dependências:

Remover os pacotes a seguir:
1) libc6-dev
2) libc6-i686:i386
3) zlib1g-dev

Manter os pacotes a seguir em suas versões atuais:
4) cpp [Não Instalado]
5) cpp-4.7 [Não Instalado]
6) lsb [Não Instalado]
7) lsb-core [Não Instalado]
8) lsb-cxx [Não Instalado]
9) lsb-desktop [Não Instalado]
10) lsb-graphics [Não Instalado]
11) lsb-languages [Não Instalado]
12) lsb-multimedia [Não Instalado]
13) lsb-printing [Não Instalado]
14) x11-xserver-utils [Não Instalado]

Deixar as seguintes dependências por resolver:
15) lsb-security recomenda lsb-core (>= 4.1+Debian8+deb7u1)
16) xdg-utils recomenda x11-xserver-utils
17) libc6:i386 recomenda libc6-i686:i386


Aceitar esta solução? [Y/n/q/?]


O que eu devo escolher?

Obrigado


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts