Instalando o Google Chrome nativo no Linux com suporte a flashplayer

Publicado por albert guedes em 24/07/2009

[ Hits: 50.529 ]

Blog: http://www.socrates.if.usp.br/~arcguede

 


Instalando o Google Chrome nativo no Linux com suporte a flashplayer

O novo navegador da Google, o Google Chrome, está disponível em uma versão nativa para o Linux com interface em GTK, a mesma do Gnome. Para quem usa sistemas Debian-like, entre na página:
Baixe o pacote '.deb' correspondente a sua arquitetura (32 ou 64 bits) e rode como root:

# dpkg -i google-chrome-unstable_current_xxx.deb

Automaticamente o pacote acrescentará uma linha no 'sources.list' com o repositório para atualizações futuras do Chrome. Para outras distros, é só baixar da página http://build.chromium.org/buildbot/snapshots/chromium-rel-linux e pegar a versão mais atual possível. A seguir crie como root o diretório:

# mkdir -p /opt/google

Mova a pasta descompactada 'chrome-linux' para '/opt/google/' e crie o link:

# ln -s /opt/google/chrome-linux/chrome /usr/local/bin/chrome

Aí é só digitar num terminal o comando abaixo e navegar.

$ chrome

Para rodar o Flashplayer no Google Chrome é só fazer o seguinte:

1) como root, crie na pasta do chrome uma nova pasta com nome 'plugins' (no meu caso é a pasta '/opt/google/chrome/', pois uso no Debian):

# mkdir /opt/google/chrome/plugins

2) baixe o pacote do flash player em: http://get.adobe.com/flashplayer/

3) descompacte o pacote baixado:

$ tar -xzvf install_flash_player_xxx_linux.tar.gz

4) copie o arquivo 'libflashplayer.so' do pacote do flash descompactado para a pasta 'plugins' que você criou;

Abra o Google Chrome e digite:

about:plugins

na barra de endereços, vendo se o flash está habilitado. Se não apareceu nada, abra o navegador via terminal com o comando abaixo e digite novamente "about:plugins" . Se aparecer, tente rodar um videozinho do youtube e verifique se tudo está ok:

$ google-chrome --enable-plugins

Se não rodar, pode ser que o seu chrome seja de um build sem habilitação para flash. Pegue a versão mais atual e tente a dica de novo. Caso não saiba qual é o seu build, digite na barra de endereços do Chrome "about:" e você verá uma linha escrito:

Google Chrome    3.0.194.3 (Official Build 20926)

Vemos nesse exemplo que a build é 20926, onde foi testada a dica, e rodou flash na boa. Pode ser que outros usuários tenham algum problema com flash, mas devo lembrar que o Google Chrome ainda está em desenvolvimento e problemas podem ocorrer.

Dúvidas, entrem no IRC do VOL: Canal IRC do VOL - Participe você também!

Até a próxima dica.

Outras dicas deste autor

Usando repositórios do Yum no Zypper do SuSE

Ache vídeos do youtube facilmente

Definindo um tema de cores para o Emacs

Configurar o alsa sem o alsaconf

Mostrar os campos de uma tabela do PostgreSQL com PHP

Leitura recomendada

Atualização do Firefox pelo navegador no Slackware

Assistir vídeos da globo no Debian

Modem 3G da Brasil Telecom no OpenSuSE 11.1

Buscador de MP3

SkipScreen - Agilize seus downloads no Firefox


Comentários
[1] Comentário enviado por femars em 24/07/2009 - 09:53h

Mto boa a dica...vlw....
só uma dúvida... no meu firefox, o flash não roda mto bem, o vídeo fica "travando ou pulando na tela", inclusive tive o mesmo problema no slack, o que vc acho do desempenho no navegador da google?

Parabens pela dica...
[]'s Xiiico.

[2] Comentário enviado por rmchan em 03/08/2009 - 20:25h

Está dica é muito boa... Valeu

[3] Comentário enviado por lminhoka em 11/08/2009 - 21:54h

Conssegui, o único proble é que só inicia via terminal e se o mesmo permancer aberto, algem sabe como resolver isso?

[4] Comentário enviado por albertguedes em 12/08/2009 - 02:19h

@Iminhoka é só você criar um script assim

--------------------------------------
!/bin/sh

google-chrome --enable-plugins

--------------------------------------

salve com o nome 'google-chrome.sh' e dê permissão

$ chmod +x google-chrome


e salve esse script no diretório '/opt/google/chrome-linux/'.

Após isso , crie o link

$ ln -s /opt/google/chrome-linux/google-chrome /usr/local/bin/chrome

em vez do link que descrevi na dica.

Dê um

$ locate chrome

e verifique se ele retorna pelo menos o diretório do link ai pra ter certeza que não tem dois "chrome" no PATH, porque só pode haver um.


[5] Comentário enviado por error13 em 22/08/2009 - 17:49h

o @albert eu consegui fazer funcionar... mais somente como root, pelo terminal!!

pq sera???

e eu tiver coomo user no terminal tb nao funciona
!!!!


[6] Comentário enviado por albertguedes em 23/08/2009 - 10:51h

@error13 Cara, você tem que verificar as permissões de alguma coisa. Pode ser o script ou o binario, dá uma olhada ai é no seu sistema.

[7] Comentário enviado por error13 em 23/08/2009 - 14:16h

o @albertquedes eu refiz o processo esta funcionando mais somente pelo terminal agora...
tentei fazer o esquema do script mais no funciona, qdo eusubstituo o arq google-chrome do /usr/bin ele da erro e nao executa nem pelo terminal!...


qdo eu o removo ele volta funcionar, mais somente pelo terminal!

oq pode ser?

[8] Comentário enviado por albertguedes em 23/08/2009 - 15:08h

@error13 Ah, eu disse ai em cima que é pra fazer um link em '/usr/local/bin' e não '/usr/bin'.
No '/usr/bin' ficam os programas oficiais do sistema, deixe esse diretorio so pra ele, pra artimanhas pessoais sempre use '/usr/local/bin' ou '/opt/bin'

Além do mais, você tem que ter certeza que o '/usr/local/bin' está no PATH do usuario

# echo $PATH

Se não estiver, acrescente com

# setenv PATH="$PATH:/usr/local/bin"

e abra de novo o shell.

[9] Comentário enviado por error13 em 23/08/2009 - 19:37h

certo!
realmente estava vendo errado...depois verifiquei e achei odireitorio!
mais o meu problema esta agora,,,q eu nao consigo criar o link pois jatem o arq com onome!

oq faco nestesentido?

[10] Comentário enviado por markinn91 em 08/09/2009 - 17:08h

Parabéns pelo artigo. Me ajudou muito.
Estou começando agora no Linux e já estou gostando.


[11] Comentário enviado por axshi em 09/12/2009 - 20:58h

Muito boa a dica.

[12] Comentário enviado por ederhba em 25/12/2009 - 14:18h

Iae pessoal...

Sera q vcs podem me ajudar pls... O som do meu PC funfa de boa, mas quando tento escutar algo em um vídeo em flash, não consigo em nenhum dos navegadores que possuo OPERA CHROME E FIREFOX.

Já reinstalei o opera e chrome mas não adiantou.


No aguardo. VLW

[13] Comentário enviado por RenatoSantoss em 25/07/2011 - 13:07h

criando um lançador na area de trabalho.
botão direto do mouse -> criar lançador
Nome = google chrome ou o q vc quiser
digite no terminal
$ which google-chrome
ai vai tar o local geralmente /usr/bin/google-chrome
dai cola no comando = /usr/bin/google-chrome e dê OK
Pronts
By: Renatosantos



Contribuir com comentário