problema ao instalar o gui-ufw [RESOLVIDO]

1. problema ao instalar o gui-ufw [RESOLVIDO]

shoujo
shoujo

(usa Slackware)

Enviado em 30/05/2019 - 20:52h

Olá, estou tentando instalar o gui-ufw, mas estou com problemas, ele da o seguinte erro:
ModuleNotFoundError: No module named 'DistUtilsExtra'

Já instalei o python-distutils-extra, e mesmo assim tá reclamando a dependencia na hora de compilar...


  


2. Re: problema ao instalar o gui-ufw

Izaias
izaias

(usa Ubuntu)

Enviado em 31/05/2019 - 11:42h

shoujo escreveu:

Olá, estou tentando instalar o gui-ufw, mas estou com problemas, ele da o seguinte erro:
ModuleNotFoundError: No module named 'DistUtilsExtra'

Já instalei o python-distutils-extra, e mesmo assim tá reclamando a dependencia na hora de compilar...


Veja a versão do seu Slack primeiro: https://slackbuilds.org/repository/14.2/network/gui-ufw/?search=gui-ufw

** Não esqueça de instalar as dependências primeiro.


3. Re: problema ao instalar o gui-ufw [RESOLVIDO]

Matheus
pylm

(usa Gentoo)

Enviado em 31/05/2019 - 11:46h


shoujo escreveu:

Já instalei o python-distutils-extra, e mesmo assim tá reclamando a dependencia na hora de compilar...


Tens que ver qual versão python o programa usa e daí instalar o módulo pra respectiva versão.
Provavelmente o programa usa python3 e tu instalou a versão python2 do módulo.


4. Re: problema ao instalar o gui-ufw [RESOLVIDO]

shoujo
shoujo

(usa Slackware)

Enviado em 31/05/2019 - 13:05h

pylm escreveu:


shoujo escreveu:

Já instalei o python-distutils-extra, e mesmo assim tá reclamando a dependencia na hora de compilar...


Tens que ver qual versão python o programa usa e daí instalar o módulo pra respectiva versão.
Provavelmente o programa usa python3 e tu instalou a versão python2 do módulo.


Pois é, mas por algum motivo esse pacote python-distutils-extra é para o python2.7, mas nao consigo encontrar a versao pro python3.7


5. Re: problema ao instalar o gui-ufw [RESOLVIDO]

shoujo
shoujo

(usa Slackware)

Enviado em 31/05/2019 - 13:56h

Consegui resolver, bastou compilar manualmente o python-disutils-extra usando o seguinte
PYTHON3=yes ./python-distutils-extra.SlackBuild


6. Re: problema ao instalar o gui-ufw [RESOLVIDO]

shoujo
shoujo

(usa Slackware)

Enviado em 31/05/2019 - 14:03h

Pior que instalou, mas o firewall nao abriu : (






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts