Testes com OpenSUSE Millestone 1, começando a resolver

1. Testes com OpenSUSE Millestone 1, começando a resolver

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 05/06/2011 - 21:14h

Estou fazendo uns testes com o novo openSUSE 12.1.

O KDE nunca abre, volta para tela de login e as vêzes nem o GNOME3 abre, fecha, volta para tela de login e a mensagem de erro é:

"FIBMAP Invalid Argument"

O XFCE e o IceWM abrem, estou escrevendo desse ultimo.

também os efeitos 3D não funcionam, nem com NVIDIA, nem com Nouveau. Sei que o problema tem a ver com driver de video, pq
o GNOME3 só não abre com Nouveau, mas com NVIDIA sim, entretanto o KDE não funciona com nenhum dos dois. Com NV comum, tenho X, mas só o GNOME3 abre.

Mandei um reporto para o Forum e desenvolvedores openSUSE, e estou aguardando a resposta, mas s e alguém aqui conhecer o problema....


  


2. Re: Testes com OpenSUSE Millestone 1, começando a resolver

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 05/06/2011 - 21:24h

agora tenho 3D... removí tudo de NVIDIA, instalei o nouveau no kernel 39, e funcionando ( glxgears,cerca de 4000 FPS), bem bom, até
mas nem GNOME, nem KDE abrem e aparecer o erro acima.

Isso vem a confirmar meus experimentos, no sabayon XFCE tb, o driver Nouveau é bem eficiente em kernel 39.


3. Re: Testes com OpenSUSE Millestone 1, começando a resolver

Fábio Farias
Fabio_Farias

(usa openSUSE)

Enviado em 05/06/2011 - 21:58h

Alberto.
Penso eu que o milestone 1 do openSUSE 11.2 ainda está bem verde (nenhuma relação com a cor da distro rsrsrs).

Drivers como o da nvidia só estarão prontos quando a distro for lançada. Por isso penso que os efeitos visuais durante o desenvolvimento não serão possíveis.

Vamos aguardar como sertá o desenvolvimento. Talvez eu baixe o próximo ou quem sabe o terceiro milestone.

Abraços!


4. Re: Testes com OpenSUSE Millestone 1, começando a resolver

Izaias
izaias

(usa Ubuntu)

Enviado em 05/06/2011 - 22:05h

Qual será a novidade dessa versão? Estou curioso.
Linus lançará em breve o Kernel-3, quem sabe não virá com ele!


5. Re: Testes com OpenSUSE Millestone 1, começando a resolver

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 05/06/2011 - 23:55h

Fábio, os efeitos 3D estão funcionando, agora, com nouveau.

Outras novidades, ex. remasterysys para openSUSE etc...

https://hermes.opensuse.org/feeds/26237.rdf


Apesar disso, com os nvidia dos repos (ativando os repos NVIDIA download) , não foi possivel ativar nada, estou usando o Nouveau, ele funciona bem.

Outra novidade que apenas o GNOME 3 é padrão,o 2 acabou.

mas há reportos já de que o GNOME 3 dá problema com certas placas de vídeo:

http://news.opensuse.org/2011/06/01/first-step-towards-12-1-with-milestone-1/

......pode ser isso o meu problema?, duro que nem KDE funfa, estou escrevendo do IceWM, mas ele não tem 3D.
Se troco o nouveau pelo nv, o GNOME3 roda, mas o KDE não, com NVIDIA, nada! srsrsrr......

Ele tá sim, muito verde e crú! Claro que não é para usar como distro principal, a 12.1 é para testes, não é para usar no dia a dia, a não ser que vc queira VER openSUSE, não USAR openSUSE!rsrsrsrsr


6. Re: Testes com OpenSUSE Millestone 1, começando a resolver

Fábio Farias
Fabio_Farias

(usa openSUSE)

Enviado em 06/06/2011 - 09:27h

Bom saber que com o driver noveau está funcioanndo. Mas IceWM (com todo respeito) é horrível. Agora se dá para utilizar o Xfce tudo bem. Esse é ótimo.

Me diga uma coisa: você baixou o DVD? 32 ou 64 bits? Qual sistema de arquivos é selecionado por omissão durante a instalação?

Izaías
Se o Kernel 3 não demorar pode ser que o openSUSE 12.1 venha com ele. Mas ele tem que sair logo para que possa ser incluído nesses milestones.

Ultimamente estou baixando betas de outra coisa e tenho ajudado em outra área do softwre livre. Mas quero ver se consigo testar esses milestones do openSUSE 12.1 quando saírem.

Abraços!


7. Re: Testes com OpenSUSE Millestone 1, começando a resolver

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 06/06/2011 - 09:38h

Baixei o DVD aquele maior, de 64 Bits, todos os meus Linux são 64 Bits.

Instalei a versão KDE (não é mais como nos antigos, que vc escolhia personalizado, agora ou ele instala KDE ou GNOME), depois instalei XFCE, GNOME etc... usando o YaST.

Acho que quando eu descobrir a causa do problema, vou poder abrir o KDE e o GNOME3, este último, como falei, se eu desativo o nouveau, colocando "nv" no XOrg, ele abre.

Sôbre o GNOME3 (ainda claro, sem 3D) o que estou achando.
Ele instala limpo, não tem icones no desktop, nem faz icones com o botão direito do mouse.
O Menu fica em cima, parecendo o antigo menu.
Para fazer atalhos, vc vai no menu, "pega" o aplicativo, ex. o gnome-terminal, e "arrasta" para a barra de menu ou para o desktop, ele fica, mas o icone não sai mais, ainda não descobri como remove.

Apesar dele estar diferente, ele tem um jeitão de... GNOME...

quando eu conseguir abrir o GNOME3 com 3D, postarei screenshot.

O uso está diferente,não existe mais as opções de configurar painel, acessáveis com o bitão direito do mouse.

Sei que o GNOME3 esta completo, pq como eu queria testar, marquei todos os pacotes de GNOME3 no Yast

O IceWM, abrí. pq como não estava tendo acesso ao KDE, e ainda não tinha instalado nem o GNOME nem o XFCE, eu precisava abrir alguma coisa, para usar a Rede, o YaST etc...

Sistema de arquivos padrão é o Ext4, usei ext4 para Raiz,/ e xfs para a /home.

O openSUSE novo dá uma mensagem de que se o usuário quiser pode usar brtFS, como escolha, uma mensagem em vermelho, mas não usei. tenho costume de usar ou Ext4 ou reiserfs. No Gentoo, Sabayon etc... costumo usar ReiserFS


8. Re: Testes com OpenSUSE Millestone 1, começando a resolver

Fábio Farias
Fabio_Farias

(usa openSUSE)

Enviado em 06/06/2011 - 11:08h

“Baixei o DVD aquele maior, de 64 Bits, todos os meus Linux são 64 Bits.”

Hum...eu costumo baixar o 32 bits.

“Instalei a versão KDE (não é mais como nos antigos, que vc escolhia personalizado, agora ou ele instala KDE ou GNOME), depois instalei XFCE, GNOME etc... usando o YaST.”

Isso daqui eu não entendi. Significa que na tela de escolha da interface só há Gnome e Kde? Aquele botão “Outro” (para selecionar Xfce, Lxde, Gráfico Mínimo e Modo Texto) não existe mais?

“Sistema de arquivos padrão é o Ext4, usei ext4 para Raiz,/ e xfs para a /home.”

Certo. Pensei que iam colocar o Btrfs como padrão uma vez que parece mesmo que será o sistema de arquivos padrão dos Linux. Talvez ele ainda não seja bootável.

Obrigado Alberto.
Pelo jeito vou ter que baixar esse mesmo para saber como andam as coisas rsrsrsrs.

Valeu.
Abraços!


9. Meus reportos iniciais dos testes.

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 06/06/2011 - 16:02h

Fábio...

Exatamente, o botão OUTROS, o PERSONALIZAR, não está presente no millestone 1, vc começa instalando GNOME ou KDE, e depois instala os outros ambientes gráficos, com YaST, por ex.

sim vc pode testar o BRTfs, eu nõa usei, só. segundo se lê no DVD, o Brtfs do Millestone 1, È BOOTÁVEL.

Meus testes, fui reportar o problema de não abrir KDE e nem GNOME no Forum openSUSE para os desenvolvedores verem, mas achei! é BUG conhecido do Millestone1:

http://forums.opensuse.org/english/get-technical-help-here/pre-release-beta/460489-schedule-12-1-m1-...

Citação, no Link:

The GNOME one "FAILS TO LOAD GNOME3", but I played (and won of course a
round of freecell solitaire as Live-CD User, so I'd say it's good enough for a
Milestone 1 ;-)

Se for testar, recomendo que instale em outra partição limpa de seu HDD, e não como openSUSE "principal", ele está muito "VERDE" rsrsrsrs para uso rotineiro rsrsrsrsrsrs

mais "verde" que de costume! Já é Verde por Natureza, né? prá mim que sou palmeirense! P Palmeiras é o "Verdão", openSUSE é um outro "Verdão"!
srrsrsrs srrsrsrsrr


10. Re: Testes com OpenSUSE Millestone 1, começando a resolver

Fábio Farias
Fabio_Farias

(usa openSUSE)

Enviado em 06/06/2011 - 17:11h

“Exatamente, o botão OUTROS, o PERSONALIZAR, não está presente no millestone 1, vc começa instalando GNOME ou KDE, e depois instala os outros ambientes gráficos, com YaST, por ex.”

Esse é um diferencial e tanto para mim. Sempre gostei do esquema de oferecer as principais interfaces gráficas durante a instalação pelo DVD. Vou ter mesmo que baixar essa versão para ver o que está mudando.

“sim vc pode testar o BRTfs, eu nõa usei, só. segundo se lê no DVD, o Brtfs do Millestone 1, È BOOTÁVEL.”

Se ele é bootável agora (não precisa mais de uma pequena partição em Ext para o /boot) eu vou testar com o Btrfs.

“Meus testes, fui reportar o problema de não abrir KDE e nem GNOME no Forum openSUSE para os desenvolvedores verem, mas achei! é BUG conhecido do Millestone1”

Se é bug conhecido não há o que fazer. O jeito é esperar a correção, seja em forma de atualização ou no Milestone 2


“Se for testar, recomendo que instale em outra partição limpa de seu HDD, e não como openSUSE "principal", ele está muito "VERDE" rsrsrsrs para uso rotineiro rsrsrsrsrsrs”

É..vou colocar ele em uma máquina virtual...ou fazer isso que você indicou. O problema é arrumar espaço rsrsrsrsrsr.

“mais "verde" que de costume! Já é Verde por Natureza, né? prá mim que sou palmeirense! P Palmeiras é o "Verdão", openSUSE é um outro "Verdão"!
srrsrsrs srrsrsrsrr”

é muito mais verde que de costume. Embora seja uma distro madura (17 anos) é verde como meu Palmeiras (também sou palmeirense) e Verde como meu Coritiba (Coxa).

Mas a razão de usar o openSUSE não é por causa de sua cor!

Você me deixou curioso. Vou baixar e testar esse milestone 1.

Abraços!


11. Re: Testes com OpenSUSE Millestone 1, começando a resolver

Fábio Farias
Fabio_Farias

(usa openSUSE)

Enviado em 07/06/2011 - 23:35h

Alberto

Eu baixei e testei o Milestone 1 do 12.1 e:

- De fato o Kde não inicia. Tive que usar o IceWM também.
- O Btrfs ainda não é bootável. Necessita de uma pequena partição em Ext para o /boot
- A opção "Outro" para a escolha da interface gráfica ainda persiste. A tela a qual me refiro é essa:

http://img.vivaolinux.com.br/imagens/artigos/comunidade/thumb_Imagem%2010.jpeg

E nesse tela ainda pode-se escolher qual interface deseja instalar.

Mas ainda tá meio bugada mesmo. Vou esperar o Milestone 2 para voltar a usá-lo.

Abraços e obrigado pelas informações sobre o novo openSUSE.


12. Re: Testes com OpenSUSE Millestone 1, começando a resolver

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 09/06/2011 - 19:44h

O KDE opção PLASMA abre.... e funciona! Inclusive os efeitos 3D.

screenshot simples, antes de ativar o Kwin 3D:

http://www.brimg.info/uploads/4/9576ad9042.png

o GNOME3, continua com problemas, só usando nv ele funciona, não dá pra usar Nouveau nem NVIDIA, ele só funciona sem a 3D portanto,mas a opção Plasma do KDE funciona com Kwin e o XFCE funciona com compiz.
driver 3D nouveau

Sim Fábio, agora estou mexendo nas coonfigs do GNOME3, para ver pq não abre com 3D ativado.

também já atualizei tudo, com Zypper dup, pq assim começo a pegar os pacotes que vão ser da Millestone 2.

Estou em contacto com Forum do openSUSE, para ver como estão as coisas, reportar Bugs etc..

é fase de testes, eu gosto, faço isso com outras distros tb, Mandriva, Gentoo etc...
tanto pq minha distro do dia a dia é Sabayon.
Como eu tenho comp multidistro, não fico nunca sem computador.



01 02 03



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts