Testes para monitoração de Zabbix.

1. Testes para monitoração de Zabbix.

gabriel jesus
frodopuc

(usa Ubuntu)

Enviado em 23/12/2019 - 10:41h

Caros,
instalei o zabbix server + client num servidor e esta monitorando perfeito (servidor ubuntu 18)
porem, instalei o zabbix client (seguindo passos de varios sites e do proprio site do zabbix) em outro servidor (debian) e não está coletando dados.

O que pode ser o erro? quais testes eu posso fazer pra verificar onde errei?


  


2. Re: Testes para monitoração de Zabbix.

Leandro Silva
LSSilva

(usa Outra)

Enviado em 25/12/2019 - 14:15h

Processo tem que estar rodando; arquivo de configuração tem que estar condizente com o IP do seu server zabbix e, se estiverem em redes distintas e houver NAT entre elas, terá que colocar o IP do Gateway como IP do servidor. De toda forma, se houver problemas de rede, o log do Zabbix client costuma entregar.


3. Re: Testes para monitoração de Zabbix.

gabriel jesus
frodopuc

(usa Ubuntu)

Enviado em 26/12/2019 - 11:15h

LSSilva escreveu:

Processo tem que estar rodando; arquivo de configuração tem que estar condizente com o IP do seu server zabbix e, se estiverem em redes distintas e houver NAT entre elas, terá que colocar o IP do Gateway como IP do servidor. De toda forma, se houver problemas de rede, o log do Zabbix client costuma entregar.


Por partes:
Processo tem que estar rodando:
-> O processo está rodando no servidor em que o Zabbix foi instalado. Consigo monitorar o próprio servidor e ainda coletar logs e gráficos.
-> No cliente o serviço está rodando. Dentro da página do zabbix eu vou em Configuração -> Hosts e vejo o Servidor com status de ATIVO, Disponibilidade com ZBX em verde, criptografia NENHUM.

Arquivo de configuração condizente com o IP do seu server zabbix:
o Server=IP_DO_SERVIDOR_ZABBIX
o ServerActive=IP_DO_SERVIDOR_ZABBIX
Então acredito que esteja tudo certinho

Estão na mesma rede, não precisa de NAT.

Eu abri agora a tela de incidentes do servidor cliente e mostra uns alertas:
telnet service is down on Cliente ( verifiquei de novo e já esta Running )
LDAP service is down on Cliente ( verifiquei de novo e já esta Running )
node_exporter is not available (cliquei em get node metrics e está zerado)
Apache: Process is not running ( verifiquei de novo e já esta Running )

Eu queria monitorar armazenamento, cpu e memoria, mas quando abro o gráfico esta tudo zerado.
o Cliente faz parte do grupo Linux Servers
o Em templates eu adicionei HTTP service, LDAP Service, SSH service, Telnet service e Module Linux network...
o Não consigo Template Module Linux CPU by Zabbix agent (erro O gráfico "CPU jumps" já existe em "Servidor" (com itens diferentes).

E agora?






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts