KDE Plasma com problemas de acentuação

1. KDE Plasma com problemas de acentuação

Mariana Dantas dos Santos
MarianaDantas

(usa Linux Mint)

Enviado em 09/09/2020 - 00:04h

Boa noite, gente.

Esses dias, estava tentando instalar o Scrivener através do Wine, tanto no meu computador como no computador da minha irmã. Depois de muitos problemas eu finalmente consegui, e o programa funcionou perfeitamente no meu computador. Só que quando fui instalar no dela, ela disse que estava com problemas com os acentos. Eu tinha instalado no dela antes usando o CrossOver, e ela relatou o mesmo problema depois de um tempo, só que ela disse que esse problema não estava no momento da instalação. Só apareceu depois de um tempo de uso. E aí, quando instalei usando o Wine "puro" (na linha de comando), ela imediatamente disse que o problema se repetia.

O problema é o seguinte: só funciona o acento agudo com a letra a. Isso significa que qualquer outro acento e qualquer outra letra apertada, vai ficar sempre "á".

Inicialmente, eu achei que o problema seria com o programa, mas acho que não pode ser, porque no meu funcionou perfeitamente. E eu utilizei o mesmo método de instalação em ambos os sistemas, repeti todos os processos que fiz sem alteração nenhuma. Então acredito que o problema seja com o SO dela mesmo. Ela utiliza o Kubuntu 20.04, com KDE Plasma 5.18.5.

Eu vi aqui que outros tópicos chegaram a ser abertos referente a problema de acentos no KDE Plasma, mas a descrição dos problemas era um pouco diferente do problema que estamos sendo agora. De qualquer forma, eu tentei tudo que foi descrito nos tópicos por desencargo de consciência, e nada funcionou. Caso seja de alguma ajuda, vou linkar os tópicos que testei:

https://www.vivaolinux.com.br/topico/KDE/KDE-Plasma-514-com-problemas-de-acentuacao
https://www.vivaolinux.com.br/topico/KDE-4/Acentos-no-kde-nao-sao-colocados-nas-letras/
https://www.vivaolinux.com.br/topico/Kubuntu/Acentuacao-KUBUNTU-1504

Espero que consigam me ajudar a resolver esse problema. Agradeço desde já.


  


2. Re: KDE Plasma com problemas de acentuação

Andre (pinduvoz)
pinduvoz

(usa Debian)

Enviado em 09/09/2020 - 00:20h


Tente a solução da dica abaixo antes de abrir o programa onde os acentos não funcionam.

https://www.vivaolinux.com.br/dica/Teclado-ABNT2-pelo-Terminal/

Se não funcionar, tente com o programa problemático aberto.

A dica só serve para teclado ABNT ou ABNT2, ou seja, teclados com o "ç".


3. Re: KDE Plasma com problemas de acentuação

Mariana Dantas dos Santos
MarianaDantas

(usa Linux Mint)

Enviado em 09/09/2020 - 08:37h

pinduvoz escreveu:


Tente a solução da dica abaixo antes de abrir o programa onde os acentos não funcionam.

https://www.vivaolinux.com.br/dica/Teclado-ABNT2-pelo-Terminal/

Se não funcionar, tente com o programa problemático aberto.

A dica só serve para teclado ABNT ou ABNT2, ou seja, teclados com o "ç".


Olá, bom dia. Infelizmente, não funcionou.

Na verdade, acabei percebendo mais algumas particularidades a respeito do problema. Aparentemente, quando abro o programa e digito um acento qualquer com uma letra específica, por exemplo, "á", ele não vai aceitar quaisquer outras combinações além dessa. Então qualquer combinação que eu digitar depois desse "á", sempre vai ficar "á". Mas, se eu fechar o programa e depois abri-lo de novo, e colocar outro acento, por exemplo "ô", então ele vai usar só "ô" pra todos os outros acentos que eu colocar.

Será que é possível resolver esse problema?






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts