Driver de rede não carrega

1. Driver de rede não carrega

johnf
johnf

(usa Slackware)

Enviado em 22/08/2019 - 14:40h

Fala galera!
Instalei o Slackware Current x64 em um Notebook Positivo Master N350i, o driver wireless funciona perfeitamente, porém, a interface ETH0 não carrega nem por reza. Já busquei em vários fóruns algumas soluções, mas nada até agora funcionou, o módulo kernel e1000e não funciona de jeito nenhum.
O que eu já fiz:
1- Baixei o driver atualizado no site da intel (e1000e-3.5.1) e tentei instalar, a saída do comando é essa:
bash-5.0# make install
make -C /lib/modules/4.19.67/build CC=gcc SUBDIRS=/home/johnf/Downloads/e1000e-3.5.1/src modules
make[1]: Entering directory '/usr/src/linux-4.19.67'
Building modules, stage 2.
MODPOST 1 modules
make[1]: Leaving directory '/usr/src/linux-4.19.67'
gzip -c ../e1000e.7 > e1000e.7.gz
# remove all old versions of the driver
find /lib/modules/4.19.67 -name e1000e.ko -exec rm -f {} \; || true
find /lib/modules/4.19.67 -name e1000e.ko.gz -exec rm -f {} \; || true
install -D -m 644 e1000e.ko /lib/modules/4.19.67/updates/drivers/net/ethernet/intel/e1000e/e1000e.ko
/sbin/depmod -a 4.19.67 || true
install -D -m 644 e1000e.7.gz /usr/man/man7/e1000e.7.gz
man -c -P'cat > /dev/null' e1000e || true
man:
não foi possível escrever em /var/cache/man/usr-man/cat7/e1000e.7.gz no modo catman
e1000e.


2- Saída do comando lspci -vknn:
00:19.0 Ethernet controller [0200]: Intel Corporation Ethernet Connection I217-LM [8086:153a] (rev 05)
Subsystem: CLEVO/KAPOK Computer Ethernet Connection I217-LM [1558:0940]
Flags: bus master, fast devsel, latency 0, IRQ 5
Memory at f7c00000 (32-bit, non-prefetchable) [size=128K]
Memory at f7c3d000 (32-bit, non-prefetchable) [size=4K]
I/O ports at f080 [size=32]
Capabilities: [c8] Power Management version 2
Capabilities: [d0] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [e0] PCI Advanced Features
Kernel modules: e1000e


3- Saída do comando ifconfig -a:
bash-5.0# ifconfig -a
lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 1000 (Local Loopback)
RX packets 328 bytes 19156 (18.7 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 328 bytes 19156 (18.7 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.0.240 netmask 255.255.255.0 broadcast 192.168.0.255
inet6 fe80::9814:87a3:a1db:63fe prefixlen 64 scopeid 0x20<link>
ether 80:86:f2:73:2a:f3 txqueuelen 1000 (Ethernet)
RX packets 3803038 bytes 2381032723 (2.2 GiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 1203562 bytes 853809608 (814.2 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0


4- lsmod:
i2c_core               77824  7 videodev,drm_kms_helper,i2c_algo_bit,i2c_i801,i915,psmouse,drm
snd 90112 21 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_timer,snd_hda_codec_via,snd_pcm
battery 24576 0
mei_me 32768 0
tpm_tis 16384 0
e1000e 225280 0
lpc_ich 28672 0
tpm_tis_core 20480 1 tpm_tis
ehci_pci 16384 0
mei 81920 1 mei_me
video 45056 1 i915
soundcore 16384 1 snd
button 16384 0
ac 16384 0
ehci_hcd 61440 1 ehci_pci
xhci_pci 16384 0
xhci_hcd 241664 1 xhci_pci
tpm 65536 3 tpm_tis,tpm_infineon,tpm_tis_core
pcc_cpufreq 16384 0
loop 36864 0



Mesmo rodando os comandos modprobe ou mesmo insmod, a interface não carrega.
Bom, se alguém puder me dar alguma ideia agradeceria muito!
Valeu!




  


2. Re: Driver de rede não carrega

asdfg
ppa-DO_MAL

(usa Slackware)

Enviado em 23/08/2019 - 03:36h

não entendo muito de rede mais pelo que eu sei eth0 é rede cabeada
ta funcionando a internet via cabo ?
também tem o comando iwconfig para placas wireles






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts