Estou tendo problemas ao instalar o repositório do Java, ele da esse erro

1. Estou tendo problemas ao instalar o repositório do Java, ele da esse erro

Hélio Matheus Gonçalves Figueira David
heliodavid

(usa Linux Mint)

Enviado em 09/05/2020 - 01:33h

Traceback (most recent call last):
File "/usr/bin/add-apt-repository", line 95, in <module>
sp = SoftwareProperties(options=options)
File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 109, in __init__
self.reload_sourceslist()
File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 599, in reload_sourceslist
self.distro.get_sources(self.sourceslist)
File "/usr/lib/python3/dist-packages/aptsources/distro.py", line 93, in get_sources
(self.id, self.codename))
aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template for Deepin/n/a


Me ajudem, por favor, preciso do java com extrema urgência


  


2. Fé

Xe Roberto
esmeril968

(usa Outra)

Enviado em 09/05/2020 - 07:23h

Esse tipo de blog é de grande importância para todos aqueles que, como eu, têm um conhecimento muito limitado sobre criptomoedas e outros métodos de pagamento virtual. Espero que eles me ajudem a esclarecer alguns problemas. FÉ


3. aptsources.distro.NoDistroTemplateException

Marcos Fernandes
markirius

(usa Arch Linux)

Enviado em 09/05/2020 - 08:20h

o que ocorre...
o repositório que você está usando não atende a sua distro "Deepin" (se não for essa, você addicionou um repositório de forma incorreta no source list)...
- você pode/deve procurar algum repositório adequado para o Deepin (uma alternativa pode ser o linuxuprising java)
- instalar manualmente ou até mesmo optar pelo OpenJDK
- caso seja de extrema necessidade usar a versão java da oracle... bem...

eu fiz um script de instalação utilizando um mirror para distros atualizadas baseadas em ubuntu:

https://github.com/markirius/ubuntu_java_install

você pode seguir os passos manualmente lendo o script ou mesmo executar o script.

espero que ajude.


4. Re: Estou tendo problemas ao instalar o repositório do Java, ele da esse erro

Adriano Siqueira
adrisiq

(usa Linux Mint)

Enviado em 09/05/2020 - 09:52h

Para instalar o Java da Oracle no Linux, siga esse passo-a-passo: https://sites.google.com/view/instalar-java-oracle-linux/home






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts