Problema com dpkg com apt upgrade [RESOLVIDO]

1. Problema com dpkg com apt upgrade [RESOLVIDO]

Rafael Balderrama
Flycean

(usa Linux Mint)

Enviado em 10/09/2019 - 12:44h

Olá,
Sou novo no mundo linux e no fórum. Estou aprendendo sobre linux, e estou com o seguinte problema numa máquina com linux mint ao tentar dar upgrade:

User02@Jovi:~$ sudo apt upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
6 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y

Setting up linux-headers-4.15.0-60-generic (4.15.0-60.67) ...
/etc/kernel/header_postinst.d/dkms:
* dkms: running auto installation service for kernel 4.15.0-60-generic
Error! Could not locate dkms.conf file.
File: does not exist.
...fail!
run-parts: /etc/kernel/header_postinst.d/dkms exited with return code 4
dpkg: error processing package linux-headers-4.15.0-60-generic (--configure):
installed linux-headers-4.15.0-60-generic package post-installation script subprocess returned error exit status 1
Setting up linux-headers-4.15.0-62-generic (4.15.0-62.69) ...
/etc/kernel/header_postinst.d/dkms:
* dkms: running auto installation service for kernel 4.15.0-62-generic
Error! Could not locate dkms.conf file.
File: does not exist.
...fail!
run-parts: /etc/kernel/header_postinst.d/dkms exited with return code 4
dpkg: error processing package linux-headers-4.15.0-62-generic (--configure):
installed linux-headers-4.15.0-62-generic package post-installation script subprocess returned error exit status 1
Setting up linux-image-4.15.0-62-generic (4.15.0-62.69) ...
Setting up linux-image-4.15.0-60-generic (4.15.0-60.67) ...
I: /initrd.img.old is now a symlink to boot/initrd.img-4.15.0-60-generic
dpkg: dependency problems prevent configuration of linux-headers-generic:
linux-headers-generic depends on linux-headers-4.15.0-62-generic; however:
Package linux-headers-4.15.0-62-generic is not configured yet.

dpkg: error processing package linux-headers-generic (--configure):
dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of linux-generic:
linux-generic depends on linux-headers-generic (= 4.15.0.62.64); however:
Package linux-headers-generic is not configured yet.

dpkg: error processing package linux-generic (--configure):
dependency problems - leaving unconfigured
Processing triggers for linux-image-4.15.0-62-generic (4.15.0-62.69) ...
/etc/kernel/postinst.d/dkms:
* dkms: running auto installation service for kernel 4.15.0-62-generic
Error! Could not locate dkms.conf file.
File: does not exist.
...fail!
run-parts: /etc/kernel/postinst.d/dkms exited with return code 4
dpkg: error processing package linux-image-4.15.0-62-generic (--configure):
installed linux-image-4.15.0-62-generic package post-installation script subprocess returned error exit status 1
No apport report written because MaxReports is reached already
Processing triggers for linux-image-4.15.0-60-generic (4.15.0-60.67) ...
/etc/kernel/postinst.d/dkms:
* dkms: running auto installation service for kernel 4.15.0-60-generic
Error! Could not locate dkms.conf file.
File: does not exist.
...fail!
run-parts: /etc/kernel/postinst.d/dkms exited with return code 4
dpkg: error processing package linux-image-4.15.0-60-generic (--configure):
installed linux-image-4.15.0-60-generic package post-installation script subprocess returned error exit status 1
No apport report written because MaxReports is reached already
Errors were encountered while processing:
linux-headers-4.15.0-60-generic
linux-headers-4.15.0-62-generic
linux-headers-generic
linux-generic
linux-image-4.15.0-62-generic
linux-image-4.15.0-60-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)

Com certeza foi alguma falha na instalação ou remoção do dpkg. Tentei restaurar porém não há imagens de backup para salvar do desastre e o pc está com alguns arquivos importantes... o que me resta tentar solucionar esse problema.

Alguma sugestão - passo a passo - para me ajudar, por favor?


  


2. Re: Problema com dpkg com apt upgrade

Edivan  Santtos
edivandjs

(usa Debian)

Enviado em 10/09/2019 - 15:25h

sudo apt-get update

$ sudo apt-get upgrade

$ sudo apt-get dist-upgrade

Esses são os mais usados, creio.

Digite no terminal $ man apt

e terá o manual de uso.
________________
“Quem combate monstruosidades deve cuidar para que não se torne um monstro. E se você olhar longamente para um abismo, o abismo também olha para dentro de você”
Nietzsche.


3. Re: Problema com dpkg com apt upgrade [RESOLVIDO]

Irova
Irova

(usa Linux Mint)

Enviado em 10/09/2019 - 15:28h

Primeiro tente o seguinte comando e cole o resultado
sudo dpkg --configure -a 



---------------------

Nem sempre é necessário formatar! (ou não).


4. Re: Problema com dpkg com apt upgrade [RESOLVIDO]

Rafael Balderrama
Flycean

(usa Linux Mint)

Enviado em 10/09/2019 - 16:04h

[quote]Irova escreveu:

Primeiro tente o seguinte comando e cole o resultado
sudo dpkg --configure -a 



Segue resultado:

User02@Jovi:~$ sudo dpkg --configure -a
[sudo] password for User02:
Setting up linux-headers-4.15.0-60-generic (4.15.0-60.67) ...
/etc/kernel/header_postinst.d/dkms:
* dkms: running auto installation service for kernel 4.15.0-60-generic
Error! Could not locate dkms.conf file.
File: does not exist.
...fail!
run-parts: /etc/kernel/header_postinst.d/dkms exited with return code 4
dpkg: error processing package linux-headers-4.15.0-60-generic (--configure):
installed linux-headers-4.15.0-60-generic package post-installation script subprocess returned error exit status 1
Setting up linux-headers-4.15.0-62-generic (4.15.0-62.69) ...
/etc/kernel/header_postinst.d/dkms:
* dkms: running auto installation service for kernel 4.15.0-62-generic
Error! Could not locate dkms.conf file.
File: does not exist.
...fail!
run-parts: /etc/kernel/header_postinst.d/dkms exited with return code 4
dpkg: error processing package linux-headers-4.15.0-62-generic (--configure):
installed linux-headers-4.15.0-62-generic package post-installation script subprocess returned error exit status 1
Setting up linux-image-4.15.0-62-generic (4.15.0-62.69) ...
I: /initrd.img is now a symlink to boot/initrd.img-4.15.0-62-generic
Setting up linux-image-4.15.0-60-generic (4.15.0-60.67) ...
I: /initrd.img.old is now a symlink to boot/initrd.img-4.15.0-60-generic
dpkg: dependency problems prevent configuration of linux-headers-generic:
linux-headers-generic depends on linux-headers-4.15.0-62-generic; however:
Package linux-headers-4.15.0-62-generic is not configured yet.

dpkg: error processing package linux-headers-generic (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-generic:
linux-generic depends on linux-headers-generic (= 4.15.0.62.64); however:
Package linux-headers-generic is not configured yet.

dpkg: error processing package linux-generic (--configure):
dependency problems - leaving unconfigured
Processing triggers for linux-image-4.15.0-62-generic (4.15.0-62.69) ...
/etc/kernel/postinst.d/dkms:
* dkms: running auto installation service for kernel 4.15.0-62-generic
Error! Could not locate dkms.conf file.
File: does not exist.
...fail!
run-parts: /etc/kernel/postinst.d/dkms exited with return code 4
dpkg: error processing package linux-image-4.15.0-62-generic (--configure):
installed linux-image-4.15.0-62-generic package post-installation script subprocess returned error exit status 1
Processing triggers for linux-image-4.15.0-60-generic (4.15.0-60.67) ...
/etc/kernel/postinst.d/dkms:
* dkms: running auto installation service for kernel 4.15.0-60-generic
Error! Could not locate dkms.conf file.
File: does not exist.
...fail!
run-parts: /etc/kernel/postinst.d/dkms exited with return code 4
dpkg: error processing package linux-image-4.15.0-60-generic (--configure):
installed linux-image-4.15.0-60-generic package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
linux-headers-4.15.0-60-generic
linux-headers-4.15.0-62-generic
linux-headers-generic
linux-generic
linux-image-4.15.0-62-generic
linux-image-4.15.0-60-generic


5. Re: Problema com dpkg com apt upgrade

Irova
Irova

(usa Linux Mint)

Enviado em 10/09/2019 - 16:12h

Flycean escreveu:

[quote]Irova escreveu:

Primeiro tente o seguinte comando e cole o resultado
sudo dpkg --configure -a 



Segue resultado:

User02@Jovi:~$ sudo dpkg --configure -a
[sudo] password for User02:
Setting up linux-headers-4.15.0-60-generic (4.15.0-60.67) ...
/etc/kernel/header_postinst.d/dkms:
* dkms: running auto installation service for kernel 4.15.0-60-generic
Error! Could not locate dkms.conf file.
File: does not exist.
...fail!
run-parts: /etc/kernel/header_postinst.d/dkms exited with return code 4
dpkg: error processing package linux-headers-4.15.0-60-generic (--configure):
installed linux-headers-4.15.0-60-generic package post-installation script subprocess returned error exit status 1
Setting up linux-headers-4.15.0-62-generic (4.15.0-62.69) ...
/etc/kernel/header_postinst.d/dkms:
* dkms: running auto installation service for kernel 4.15.0-62-generic
Error! Could not locate dkms.conf file.
File: does not exist.
...fail!
run-parts: /etc/kernel/header_postinst.d/dkms exited with return code 4
dpkg: error processing package linux-headers-4.15.0-62-generic (--configure):
installed linux-headers-4.15.0-62-generic package post-installation script subprocess returned error exit status 1
Setting up linux-image-4.15.0-62-generic (4.15.0-62.69) ...
I: /initrd.img is now a symlink to boot/initrd.img-4.15.0-62-generic
Setting up linux-image-4.15.0-60-generic (4.15.0-60.67) ...
I: /initrd.img.old is now a symlink to boot/initrd.img-4.15.0-60-generic
dpkg: dependency problems prevent configuration of linux-headers-generic:
linux-headers-generic depends on linux-headers-4.15.0-62-generic; however:
Package linux-headers-4.15.0-62-generic is not configured yet.

dpkg: error processing package linux-headers-generic (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-generic:
linux-generic depends on linux-headers-generic (= 4.15.0.62.64); however:
Package linux-headers-generic is not configured yet.

dpkg: error processing package linux-generic (--configure):
dependency problems - leaving unconfigured
Processing triggers for linux-image-4.15.0-62-generic (4.15.0-62.69) ...
/etc/kernel/postinst.d/dkms:
* dkms: running auto installation service for kernel 4.15.0-62-generic
Error! Could not locate dkms.conf file.
File: does not exist.
...fail!
run-parts: /etc/kernel/postinst.d/dkms exited with return code 4
dpkg: error processing package linux-image-4.15.0-62-generic (--configure):
installed linux-image-4.15.0-62-generic package post-installation script subprocess returned error exit status 1
Processing triggers for linux-image-4.15.0-60-generic (4.15.0-60.67) ...
/etc/kernel/postinst.d/dkms:
* dkms: running auto installation service for kernel 4.15.0-60-generic
Error! Could not locate dkms.conf file.
File: does not exist.
...fail!
run-parts: /etc/kernel/postinst.d/dkms exited with return code 4
dpkg: error processing package linux-image-4.15.0-60-generic (--configure):
installed linux-image-4.15.0-60-generic package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
linux-headers-4.15.0-60-generic
linux-headers-4.15.0-62-generic
linux-headers-generic
linux-generic
linux-image-4.15.0-62-generic
linux-image-4.15.0-60-generic

Tente:
sudo apt update --fix-missing 

depois
sudo dpkg --configure -a 

depois
sudo rm /var/lib/apt/lists/lock 

depois
sudo rm /var/cache/apt/archives/lock 

e por último
apt full-upgrade 

agora se não funcionar é brabo o problema

---------------------

Nem sempre é necessário formatar! (ou não).


6. Re: Problema com dpkg com apt upgrade [RESOLVIDO]

Rafael Balderrama
Flycean

(usa Linux Mint)

Enviado em 10/09/2019 - 16:31h


Tente:
sudo apt update --fix-missing 

depois
sudo dpkg --configure -a 

depois
sudo rm /var/lib/apt/lists/lock 

depois
sudo rm /var/cache/apt/archives/lock 

e por último
apt full-upgrade 

agora se não funcionar é brabo o problema

---------------------
Fiz todas as etapas que disse, essa foi a última saída depois do apt full-upgrade.
Pelo jeito o problema é brabo... vc acha que é um caso de formatar o pc? Em que casos essa falha do dpkg no upgrade pode me atrapalhar futuramente?

Setting up linux-headers-4.15.0-60-generic (4.15.0-60.67) ...
/etc/kernel/header_postinst.d/dkms:
* dkms: running auto installation service for kernel 4.15.0-60-generic
Error! Could not locate dkms.conf file.
File: does not exist.
...fail!
run-parts: /etc/kernel/header_postinst.d/dkms exited with return code 4
dpkg: error processing package linux-headers-4.15.0-60-generic (--configure):
installed linux-headers-4.15.0-60-generic package post-installation script subprocess returned error exit status 1
Setting up linux-headers-4.15.0-62-generic (4.15.0-62.69) ...
/etc/kernel/header_postinst.d/dkms:
* dkms: running auto installation service for kernel 4.15.0-62-generic
Error! Could not locate dkms.conf file.
File: does not exist.
...fail!
run-parts: /etc/kernel/header_postinst.d/dkms exited with return code 4
dpkg: error processing package linux-headers-4.15.0-62-generic (--configure):
installed linux-headers-4.15.0-62-generic package post-installation script subprocess returned error exit status 1
Setting up linux-image-4.15.0-62-generic (4.15.0-62.69) ...
I: /initrd.img is now a symlink to boot/initrd.img-4.15.0-62-generic
Setting up linux-image-4.15.0-60-generic (4.15.0-60.67) ...
I: /initrd.img.old is now a symlink to boot/initrd.img-4.15.0-60-generic
dpkg: dependency problems prevent configuration of linux-headers-generic:
linux-headers-generic depends on linux-headers-4.15.0-62-generic; however:
Package linux-headers-4.15.0-62-generic is not configured yet.

dpkg: error processing package linux-headers-generic (--configure):
dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of linux-generic:
linux-generic depends on linux-headers-generic (= 4.15.0.62.64); however:
Package linux-headers-generic is not configured yet.

dpkg: error processing package linux-generic (--configure):
dependency problems - leaving unconfigured
Processing triggers for linux-image-4.15.0-62-generic (4.15.0-62.69) ...
/etc/kernel/postinst.d/dkms:
* dkms: running auto installation service for kernel 4.15.0-62-generic
Error! Could not locate dkms.conf file.
File: does not exist.
...fail!
run-parts: /etc/kernel/postinst.d/dkms exited with return code 4
dpkg: error processing package linux-image-4.15.0-62-generic (--configure):
installed linux-image-4.15.0-62-generic package post-installation script subprocess returned error exit status 1
No apport report written because MaxReports is reached already
Processing triggers for linux-image-4.15.0-60-generic (4.15.0-60.67) ...
/etc/kernel/postinst.d/dkms:
* dkms: running auto installation service for kernel 4.15.0-60-generic
Error! Could not locate dkms.conf file.
File: does not exist.
...fail!
run-parts: /etc/kernel/postinst.d/dkms exited with return code 4
dpkg: error processing package linux-image-4.15.0-60-generic (--configure):
installed linux-image-4.15.0-60-generic package post-installation script subprocess returned error exit status 1
No apport report written because MaxReports is reached already
Errors were encountered while processing:
linux-headers-4.15.0-60-generic
linux-headers-4.15.0-62-generic
linux-headers-generic
linux-generic
linux-image-4.15.0-62-generic
linux-image-4.15.0-60-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)



7. Re: Problema com dpkg com apt upgrade [RESOLVIDO]

Irova
Irova

(usa Linux Mint)

Enviado em 10/09/2019 - 16:36h

Flycean escreveu:


Tente:
sudo apt update --fix-missing 

depois
sudo dpkg --configure -a 

depois
sudo rm /var/lib/apt/lists/lock 

depois
sudo rm /var/cache/apt/archives/lock 

e por último
apt full-upgrade 

agora se não funcionar é brabo o problema

---------------------
Fiz todas as etapas que disse, essa foi a última saída depois do apt full-upgrade.
Pelo jeito o problema é brabo... vc acha que é um caso de formatar o pc? Em que casos essa falha do dpkg no upgrade pode me atrapalhar futuramente?

Setting up linux-headers-4.15.0-60-generic (4.15.0-60.67) ...
/etc/kernel/header_postinst.d/dkms:
* dkms: running auto installation service for kernel 4.15.0-60-generic
Error! Could not locate dkms.conf file.
File: does not exist.
...fail!
run-parts: /etc/kernel/header_postinst.d/dkms exited with return code 4
dpkg: error processing package linux-headers-4.15.0-60-generic (--configure):
installed linux-headers-4.15.0-60-generic package post-installation script subprocess returned error exit status 1
Setting up linux-headers-4.15.0-62-generic (4.15.0-62.69) ...
/etc/kernel/header_postinst.d/dkms:
* dkms: running auto installation service for kernel 4.15.0-62-generic
Error! Could not locate dkms.conf file.
File: does not exist.
...fail!
run-parts: /etc/kernel/header_postinst.d/dkms exited with return code 4
dpkg: error processing package linux-headers-4.15.0-62-generic (--configure):
installed linux-headers-4.15.0-62-generic package post-installation script subprocess returned error exit status 1
Setting up linux-image-4.15.0-62-generic (4.15.0-62.69) ...
I: /initrd.img is now a symlink to boot/initrd.img-4.15.0-62-generic
Setting up linux-image-4.15.0-60-generic (4.15.0-60.67) ...
I: /initrd.img.old is now a symlink to boot/initrd.img-4.15.0-60-generic
dpkg: dependency problems prevent configuration of linux-headers-generic:
linux-headers-generic depends on linux-headers-4.15.0-62-generic; however:
Package linux-headers-4.15.0-62-generic is not configured yet.

dpkg: error processing package linux-headers-generic (--configure):
dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of linux-generic:
linux-generic depends on linux-headers-generic (= 4.15.0.62.64); however:
Package linux-headers-generic is not configured yet.

dpkg: error processing package linux-generic (--configure):
dependency problems - leaving unconfigured
Processing triggers for linux-image-4.15.0-62-generic (4.15.0-62.69) ...
/etc/kernel/postinst.d/dkms:
* dkms: running auto installation service for kernel 4.15.0-62-generic
Error! Could not locate dkms.conf file.
File: does not exist.
...fail!
run-parts: /etc/kernel/postinst.d/dkms exited with return code 4
dpkg: error processing package linux-image-4.15.0-62-generic (--configure):
installed linux-image-4.15.0-62-generic package post-installation script subprocess returned error exit status 1
No apport report written because MaxReports is reached already
Processing triggers for linux-image-4.15.0-60-generic (4.15.0-60.67) ...
/etc/kernel/postinst.d/dkms:
* dkms: running auto installation service for kernel 4.15.0-60-generic
Error! Could not locate dkms.conf file.
File: does not exist.
...fail!
run-parts: /etc/kernel/postinst.d/dkms exited with return code 4
dpkg: error processing package linux-image-4.15.0-60-generic (--configure):
installed linux-image-4.15.0-60-generic package post-installation script subprocess returned error exit status 1
No apport report written because MaxReports is reached already
Errors were encountered while processing:
linux-headers-4.15.0-60-generic
linux-headers-4.15.0-62-generic
linux-headers-generic
linux-generic
linux-image-4.15.0-62-generic
linux-image-4.15.0-60-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)

Com essa falha do dpkg e apt não será possível nem atualizar, remover pacotes e instalar pacotes via apt, tente criar um tópico com o nome "DPKG/APT CORROMPIDOS", assim usuários mais avançados poderão te ajudar, caso ainda não obtenha resposta, a solução é formatar, mas me fala hein, como você conseguiu um erro tão grave desse jeito, conseguiu converter o baidu.exe para baidu.deb? huahuahauha.




---------------------

Nem sempre é necessário formatar! (ou não).


8. Re: Problema com dpkg com apt upgrade [RESOLVIDO]

Edivan  Santtos
edivandjs

(usa Debian)

Enviado em 10/09/2019 - 16:45h

Flycean escreveu:


Tente:
sudo apt update --fix-missing 

depois
sudo dpkg --configure -a 

depois
sudo rm /var/lib/apt/lists/lock 

depois
sudo rm /var/cache/apt/archives/lock 

e por último
apt full-upgrade 

agora se não funcionar é brabo o problema

---------------------
Fiz todas as etapas que disse, essa foi a última saída depois do apt full-upgrade.
Pelo jeito o problema é brabo... vc acha que é um caso de formatar o pc? Em que casos essa falha do dpkg no upgrade pode me atrapalhar futuramente?

Setting up linux-headers-4.15.0-60-generic (4.15.0-60.67) ...
/etc/kernel/header_postinst.d/dkms:
* dkms: running auto installation service for kernel 4.15.0-60-generic
Error! Could not locate dkms.conf file.
File: does not exist.
...fail!
run-parts: /etc/kernel/header_postinst.d/dkms exited with return code 4
dpkg: error processing package linux-headers-4.15.0-60-generic (--configure):
installed linux-headers-4.15.0-60-generic package post-installation script subprocess returned error exit status 1
Setting up linux-headers-4.15.0-62-generic (4.15.0-62.69) ...
/etc/kernel/header_postinst.d/dkms:
* dkms: running auto installation service for kernel 4.15.0-62-generic
Error! Could not locate dkms.conf file.
File: does not exist.
...fail!
run-parts: /etc/kernel/header_postinst.d/dkms exited with return code 4
dpkg: error processing package linux-headers-4.15.0-62-generic (--configure):
installed linux-headers-4.15.0-62-generic package post-installation script subprocess returned error exit status 1
Setting up linux-image-4.15.0-62-generic (4.15.0-62.69) ...
I: /initrd.img is now a symlink to boot/initrd.img-4.15.0-62-generic
Setting up linux-image-4.15.0-60-generic (4.15.0-60.67) ...
I: /initrd.img.old is now a symlink to boot/initrd.img-4.15.0-60-generic
dpkg: dependency problems prevent configuration of linux-headers-generic:
linux-headers-generic depends on linux-headers-4.15.0-62-generic; however:
Package linux-headers-4.15.0-62-generic is not configured yet.

dpkg: error processing package linux-headers-generic (--configure):
dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of linux-generic:
linux-generic depends on linux-headers-generic (= 4.15.0.62.64); however:
Package linux-headers-generic is not configured yet.

dpkg: error processing package linux-generic (--configure):
dependency problems - leaving unconfigured
Processing triggers for linux-image-4.15.0-62-generic (4.15.0-62.69) ...
/etc/kernel/postinst.d/dkms:
* dkms: running auto installation service for kernel 4.15.0-62-generic
Error! Could not locate dkms.conf file.
File: does not exist.
...fail!
run-parts: /etc/kernel/postinst.d/dkms exited with return code 4
dpkg: error processing package linux-image-4.15.0-62-generic (--configure):
installed linux-image-4.15.0-62-generic package post-installation script subprocess returned error exit status 1
No apport report written because MaxReports is reached already
Processing triggers for linux-image-4.15.0-60-generic (4.15.0-60.67) ...
/etc/kernel/postinst.d/dkms:
* dkms: running auto installation service for kernel 4.15.0-60-generic
Error! Could not locate dkms.conf file.
File: does not exist.
...fail!
run-parts: /etc/kernel/postinst.d/dkms exited with return code 4
dpkg: error processing package linux-image-4.15.0-60-generic (--configure):
installed linux-image-4.15.0-60-generic package post-installation script subprocess returned error exit status 1
No apport report written because MaxReports is reached already
Errors were encountered while processing:
linux-headers-4.15.0-60-generic
linux-headers-4.15.0-62-generic
linux-headers-generic
linux-generic
linux-image-4.15.0-62-generic
linux-image-4.15.0-60-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)



sudo dpkg --clear-avail && sudo apt-get update

se ainda estiver aí, qual o resultado do comando acima?
___
“Quem combate monstruosidades deve cuidar para que não se torne um monstro. E se você olhar longamente para um abismo, o abismo também olha para dentro de você”
Nietzsche.


9. Re: Problema com dpkg com apt upgrade [RESOLVIDO]

Paulo Jr
Pebis

(usa Debian)

Enviado em 10/09/2019 - 16:46h


O problema é no dkms

Dá uma olhada como root!

dkms status
dkms autoinstall


10. Re: Problema com dpkg com apt upgrade [RESOLVIDO]

Rafael Balderrama
Flycean

(usa Linux Mint)

Enviado em 10/09/2019 - 16:51h


sudo dpkg --clear-avail && sudo apt-get update

se ainda estiver aí, qual o resultado do comando acima?
___
“Quem combate monstruosidades deve cuidar para que não se torne um monstro. E se você olhar longamente para um abismo, o abismo também olha para dentro de você”
Nietzsche.[/quote]

sudo dpkg --clear-avail && sudo apt-get update
Hit:1 http://download.virtualbox.org/virtualbox/debian bionic InRelease
Hit:2 https://repo.skype.com/deb stable InRelease
Ign:3 http://dl.google.com/linux/chrome/deb stable InRelease
Ign:4 http://packages.linuxmint.com tessa InRelease
Hit:5 http://archive.canonical.com/ubuntu bionic InRelease
Hit:6 http://dl.google.com/linux/chrome/deb stable Release
Get:7 http://repository.spotify.com stable InRelease [3.316 B]
Hit:8 http://packages.linuxmint.com tessa Release
Hit:9 http://archive.ubuntu.com/ubuntu bionic InRelease
Hit:10 http://security.ubuntu.com/ubuntu bionic-security InRelease
Err:7 http://repository.spotify.com stable InRelease
The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 4773BD5E130D1D45
Hit:13 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:14 http://archive.ubuntu.com/ubuntu bionic-backports InRelease
Reading package lists... Done
W: GPG error: http://repository.spotify.com stable InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 4773BD5E130D1D45
E: The repository 'http://repository.spotify.com stable InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.



11. Re: Problema com dpkg com apt upgrade [RESOLVIDO]

Rafael Balderrama
Flycean

(usa Linux Mint)

Enviado em 10/09/2019 - 17:08h

Pebis escreveu:


O problema é no dkms

Dá uma olhada como root!

dkms status
dkms autoinstall



Essa foi a saída:
sudo dkms status
8812au, 4.2.2: added
nvidia, 430.26, 4.15.0-58-generic, x86_64: installed

sudo dkms autoinstall
Error! Could not locate dkms.conf file.
File: does not exist.



12. Re: Problema com dpkg com apt upgrade [RESOLVIDO]

Rafael Balderrama
Flycean

(usa Linux Mint)

Enviado em 10/09/2019 - 17:50h

Galera, consegui resolver depois de algumas horas de pesquisa pela fonte:

https://phoenixnap.com/kb/fix-sub-process-usr-bin-dpkg-returned-error-code-1

Realizei os passos 1, 2 e 3.
No passo 3, tive que dar purge pacote por pacote que estavam danificados.

No fim, update && upgrade e tudo certo.
*Foi necessário baixar e reinstalar pacote por pacote avulso que dei purge.

Obrigado pela atenção e apoio!






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts