Problema ao tentar usar o msfvenom

1. Problema ao tentar usar o msfvenom

Helvio
kvothe

(usa Ubuntu)

Enviado em 31/05/2019 - 11:49h

Iai, pessoal, estou tentando usar o msfvenom e quando digito por exemplo ""msfvenom -l payloads"" ele me da a seguinte resposta em vez de me mostrar os payloads:

Traceback (most recent call last):
36: from /opt/metasploit/apps/pro/vendor/bundle/ruby/2.5.0/bin/msfvenom:23:in `<main>'
35: from /opt/metasploit/apps/pro/vendor/bundle/ruby/2.5.0/bin/msfvenom:23:in `load'
34: from /opt/metasploit/apps/pro/vendor/bundle/ruby/2.5.0/gems/metasploit-framework-4.17.56/msfvenom:377:in `<top (required)>'
33: from /opt/metasploit/apps/pro/vendor/bundle/ruby/2.5.0/gems/metasploit-framework-4.17.56/msfvenom:377:in `each'
32: from /opt/metasploit/apps/pro/vendor/bundle/ruby/2.5.0/gems/metasploit-framework-4.17.56/msfvenom:380:in `block in <top (required)>'
31: from /opt/metasploit/apps/pro/vendor/bundle/ruby/2.5.0/gems/metasploit-framework-4.17.56/msfvenom:307:in `dump_payloads'
30: from /opt/metasploit/apps/pro/vendor/bundle/ruby/2.5.0/gems/metasploit-framework-4.17.56/msfvenom:36:in `init_framework'
29: from /opt/metasploit/apps/pro/vendor/bundle/ruby/2.5.0/gems/metasploit-framework-4.17.56/msfvenom:18:in `require_deps'
28: from /opt/metasploit/apps/pro/vendor/bundle/ruby/2.5.0/gems/metasploit-framework-4.17.56/msfvenom:18:in `require'
27: from /opt/metasploit/apps/pro/vendor/bundle/ruby/2.5.0/gems/metasploit-framework-4.17.56/lib/msfenv.rb:18:in `<top (required)>'
26: from /opt/metasploit/apps/pro/vendor/bundle/ruby/2.5.0/gems/metasploit-framework-4.17.56/lib/msfenv.rb:18:in `require'
25: from /opt/metasploit/apps/pro/vendor/bundle/ruby/2.5.0/gems/metasploit-framework-4.17.56/config/environment.rb:5:in `<top (required)>'
24: from /opt/metasploit/apps/pro/vendor/bundle/ruby/2.5.0/gems/railties-4.2.11.1/lib/rails/railtie.rb:194:in `method_missing'
23: from /opt/metasploit/apps/pro/vendor/bundle/ruby/2.5.0/gems/railties-4.2.11.1/lib/rails/railtie.rb:194:in `public_send'
22: from /opt/metasploit/apps/pro/vendor/bundle/ruby/2.5.0/gems/railties-4.2.11.1/lib/rails/application.rb:352:in `initialize!'
21: from /opt/metasploit/apps/pro/vendor/bundle/ruby/2.5.0/gems/railties-4.2.11.1/lib/rails/initializable.rb:54:in `run_initializers'
20: from /opt/metasploit/ruby/lib/ruby/2.5.0/tsort.rb:205:in `tsort_each'
19: from /opt/metasploit/ruby/lib/ruby/2.5.0/tsort.rb:226:in `tsort_each'
18: from /opt/metasploit/ruby/lib/ruby/2.5.0/tsort.rb:347:in `each_strongly_connected_component'
17: from /opt/metasploit/ruby/lib/ruby/2.5.0/tsort.rb:347:in `call'
16: from /opt/metasploit/ruby/lib/ruby/2.5.0/tsort.rb:347:in `each'
15: from /opt/metasploit/ruby/lib/ruby/2.5.0/tsort.rb:349:in `block in each_strongly_connected_component'
14: from /opt/metasploit/ruby/lib/ruby/2.5.0/tsort.rb:431:in `each_strongly_connected_component_from'
13: from /opt/metasploit/ruby/lib/ruby/2.5.0/tsort.rb:350:in `block (2 levels) in each_strongly_connected_component'
12: from /opt/metasploit/ruby/lib/ruby/2.5.0/tsort.rb:228:in `block in tsort_each'
11: from /opt/metasploit/apps/pro/vendor/bundle/ruby/2.5.0/gems/railties-4.2.11.1/lib/rails/initializable.rb:55:in `block in run_initializers'
10: from /opt/metasploit/apps/pro/vendor/bundle/ruby/2.5.0/gems/railties-4.2.11.1/lib/rails/initializable.rb:30:in `run'
9: from /opt/metasploit/apps/pro/vendor/bundle/ruby/2.5.0/gems/railties-4.2.11.1/lib/rails/initializable.rb:30:in `instance_exec'
8: from /opt/metasploit/apps/pro/vendor/bundle/ruby/2.5.0/gems/railties-4.2.11.1/lib/rails/application/finisher.rb:56:in `block in <module:Finisher>'
7: from /opt/metasploit/apps/pro/vendor/bundle/ruby/2.5.0/gems/railties-4.2.11.1/lib/rails/application/finisher.rb:56:in `each'
6: from /opt/metasploit/apps/pro/vendor/bundle/ruby/2.5.0/gems/railties-4.2.11.1/lib/rails/engine.rb:346:in `eager_load!'
5: from /opt/metasploit/apps/pro/vendor/bundle/ruby/2.5.0/gems/railties-4.2.11.1/lib/rails/engine.rb:469:in `eager_load!'
4: from /opt/metasploit/apps/pro/vendor/bundle/ruby/2.5.0/gems/railties-4.2.11.1/lib/rails/engine.rb:469:in `each'
3: from /opt/metasploit/apps/pro/vendor/bundle/ruby/2.5.0/gems/railties-4.2.11.1/lib/rails/engine.rb:471:in `block in eager_load!'
2: from /opt/metasploit/apps/pro/vendor/bundle/ruby/2.5.0/gems/railties-4.2.11.1/lib/rails/engine.rb:471:in `each'
1: from /opt/metasploit/apps/pro/vendor/bundle/ruby/2.5.0/gems/railties-4.2.11.1/lib/rails/engine.rb:472:in `block (2 levels) in eager_load!'
/opt/metasploit/apps/pro/vendor/bundle/ruby/2.5.0/gems/wicked-0.5.0/app/controllers/wicked/wizard_controller.rb:5:in `<top (required)>': uninitialized constant ApplicationController (NameError)

Alguem poderia me ajudar a resolver?


  


2. Re: Problema ao tentar usar o msfvenom

Ruan
ru4n

(usa Debian)

Enviado em 31/05/2019 - 21:07h

Tenta reinstalar o metasploit.

--
Linux Counter: #596371


3. Re: Problema ao tentar usar o msfvenom

Helvio
kvothe

(usa Ubuntu)

Enviado em 01/06/2019 - 15:59h

ru4n escreveu:

Tenta reinstalar o metasploit.

--
Linux Counter: #596371


Opa, consegui, obrigado






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts