Não encontro os firmwares para meu notebook [RESOLVIDO]

1. Não encontro os firmwares para meu notebook [RESOLVIDO]

Robson Dantas
rdaguiar

(usa Debian)

Enviado em 26/09/2019 - 12:44h

robson@debian:~$ sudo dmesg | grep firmware

[ 0.210311] Spectre V2 : Enabling Restricted Speculation for firmware calls
[ 1.756859] i915 0000:00:02.0: firmware: direct-loading firmware i915/kbl_dmc_ver1_04.bin
[ 1.757375] [drm] Finished loading DMC firmware i915/kbl_dmc_ver1_04.bin (v1.4)
[ 11.277977] ath10k_pci 0000:02:00.0: firmware: failed to load ath10k/pre-cal-pci-0000:02:00.0.bin (-2)
[ 11.278073] firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware
[ 11.278199] ath10k_pci 0000:02:00.0: firmware: failed to load ath10k/cal-pci-0000:02:00.0.bin (-2)
[ 11.384377] ath10k_pci 0000:02:00.0: firmware: direct-loading firmware ath10k/QCA9377/hw1.0/firmware-6.bin
[ 11.385891] ath10k_pci 0000:02:00.0: firmware ver WLAN.TF.2.1-00021-QCARMSWP-1 api 6 features wowlan,ignore-otp crc32 42e41877
[ 11.519282] ath10k_pci 0000:02:00.0: firmware: direct-loading firmware ath10k/QCA9377/hw1.0/board-2.bin
[ 15.808232] r8169 0000:01:00.0: firmware: direct-loading firmware rtl_nic/rtl8106e-1.fw

Alguém poderia me ajudar a corrigir isso?
Já tentei instalar (até atualizei) os firmwares da versão sid e nada!
A descrição do dmesg acima está informando a situação atual, após atualizar o firmware da versão sid.

Usando o Debian 10.1 (atualizado)
Mate 1.20.4
Notebook Samsung E30 - NP350XAA-KF4BR
Site: https://www.samsung.com/br/support/model/NP350XAA-KF4BR/

Qualquer ajuda é bem-vinda.



  


2. MELHOR RESPOSTA

niquelnausea
niquelnausea

(usa Arch Linux)

Enviado em 26/09/2019 - 22:07h

mensagem de erro não necessariamente significa que algo não esta funcionando, ou funciona errado. toda distro com systemd, dependendo do nível de informação, apresenta quilo de erro. tanto que o playmouth tai para "melhorar" isso.

3. Re: Não encontro os firmwares para meu notebook [RESOLVIDO]

niquelnausea
niquelnausea

(usa Arch Linux)

Enviado em 26/09/2019 - 13:54h

o que especificamente não esta funcionando? wifi?


4. Re: Não encontro os firmwares para meu notebook [RESOLVIDO]

Fernando T. Da Silva
nandosilva

(usa Salix)

Enviado em 26/09/2019 - 19:38h

Como o colega perguntou o que não está funcionando neste notebook ?
Eu por exemplo tenho o mesmo note um Samsung E30 modelo NP350XAA-KF3BR, praticamente igual ao seu, apenas que o seu termina com KF4BR o que indica que houve alguma modificação pela fabricante em alguma parte do hardware. No meu tenho instalado o Lubuntu 16.04 64 bits, onde funciona o wifi, bluetooth, placa de rede cabeada, webcam, som e driver de vídeo onboard Intel tudo nativo pelo Linux.




5. Re: Não encontro os firmwares para meu notebook [RESOLVIDO]

Robson Dantas
rdaguiar

(usa Debian)

Enviado em 26/09/2019 - 20:54h


Quando instalei o Linux Mint Cinnamon 19.2 Tina funcionou bem, mas não consigo ficar longe do Debian...
Pois, e esses erros que aparecem na inicialização, algo tá errado!!
O dmesg é grande, apenas dei um grep firmware para resumir, entende?
Bom, não sei o que falta, sei que aparece no boot essas msgs de erro, talvez parte do firmware não funcione como deveria...
No Mint em uma ferramenta chamada de ddm que verifica isso, tentei instalar mas é incompatível com o Debian, mesmo sendo um .deb, cheguei a editar o .deb e recriá-lo mas não deu certo.

Bom, se ninguém sabe, vamos deixar rolar...
O Debian é assim mesmo, não gosta de acompanhar tecnologias, gosta de estabilidade com hardwares velhos, rsrsrs

blz. Grato pela ajuda.




6. Re: Não encontro os firmwares para meu notebook

linuxlts
linuxlts

(usa Debian)

Enviado em 26/09/2019 - 22:40h

Caso não tenha instalado os pacotes que contem o firmware que esta sendo pedido, tente instalar eles:

# apt install firmware-misc-nonfree

# apt install firmware-atheros

# apt install firmware-realtek

E instale também o pacote intel-microcode:

# apt install intel-microcode


7. Re: Não encontro os firmwares para meu notebook [RESOLVIDO]

Robson Dantas
rdaguiar

(usa Debian)

Enviado em 27/09/2019 - 07:06h


linuxlts escreveu:

Caso não tenha instalado os pacotes que contem o firmware que esta sendo pedido, tente instalar eles:

# apt install firmware-misc-nonfree

# apt install firmware-atheros

# apt install firmware-realtek

E instale também o pacote intel-microcode:

# apt install intel-microcode


Já estão todos instalados, acho que ficará assim mesmo, ignorar esses erros e continuar, mas vou pesquisar e tentar ver se consigo descobrir algo.
Tem um site de atualização de firmwares ( https://github.com/kvalo/ath10k-firmware/tree/master/QCA9377/hw1.0 )
...para atualizar tenho de instalar tudo manualmente compilando junto ao kernel, né?

valeu pessoal, vou pesquisar mais...


8. Re: Não encontro os firmwares para meu notebook [RESOLVIDO]

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 27/09/2019 - 08:21h

Aqui eu testei live-iso do Buster e minha wi-fi foi detectada automaticamente

Qual é sua Wi-Fi: Realtek, Atheros, Ralink, Broadcom ?




9. Re: Não encontro os firmwares para meu notebook [RESOLVIDO]

Robson Dantas
rdaguiar

(usa Debian)

Enviado em 27/09/2019 - 09:16h


clodoaldops escreveu:

Aqui eu testei live-iso do Buster e minha wi-fi foi detectada automaticamente

Qual é sua Wi-Fi: Realtek, Atheros, Ralink, Broadcom ?



Minha wifi está funcionando, o problema dela é que só funcionava a 2.4 G, 5G não pegava, só no Windows.
Então, seguindo uma dica de 2017 consegui agora colocar a 5G numa boa, os testes de velocidade ultrapassam os 200 MB. rsrsrs

Mas os erros continuam, acho que são partes do firmware que não funcionam e geram os erros.



10. Re: Não encontro os firmwares para meu notebook [RESOLVIDO]

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 27/09/2019 - 10:59h

Wi-Fi funciona?
Som funciona?
Vídeo funciona?
Teclado funciona?
Webcam funciona?
Headset funciona?
Mouse sem fio funciona?
Teclado sem fio funciona?

Se resposta for sim para todas as perguntas acima é pq não falta nenhum firmaware





11. Re: Não encontro os firmwares para meu notebook [RESOLVIDO]

Glaulher Ramalho Medeiros
GRM

(usa Void Linux)

Enviado em 27/09/2019 - 14:36h


rdaguiar escreveu:


clodoaldops escreveu:

Aqui eu testei live-iso do Buster e minha wi-fi foi detectada automaticamente

Qual é sua Wi-Fi: Realtek, Atheros, Ralink, Broadcom ?



Minha wifi está funcionando, o problema dela é que só funcionava a 2.4 G, 5G não pegava, só no Windows.
Então, seguindo uma dica de 2017 consegui agora colocar a 5G numa boa, os testes de velocidade ultrapassam os 200 MB. rsrsrs

Mas os erros continuam, acho que são partes do firmware que não funcionam e geram os erros.


Chefe coloque a dica aqui que poderá servir para outro

Disciplina é liberdade
Compaixão é fortaleza
Ter bondade é ter coragem






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts