Erro de repositório ao tentar efetuar um update/install

1. Erro de repositório ao tentar efetuar um update/install

Deivis Gonçaves
DeivisG

(usa Debian)

Enviado em 08/07/2021 - 11:31h

Salve,

Pessoal, recentemente comecei a trabalhar com uma máquina que opera como servidor utilizando a distribuição debian na versão 7.0 (eu sei que está obsoleta). Para a execução normal no dia a dia não há problemas, o problema aparece quando há necessidade de efetuar uma instalação ou update de uma ferramenta já existente. Pesquisei e vi que o repositório "wheezy" está desativado e já não recebe atualizações. Estou precisando instalar o rsync nessa máquina para fins de backup, porem aparece o erro abaixo na saída do apt-get install rsync, gostaria que se possível me apresentassem uma solução que não envolva atualizar o sistema pelo menos nesse momento. Segue arquivo sources.list abaixo!

###### Debian Main Repos
deb http://ftp.au.debian.org/debian/ wheezy main contrib non-free
deb-src http://ftp.au.debian.org/debian/ wheezy main contrib non-free

###### Debian Update Repos
deb http://security.debian.org/ wheezy/updates main contrib non-free
deb http://ftp.au.debian.org/debian/ wheezy-proposed-updates main contrib non-free
deb-src http://security.debian.org/ wheezy/updates main contrib non-free
deb-src http://ftp.au.debian.org/debian/ wheezy-proposed-updates main contrib non-free


  


2. Re: Erro de repositório ao tentar efetuar um update/install

josinaldo
-josinaldo-

(usa KUbuntu)

Enviado em 08/07/2021 - 11:57h

No pkgs.org tem o pacote para o Debian 9:
https://pkgs.org/download/rsync

Baixe e instala via terminal ( # apt install ./*.deb )





3. Re: Erro de repositório ao tentar efetuar um update/install

Ryuk Shinigami
Ryuk

(usa Nenhuma)

Enviado em 08/07/2021 - 12:34h

Para continuar usando uma versão obsoleta, mude os repositórios para "archive.debian.org":
https://www.howtoforge.com/using-old-debian-versions-in-your-sources.list

Dessa forma você poderá instalar programas normalmente via apt.



4. Re: Erro de repositório ao tentar efetuar um update/install

Suri Mukeba
kwami

(usa Debian)

Enviado em 08/07/2021 - 15:04h


-josinaldo- escreveu:

No pkgs.org tem o pacote para o Debian 9:
https://pkgs.org/download/rsync

Baixe e instala via terminal ( # apt install ./*.deb )




Ele está no Wheezy (Debian 7), provavelmente o pacote deb do 9 vai sugerir atualização das dependências, tipo: o pacote rsync depende de xxxx >= 2.xx.yyy. Penso que nesse caso deveria começar por um pacote do 8 (Jessie), que ainda assim, pode não funcionar devido ao longo período que o Debian sai de uma versão a outra, logo, a compatibilidade é da recente para a anterior e não o contrário. Todavia, tente!

A melhor maneira é o usar os repositórios de arquivo.


5. Re: Erro de repositório ao tentar efetuar um update/install

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 08/07/2021 - 15:15h

Por que Linux obsoleto, sem suporte e sem atualizações?









Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts