Impressora CUPS falha em alguns clientes Windows [RESOLVIDO]

1. Impressora CUPS falha em alguns clientes Windows [RESOLVIDO]

Carlos Sluzala
sluzala

(usa Debian)

Enviado em 11/01/2019 - 09:44h

Olá pessoal, sou novato com Linux e preciso de uma ajuda de vocês:

Configurei um servidor de impressão CUPS com uma HP Officejet Pro 8610 que funciona normalmente em vários computadores da empresa com Windows 10, 7 ou 8. Porém em 2 deles não funciona de jeito nenhum. Consigo adicioná-la, mas ao enviar a impressão é informado que a impressora está em estado de erro.
Verifiquei o log de erro do CUPS mas não retorna nada, então acredito que a requisição de impressão não está nem chegando no meu servidor.

Pinguei essas máquinas que não imprimem e elas não retornam nada.

Obrigado desde já!


  


2. Re: Impressora CUPS falha em alguns clientes Windows [RESOLVIDO]

Paulo Bonfanti
pbonfanti

(usa Debian)

Enviado em 14/01/2019 - 08:19h

sluzala escreveu:

Olá pessoal, sou novato com Linux e preciso de uma ajuda de vocês:

Configurei um servidor de impressão CUPS com uma HP Officejet Pro 8610 que funciona normalmente em vários computadores da empresa com Windows 10, 7 ou 8. Porém em 2 deles não funciona de jeito nenhum. Consigo adicioná-la, mas ao enviar a impressão é informado que a impressora está em estado de erro.
Verifiquei o log de erro do CUPS mas não retorna nada, então acredito que a requisição de impressão não está nem chegando no meu servidor.

Pinguei essas máquinas que não imprimem e elas não retornam nada.

Obrigado desde já!


Vou deduzir que com 'não retornam nada' você significa que o ping retornou 'online'.

Pare o spool de impressão dos clientes com problema.
Esvazie o diretorio de spool deles e desinstale qualquer driver antigo de impressora que possa conflitar.
Instale outra versão de driver no cliente pode ser o da hp8600,ou talvez até um driver genérico PCL 3.



3. Re: Impressora CUPS falha em alguns clientes Windows [RESOLVIDO]

Carlos Sluzala
sluzala

(usa Debian)

Enviado em 30/01/2019 - 07:41h

pbonfanti escreveu:

sluzala escreveu:

Olá pessoal, sou novato com Linux e preciso de uma ajuda de vocês:

Configurei um servidor de impressão CUPS com uma HP Officejet Pro 8610 que funciona normalmente em vários computadores da empresa com Windows 10, 7 ou 8. Porém em 2 deles não funciona de jeito nenhum. Consigo adicioná-la, mas ao enviar a impressão é informado que a impressora está em estado de erro.
Verifiquei o log de erro do CUPS mas não retorna nada, então acredito que a requisição de impressão não está nem chegando no meu servidor.

Pinguei essas máquinas que não imprimem e elas não retornam nada.

Obrigado desde já!


Vou deduzir que com 'não retornam nada' você significa que o ping retornou 'online'.

Pare o spool de impressão dos clientes com problema.
Esvazie o diretorio de spool deles e desinstale qualquer driver antigo de impressora que possa conflitar.
Instale outra versão de driver no cliente pode ser o da hp8600,ou talvez até um driver genérico PCL 3.


Eu pingava e eles não retornavam online. Percebi que isso acontecia somente com máquinas de IP dinâmico. Depois de muitas tentativas mudei eles para fixo, instalei a impressora e retornei a para dinâmico. Resolveu! Obrigado pela ajuda.







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts