Linux: architecture i386 x ou + amd64? [RESOLVIDO]

1. Linux: architecture i386 x ou + amd64? [RESOLVIDO]

Mc Sampaio
mcsbru

(usa Linux Mint)

Enviado em 22/01/2019 - 17:08h

Boa tarde companheiros.
Gostaria de tirar uma dúvida. Se eu tenho um sistema amd64 (x84-64), é usual no linux se carregar no sistema suportes à i386?
Ou pode have incompatibilidade? (Ou é fundamental para que o sistema x64 entenda também softwares 32bits?
Tenho alguns avisos de erros em atualizações e gostaria de receber vossa ajuda. Uma delas, segue abaixo, que surgiu ao fazer "update" do sistema:

"An error occurred during the signature verification.
The repository is not updated and the previous index files will be used.
GPG error: https://dl.winehq.org/wine-builds/ubuntu xenial InRelease:
As assinaturas a seguir não puderam ser verificadas devido à chave
pública não estar disponível: NO_PUBKEY 76F1A20FF987672FSkipping
acquire of configured file 'main/binary-i386/Packages' as repository
'http://dl.google.com/linux/earth/deb stable InRelease' doesn't support
architecture 'i386'
Falhou ao buscar https:
//dl.winehq.org/wine-builds/ubuntu/dists/xenial/InRelease
As assinaturas a seguir não puderam ser verificadas devido à chave
pública não estar disponível:
NO_PUBKEY 76F1A20FF987672F
Falhou o download de alguns ficheiros de índice. Foram ignorados ou
os antigos foram usados em seu lugar."

Não entendi o por que de as chaves públicas não estarem disponíveis, se é questão do site ou erro em
minha configurações.
Alguém pode me orientar por favor? Muito obrigado.

Sampaio



  


2. Re: Linux: architecture i386 x ou + amd64? [RESOLVIDO]

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 22/01/2019 - 17:13h


mcsbru escreveu:

Não entendi o por que de as chaves públicas não estarem disponíveis, se é questão do site ou erro em
minha configurações.
Alguém pode me orientar por favor? Muito obrigado.

Sampaio


Não estão disponíveis pq vc não instalou ... simples assim ... kkkkk

instala aí
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 76F1A20FF987672F 



------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




3. Re: Linux: architecture i386 x ou + amd64? [RESOLVIDO]

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 22/01/2019 - 17:14h

-vc não consegue instalar programas-64bits num linux-32bits
-google-earth e google-chrome só existem versões 64 bits há algum tempo





4. Re: Linux: architecture i386 x ou + amd64? [RESOLVIDO]

Mc Sampaio
mcsbru

(usa Linux Mint)

Enviado em 22/01/2019 - 20:48h

Mauriciodez escreveu:


mcsbru escreveu:

Não entendi o por que de as chaves públicas não estarem disponíveis, se é questão do site ou erro em
minha configurações.
Alguém pode me orientar por favor? Muito obrigado.

Sampaio


Não estão disponíveis pq vc não instalou ... simples assim ... kkkkk

instala aí
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 76F1A20FF987672F 



------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------



Valeu Maurício.
Muito obrigado.

Vou aproveitar a deixa então.
Instalei a chave pública e refiz o update, o obtive esta resposta ao final:

"Lendo listas de pacotes... Pronto
N: Omitiendo el uso del fichero configurado «main/binary-i386/Packages» ya que el repositorio «http://dl.google.com/linux/earth/deb stable InRelease» no admite la arquitectura «i386»
W: Falhou ao buscar http://packages.domain.com/dists/xenial/InRelease Não foi possível conectar em packages.domain.com:80 (127.0.0.1). - connect (111: Conexão recusada)
W: Falhou o download de alguns ficheiros de índice. Foram ignorados ou os antigos foram usados em seu lugar."

Minha máquina é um amd64, com processador A10.
São estes tipos de avisos de "architecture i386" que tenho recebido. Não sei o que está errado com relação a isto. Este é o porque de eu ter criado este tópico.
Pode me ajudar por favor?




5. Re: Linux: architecture i386 x ou + amd64? [RESOLVIDO]

Mc Sampaio
mcsbru

(usa Linux Mint)

Enviado em 22/01/2019 - 20:49h

clodoaldops escreveu:

-vc não consegue instalar programas-64bits num linux-32bits
-google-earth e google-chrome só existem versões 64 bits há algum tempo






Olá.
Minha máquina é um amd64 (x86-64). Não entendi a tua colocação.



6. Re: Linux: architecture i386 x ou + amd64? [RESOLVIDO]

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 22/01/2019 - 21:13h


mcsbru escreveu:
Olá.
Minha máquina é um amd64 (x86-64). Não entendi a tua colocação.


A sua máquina pode ser 64, mas vc deve ter instalado um 32 !!! manda aí
uname -m 


------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




7. Re: Linux: architecture i386 x ou + amd64? [RESOLVIDO]

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 22/01/2019 - 21:24h

'http://dl.google.com/linux/earth/deb stable InRelease' doesn't support architecture 'i386'

-isso significa que está tentando instalar google-earth num sistema i386/bits
-não é não ??



8. Re: Linux: architecture i386 x ou + amd64? [RESOLVIDO]

Mc Sampaio
mcsbru

(usa Linux Mint)

Enviado em 22/01/2019 - 21:30h

clodoaldops escreveu:

'http://dl.google.com/linux/earth/deb stable InRelease' doesn't support architecture 'i386'

-isso significa que está tentando instalar google-earth num sistema i386/bits
-não é não ??


Eu estava aplicando update. Devo ter copiado o comando de algum site para a instalação do google earth, e não entendi a função do "i386".
Obrigado pela orientação.
Como faço para desfazer estas instalações erradas do i386?



9. Re: Linux: architecture i386 x ou + amd64? [RESOLVIDO]

Mc Sampaio
mcsbru

(usa Linux Mint)

Enviado em 22/01/2019 - 21:32h

Mauriciodez escreveu:


mcsbru escreveu:
Olá.
Minha máquina é um amd64 (x86-64). Não entendi a tua colocação.


A sua máquina pode ser 64, mas vc deve ter instalado um 32 !!! manda aí
uname -m 


------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




nelo@sniper ~ $ uname -m
x86_64




10. Re: Linux: architecture i386 x ou + amd64?

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 22/01/2019 - 21:39h

-vá em fontes/aplicativos >> repositorios/adicionais >> desative repositório problemático do google-earth >> atualize novamente




11. Re: Linux: architecture i386 x ou + amd64? [RESOLVIDO]

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 22/01/2019 - 21:42h

-vc está usando linuxmint 18 ou 19 ??


12. Re: Linux: architecture i386 x ou + amd64?

Mc Sampaio
mcsbru

(usa Linux Mint)

Enviado em 22/01/2019 - 21:50h

clodoaldops escreveu:

-vá em fontes/aplicativos >> repositorios/adicionais >> desative repositório problemático do google-earth >> atualize novamente



Sim, pela tua responta anterior eu percebi que era em fontes e desabilitei. Veja como ficou o final do update:

$ sudo apt-get update
...
"Lendo listas de pacotes... Pronto
W: Falhou ao buscar http://packages.domain.com/dists/xenial/InRelease Não foi possível conectar em packages.domain.com:80 (127.0.0.1). - connect (111: Conexão recusada)
W: Falhou o download de alguns ficheiros de índice. Foram ignorados ou os antigos foram usados em seu lugar."

Parece que resolveu a questão do repositório google, mas agora restou o probleminha acima.

P.S.: Estou utilizando o Linux Mint KDE 18.e - Silvia.





01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts