Numero Primo

Publicado por Guilherme (última atualização em 15/11/2011)

[ Hits: 5.290 ]

Download numero-primo.alg




Um simples algoritmo para verificar se um número é primo ou não.

  



Esconder código-fonte

algoritmo "Número primo"
// Função : saber se um número é primo ou não
// Autor : Guilherme de Araújo Silva
// Data : 27/4/2011
// Seção de Declarações 
var
num,controle,primo,fim:inteiro
inicio
      escreva("Entre com um numero: ")
      repita
            leia(num)
      ate (num>=0)
      repita
            controle <- 1 + controle
            primo <- num mod controle
            se(primo=0) entao
                  fim <- 1 + fim
                  se (fim>2) entao
                     controle <- num + 1
                      escreva(num," não é primo")
                  fimse
            fimse
      ate (controle>num)
      se(fim=2) entao
            escreva(num," é primo")
      fimse
fimalgoritmo

Scripts recomendados

Crivo de Eratóstenes Simples em Fortran 95

Octave - Calcular raiz pelo método de Newton

Octave - Decomposição LU

Octave - Método de Euler-Modificado para solução de EDO

Octave - Sistemas lineares por Gauss-Seidel


  

Comentários

Nenhum comentário foi encontrado.


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts