LTSP (lts.conf)

Arquivo de configuração do LTSP, onde habilitamos o som nos terminais e configuramos diversas opções

Categoria: Networking

Software: LTSP

[ Hits: 21.888 ]

Por: Perfil removido


Arquivo de configuração do LTSP, onde habilitamos o som, resol. de video, layout do teclado  nos terminais


# Este é o principal arquivo de configuração do LTSP, 
# configure com atenção:
# 

# Substitua o "192.168.0.10" pelo endereço IP correto do 
# do servidor LTSP

[Default]
        SERVER             = 10.0.30.32 #coloca o ip do seu servidor aki
   XDM_SERVER      = 10.0.30.32 # e aki tbm

# Esta opção faz com que o LTSP detecte automaticamente a 
# placa de vídeo dos terminais, utilizando os drivers do 
# Xfree 4.2. 

        XSERVER            = auto

# Configure aqui o tipo de mouse que será usado nos terminais
# o default é utilizar um mouse PS/2

        X_MOUSE_PROTOCOL   = "Microsoft"
        X_MOUSE_DEVICE     = "/dev/ttyS0"
        X_MOUSE_RESOLUTION = 400
        X_MOUSE_BUTTONS    = 2
        USE_XFS            = N

        LOCAL_APPS         = N
        RUNLEVEL           = 5

#--------------------------------------------------------------


# Esta é a configuração individual dos terminais, que 
# bipassam os valores default determinados acima

# A opção "Xserver = auto" utiliza a detecção automática
# do vídeo. Caso ela não funcione em algum terminal, você
# pode indicar manualmente um driver, substituir o "auto" 
# por "vesa" ou "fbdev" por exemplo. O driver "vesa" 
# custuma funcionar na maioria das placas antigas, embora 
# tenha um baixo desempenho.


# O default é configurar as estações para utilizarem mouses PS/2
# Exemplo para usar um mouse serial na estação:

#[ws001]
#   XSERVER            = auto
#   X_MOUSE_PROTOCOL    = "Microsoft"
#   X_MOUSE_DEVICE      = "/dev/ttyS0"
#   X_MOUSE_RESOLUTION  = 50
#   X_MOUSE_BUTTONS     = 2   
#   X_MOUSE_EMULATE3BTN = Y
#       USE_NFS_SWAP       = Y
#       SWAPFILE_SIZE      = 16m
#       RUNLEVEL           = 5


# Exemplo para usar um mouse PS/2 COM RODA na estação:

#[ws001]
#   XSERVER            = auto
#   X_MOUSE_PROTOCOL    = "IMPS/2"
#   X_MOUSE_DEVICE      = "/dev/psaux"
#   X_MOUSE_RESOLUTION  = 400
#   X_MOUSE_BUTTONS     = 5
#   X_ZAxisMapping      = "4 5"
#       USE_NFS_SWAP       = Y
#       SWAPFILE_SIZE      = 32m
#       RUNLEVEL           = 5



# Este exemplo força a estação a usar uma resolução e taxa de
# atualização específicas, para o caso do X estar abrindo mas
# o monitor estar ficando fora de sintonia (contribuição do 
# ailtonjr):

#[ws001]
#   XSERVER            = auto
#   X_MODE_0           = 800x600 #(Resolução)
#   X_VERTREFRESH      = 60  #(Refresh rate)
#   X_COLOR_DEPTH      = 16  #(Bits de Cor) 
#       USE_NFS_SWAP       = Y
#       SWAPFILE_SIZE      = 32m
#       RUNLEVEL           = 5


# Existe ainda a opção de fazer funcionar uma placa de som
# soundblaster compatible espetada na estação. Neste caso
# qualquer som tocado no servidor, sejam os sons dos programas
# ou um MP3 por exemplo serão transmitidos pela rede e 
# tocados nas caixinhas da estação. Esta opção deve ser usada 
# com cautela em redes com muitas estações pois os sons são
# transmitidos na forma de um wav descompactado através da 
# rede. Cada estação cujo usuario esteja ouvindo um MP3 
# vai consumir cerca de 100 KB/s da banda da rede.

# As linhas abaixos ativam este recurso:

#[ws001]
#   SOUND              = Y
#   SOUND_DAEMON       = nasd   
#   VOLUME             = 80 
#   MIC_VOLUME      = 80 
#   CD_VOLUME      = 75  
#   SMODULE_01         = soundcore
#   SMODULE_02      = uart401
#   SMODULE_03      = sb io=0x220 irq=5 dma=1



#--------------------------------------------------------------



# A configuração propriamente dita... :-)
# Estes modelos abaixo mantém a configuração de utilizar um 
# mouse  PS/2 (sem roda) usando a detecção automática do 
# driver de vídeo. Substitua a configuração pelos exemplos 
# acima conforme necessário.


[ws001]
        XSERVER            = auto # se nao funcionar com auto, mude pra vesa e se mesmo assim nao funfar poe trident trident :)
        XDM_SERVER = 10.0.30.32 -dpi 140    # Aqui ele usa 140 dpi     
        X_MODE_0           = 800x600 #(Resolução) 
        X_VERTREFRESH      = 60  #(Refresh rate)
        X_COLOR_DEPTH      = 16  #(Bits de Cor)
        XkbRules = all
        XkbModel = pc104
        XkbLayout = pt_abnt2        
        USE_NFS_SWAP       = Y
        SWAPFILE_SIZE      = 132m #recomendo usar 132 de swaap, pois assim fika mais rapidim :)
        RUNLEVEL           = 5



[ws002]
        XSERVER            = auto
        USE_NFS_SWAP       = Y
        SWAPFILE_SIZE      = 32m
        RUNLEVEL           = 5 


[ws003]
        XSERVER            = auto
        USE_NFS_SWAP       = Y
        SWAPFILE_SIZE      = 32m
        RUNLEVEL           = 5 


[ws004]
        XSERVER            = auto
        USE_NFS_SWAP       = Y
        SWAPFILE_SIZE      = 32m
        RUNLEVEL           = 5 


[ws005]
        XSERVER            = auto
        USE_NFS_SWAP       = Y
        SWAPFILE_SIZE      = 32m
        RUNLEVEL           = 5 



#--------------------------------------------------------------



# EXEMPLO de configuração para uma estação usando o driver 
# "vesa", mouse serial e resolução de 800x600 com 16 bits 
# de cor, 60 hz de refresh para o monitor e ainda ativar 
# a placa de som:

#[ws001]
#   XSERVER            = vesa
#   X_MODE_0           = 800x600 #(Resolução)
#   X_VERTREFRESH      = 60  #(Refresh rate)
#   X_COLOR_DEPTH      = 16  #(Bits de Cor) 
#   X_MOUSE_PROTOCOL    = "Microsoft"
#   X_MOUSE_DEVICE      = "/dev/ttyS0"
#   X_MOUSE_RESOLUTION  = 50
#   X_MOUSE_BUTTONS     = 2   
#   X_MOUSE_EMULATE3BTN = Y
#       USE_NFS_SWAP       = Y
#       SWAPFILE_SIZE      = 32m
#   SOUND              = Y
#   SOUND_DAEMON       = nasd   
#   VOLUME             = 80 
#   MIC_VOLUME      = 80 
#   CD_VOLUME      = 75  
#   SMODULE_01         = soundcore
#   SMODULE_02      = uart401
#   SMODULE_03      = sb io=0x220 irq=5 dma=1
#       RUNLEVEL           = 5


# EXEMPLO de configuração para uma estação usando a detecção
# automatica do vídeo, mouse PS/2 com roda e resolução de 
# 1024x768 com 16 bits de cor e 60 hz de refresh para o monitor:

#[ws002]
#   XSERVER            = auto
#   X_MODE_0           = 1024x768 #(Resolução)
#   X_VERTREFRESH      = 60  #(Refresh rate)
#   X_COLOR_DEPTH      = 16  #(Bits de Cor) 
#   X_MOUSE_PROTOCOL    = "IMPS/2"
#   X_MOUSE_DEVICE      = "/dev/psaux"
#   X_MOUSE_RESOLUTION  = 400
#   X_MOUSE_BUTTONS     = 5
#   X_ZAxisMapping      = "4 5"
#       USE_NFS_SWAP       = Y
#       SWAPFILE_SIZE      = 32m
#       RUNLEVEL           = 5



# Swap via rede.

# A opções:
#       USE_NFS_SWAP       = Y
#       SWAPFILE_SIZE      = 32m

# Fazem com que seja criado um arquivo swap no HD do servidor, 
# que fica disponível para a estação. Este arquivo é recomendável 
# em estações com menos de 48 MB de memória RAM e é utilizado 
# apenas nos momentos em que a estação fica sem memória disponível. 
# Você pode alterar o número para o valor desejado ou desativar a 
# opção alterando a primeira linha para:

#       USE_NFS_SWAP       = N
 









  


Comentários
[1] Comentário enviado por alexside em 12/09/2006 - 15:20h

Prezado Alexandrehkk,

Apesar de começar do ZERO, com a ajuda e muiita leitura, instalei o linux e consegui colocar o ltsp. porém com muita coisa para se fazer, exemplo, o samba, compartilhamento na rede e o som nas estações e habilitar a usb, mas chegarei lá.

Aqui tenho suse 10.1 e ltps 4.1

instalei os pacotes e fiz apenas mudanças pequenas.
exemplo. a mb do server é uma intel d101ggc na qual tive que colocar "vesa" pois a placa de víedo não entrou e a tela ficou preta...
Realmente, com VESA fica lento para abrir no server a tela do login. Tentei efetuar uma busca para saber o probema e percebo que tem que instlar a placa de vídeo on board. Não fiz ainda.

a questão é que a partir da 19 máquina, não entra mais (não abre a tela de login) existe alguma limitação? vou tentar suas alterações e depois faço um post aqui.
Grato e aguardo ajuda.

[2] Comentário enviado por recrutazero em 16/11/2006 - 09:40h

Eu uso slackware 10.2 e LTSP 4.2

estou com dificuldade para abilitar o SOM nos terminais e de configurar os dispositivos locais nos terminais tambem.

alguem tem alguma dica?

[3] Comentário enviado por removido em 03/05/2011 - 17:16h

Boa tarde.

Cara muito bom esse artigo que vc escreveu, vc poderia me ajudar a configurar o ltsp para enxergar a porta serial na estão mas não para mouse, preciso usa-la normalmente por um software que funciona com envio e recebimento de dados tipo hyper-terminal do windows.


Contribuir com comentário

  



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts