Modem ZTE MF636 no Mandriva 2009.1

Publicado por Jose Benedito em 22/06/2009

[ Hits: 8.823 ]

 


Modem ZTE MF636 no Mandriva 2009.1



A configuração é muito simples, basta alguns pacotes e o arquivo P673M2_MF636_LINUZ_BRT.tar.gz (disponível no CD fornecido pela Brasil Telecom).

1. Instalar os seguintes pacotes:
  • libusb-devel
  • udev
  • usb_modeswitch
  • ppp
  • wvdial
  • libqt3

2. Acessar o shell e virar root:

su

Em seguida descompactar o arquivo P673M2_MF636_LINUZ_BRT.tar.gz para um diretório (por exemplo /tmp). Acessar o diretório onde o arquivo foi descompactado:

# cd P673M2_MF636_LINUZ_BRT

E editar o arquivo install.sh e editar a linha 207, de:

udevcontrol reload_rules

para:

udevadm control --reload-rules

E em seguida executar esse script:

# ./install.sh

Provavelmente esse script vai reclamar, informando que falta instalar os headers do kernel para compilar o módulo do driver do modem ZTE, mas esse módulo já existe no kernel do Mandriva 2009, por isso simplesmente ignore essa mensagem.

Pronto, tudo já está instalado e configurado. Isso mesmo!!! Graças ao script install.sh!!! Ele providencia todas as configurações necessárias para ativar o modem ZTE MF636.

Agora basta ir no menu Internet e clicar no item Brasil_Telecom. Conectar o modem e aguardar o botão [Conectar] ficar disponível (isso demora um pouco).

José Benedito
Brasília/DF

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

Instalando os driver's de impressão da Lexmark

Grupo vboxusers - Adicionando usuários de forma segura

D-Link 500G da BRT sem provedor

Resolvendo problema com CDROM e DVD trocados

Ripando CD's de áudio no XMMS.

  

Comentários
[1] Comentário enviado por felipemartinsss em 03/07/2009 - 10:17h

Utilizo CentOS 4.7 mas não tenho o comando udevcontrol e nem o comando udevadm. Alguém sabe como posso instalar esses programas?

Obrigado.

[2] Comentário enviado por jobedf em 03/07/2009 - 11:46h

Felipe,
Não utilizo o CentOS, mas voce pode baixar o pacote do UDEV para o CENTOS em: ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Client/en/os/SRPMS.
Depois de baixar e instalar, basta verificar qual o comando vc deve utilizar. Pode ser que ele utilize o comando "udev -control" ou alguma coisa semelhante. Dê uma verificada na doumentação do comando...

Benedito

[3] Comentário enviado por paulo kruger em 06/09/2009 - 18:02h

Olá.

Utilizo o KUbuntu, e, após instalado tudo e inicializado o programa da Brasil Telecom, este fica com o Estado em Inicializando, e não permite tentar conexção com BrT Internet.

É comum demorar mais de uma hora para inicializar a internet(pergunta)

O PC em questão é um Notebook acer Aspire 3000.

Obrigado.

[4] Comentário enviado por paulo kruger em 06/09/2009 - 19:08h

P.s.: A versão do KUbuntu é a 8.04

[5] Comentário enviado por jobedf em 07/09/2009 - 18:33h

Paulo,
No mandriva leva apenas 1 minuto para o modem carregar as regras e liberar a opção de "conectar". Minhas experiencias com Debian based se limitam a servidores, apenas modo texto...
Mas aparentemente o seu Kubuntu não esta reconhecendo o modem, por isso ele fica apenas "Inicializando...", possivelmente problemas com módulos... verifique nos demais tutoriais do Viva o Linux...

[6] Comentário enviado por jhugor em 11/04/2010 - 13:43h

saudacoes amigos

estou em mg e comprei um modem da zte mf 636 ( que eh vendido pela oi como 626 ) e ja desbloqueado! utilizo este modem normalmente no windows sem nenhum problema.

estou me aventurando pelo mundo tux e como voces que ja estao por aqui ja sabem ne, cada desafio torna o pinguim mais atrativo!

bom, quando eu espeto o 636 no windows pela 1a vez ele reconhece uma unidade de cd virtual e eh a partir dela que faco a instalacao do mesmo.

notei que dentro desta unidade tem-se tambem pacotes de instalacao para o linux.

trata-se do seguinte:

->fedora e suse (dir)
----->vivo-1.0.0B03.i386.rpm (file)

->suporte (dir)
----->libaudio2_1.9-2_i386.deb (file)
----->libqt3-mt_3.3.8really3.3.7-0ubuntu11_i386.deb (file)
----->qt3-3.3.8b-12.fc9.i386.rpm (file)
----->qt3-3.3.8b-42.1.i586.rpm (file)
----->wvdial-1.60-31.1.i586.rpm (file)

-ubuntu (dir)
----->vivo-1.0.0B03.i386.deb (file)


ja descobri que tenho que utilizar o "lsusb" e que se no endereco do modem estiver com o codigo 2000 eh porque ele esta carregado como cd-rom e no caso nao ira funcionar. temos na net um utilitario que "desmonta" esta usb de cd-rom virtual e carrega como um modem. neste caso o mf 636 sai de 2000 e vai para 0031. notei que diversas dicas relatam isto com o codigo 37, mais o 37 pelo que vi eh para modens diversos compativeis com o zte mf 626.

ja instalei ppp, ja tentei rodar pppconfig, ja instalei o kppp, ja instalei o gnome-ppp mais realmente pra quem esta comecando eh dificil.

agradeco se pudem me ajudar de alguma forma.

hugo

considerando-se que o ubuntu deriva do debian e que estou utilizando o debian gostaria de uma dica de voces da situacao:

como fazer este bendido modem funcionar no Debian/Gnome 2.14


[7] Comentário enviado por jhugor em 14/04/2010 - 18:51h

postei os arquivos linux que veio no modem caso alguem precise

acho que este link fica no ar por 30 dias, conta free, mais nao tenho certeza, pode ser que fique mais tempo

se precisarem que eu faca um up novamente me deem a dica pra onde mandar que mando

valeu!

LINK
http://clip2net.com/page/m41610/5271180



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts