Krusader 2.0.0 Phoenix Egg - Gerenciador de arquivos completo para o KDE4 ou superior

Publicado por Alberto Federman Neto. em 08/08/2008

[ Hits: 9.961 ]

Blog: https://ciencialivre.blog/

 


Krusader 2.0.0 Phoenix Egg - Gerenciador de arquivos completo para o KDE4 ou superior



O Krusader novo tem muitas opções diferentes das versões anteriores e é totalmente configurável. É um gerenciador de arquivos poderoso e muito completo, baseado em modificações do Midnight Commander.

Permite criar e deletar diretórios, comprimir e expandir arquivos com qualquer compressor, executar comando de terminal em modo usuário ou root, acessar arquivos e pastas escondidas ou protegidas etc.

Há alguns dias fui instalar Krusader novo no Mandriva e verifiquei que havia sido retirado dos repositórios, talvez por problemas de dependências. Procurei então um pacote RPM e achei a versão 1.80 para Mandriva (a que eu tinha) e 1.90 , somente para o openSUSE e o Fedora, mas não para o Mandriva.

As versões para openSUSE e Fedora não instalaram, por dependerem de gio_iso. Pesquisando na rede, vi que não funcionavam no Mandriva e para este, o Krusader havia sido retirado por instabilidades!

Encontrei a versão nova, 2.0.0 Beta 1, pacote fonte para o KDE4 e resolvi compilar e instalar no Mandriva... O método que usei, você pode seguir.

Baixe a versão nova do fonte:

# wget http://ufpr.dl.sourceforge.net/sourceforge/krusader/krusader-2.0.0-beta1.tar.gz

Se preferir pode baixar com navegador, com Prozilla, com Subversion etc. O site original é:
1) Salve em um diretório e expanda:

mkdir /home/meudir/baixados/krusader
$ mv (ou cp) krusader-2.0.0-beta1.tar.gz /home/meudir/baixados/krusader
$ cd /home/meudir/baixados/krusader
$ tar -xzvf krusader-2.0.0-beta1.tar.gz
$ cd krusader-2.0.0-beta1


2) Compile e instale o programa usando as flags adequadas:

su
# cmake -DCMAKE_INSTALL_PREFIX=/usr/ -DQT_INCLUDES=/usr/share/qt4/include
# make && make install


Isto vai sobrescrever a versão anterior, se você tiver, porque ela fica no /usr. Para instalar a versão em outro diretório, altere o caminho /usr para o que quiser.

Em meus testes funcionou com perfeição em Mandriva 2009 Beta 1, com KDE 4.1.0 e em Sabayon 3.5 com KDE 4.0.3, mas não em Gentoo com KDE 3.5.9.

Neste último a compilação falha porque requer bibliotecas que são só de KDE4, mas se quiser testar, instale apenas as bibliotecas indicadas na saída do comando de compilação.

3) Se preferir usar as versões estáveis 1.90 (que rodam perfeitamente em KDE4 ou superior), as encontrará nos repositórios e mirrors de sua distro ou pode baixar da rede, do Superdownloads etc, .DEB ou .RPM, para Debian, Ubuntu, openSUSE, Fedora, Red Hat, Kurumin etc.

Para abrir o programa digite "krusader" na linha de comando ou crie um atalho krusader.desktop. Também pode abrir em modo root com os comandos:

su
# krusader


ou:

sudo krusader

ou:

kdesu krusader

Ou ainda, clique ALT+K, em uma instância já aberta do Krusader em modo usuário.

Aqui no VOL, existem duas dicas, mas ambas sobre versões antigas do Krusader:
Abaixo um screenshot do Krusader novo e a tela de versão.
Krusader 2.0.0, 'Phoenix Egg' - Um Gerenciador de Arquivos Completo para o KDE4 ou Superior.
Outras dicas deste autor

Navegador Maxthon em Sabayon Linux e Gentoo

Como usar Looking Glass sem alterar seu sistema Linux

Navegador/Suíte SeaMonkey em toda e qualquer distro

Pendrive ou cartão de memória para multimídia não compatível [Resolvido]

ZSWAP (SWAP na RAM) em Linux - Controlável: "ligável", "desligável" e outros métodos

Leitura recomendada

Azureus fecha ao iniciar

Netbeans no KDE

Instalando Spotify no Ubuntu 16.04 LTS

Extraindo áudio em mp3 de um swf

VLC: Instalando sua versão mais recente no Ubuntu

  

Comentários
[1] Comentário enviado por iz@bel em 08/08/2008 - 23:57h

Muito bom! Vou esperar o Debian ou a necessidade pra instalar :P
Mas por garantia, já tá nos favoritos pra eu não perder essa dica :)
Krusader é nota 10!
vlw

[2] Comentário enviado por albfneto em 18/09/2008 - 18:17h

Este Krusader já pode ser diretamente instalado da versão 2009.0 RC1 do Mandriva, rodando com KDE 4.1.1, tudo em Português do Brasil.
Já consta dos repositórios Mandriva, o que facilita sua instalação e uso.
Não é compatível com KDE 3.5. , porém, para esse KDE antigo, a versão boa é a 1.90.

[3] Comentário enviado por albfneto em 28/10/2008 - 21:51h

Testei hoje, ele funciona no KDE 4.1.2 do Mandriva 2009.0.
Ele ianda não tem Krusader nos repos di urpmi

[4] Comentário enviado por albfneto em 16/09/2010 - 20:21h

ATUALIZAÇÃO:
12 de Junho de 2018.

Continuo a gostar e usar o Krusader. Tanto no Sabayon como no OpenSUSE. a versão nova é o 2.7.0.

Mais um bom artigo sôbre o Krusader.

http://www.guiadohardware.net/artigos/krusader/



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts