Instalando pacote local com o YUM

Publicado por Andre (pinduvoz) em 01/07/2009

[ Hits: 29.030 ]

Blog: http://casadopinduvoz.wordpress.com/

 


Instalando pacote local com o YUM



Trata-se de uma dica rápida para usuários do Fedora Linux.

Às vezes um pacote local (baixado) não é instalado pelo comando RPM por conta de dependências não satisfeitas, obrigando o usuário a procurar e baixar outros pacotes. No entanto, se apelarmos para o poderoso YUM para instalar o pacote local, é ele que vai baixar e instalar as dependências, o que torna a instalação muito mais fácil.

Então, para instalarmos o pacote XYZ.rpm (nome usado apenas para exemplificar), que está numa pasta local, usamos, "dentro" da pasta local o comando:

# yum localinstall XYZ.rpm

Se a instalação falhar pela impossibilidade de autenticar o pacote (o que é quase certo), basta acrescentarmos "nogpgcheck" ao comando, que fica assim:

# yum localinstall --nogpgcheck XYZ.rpm

Vale lembrar que, por questões óbvias de segurança, devemos sempre optar pelos pacotes dos repositórios oficiais da distribuição, evitando os de terceiros.

Até a próxima dica.

Outras dicas deste autor

Como completar um conjunto de ícones?

LXDE - Ícone da Lixeira na Área de Trabalho

Cartão SD e modo "suspender" em netbooks rodando Ubuntu

Temas do Ubuntu para o Google Chrome e o Chromium

Fundo dos ícones na bandeja do Ubuntu (GNOME 2)

Leitura recomendada

Anthares - Nova distro no mercado

Samba bugado no Zenwalk?

Como dar efeito 3D em suas fotos sem precisar de óculos especiais

Preservando as configurações do KDE (ou outro ambiente gráfico)

O inutilitário Gtick

  

Comentários
[1] Comentário enviado por luizf3108 em 21/08/2013 - 20:00h

Fedora 19
3.10.7-200.fc19.x86_64


Comigo funcinou.

Usei para instalar o skype, resolveu todas as dependências.
Obrigado!

[2] Comentário enviado por ademir21 em 13/09/2013 - 14:25h

Cara você é fods, show de bola isso ai que postou.

[3] Comentário enviado por joey_4m em 26/09/2013 - 10:29h

Tentei instalar o Insync no centOS utilizando isso que você postou porém ta dando erro.

Error: Package: insync-1.0.22-1.i686 (/insync-1.0.22-1.i686)
Requires: glibc >= 2.13
Installed: glibc-2.12-1.107.el6_4.4.i686 (@updates)
glibc = 2.12-1.107.el6_4.4
Available: glibc-2.12-1.107.el6.i686 (base)
glibc = 2.12-1.107.el6
Available: glibc-2.12-1.107.el6_4.2.i686 (updates)
glibc = 2.12-1.107.el6_4.2
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


por que será?



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts