Instalando driver de vídeo ATI no Debian Lenny (5.0) sem desastres

Publicado por Augusto André Souza em 14/05/2009

[ Hits: 17.753 ]

Blog: http://www.google.com

 


Instalando driver de vídeo ATI no Debian Lenny (5.0) sem desastres



Por achar que na internet as informações a respeito desse assunto são bastante dispersas, resolvi sugerir essa dica mais direcionada, para que usuários iniciantes como eu tenham a oportunidade de instalar sua placa de vídeo ATI no Debian Linux sem ter problemas com a configuração do servidor X.

Em primeiro lugar, fique claro que por esse método instalaremos a versão pré-testada pelos desenvolvedores do sistema, a versão que está nos repositórios do Debian, a 8.12 (segundo o site Distrowatch.com) e não a 9.3, disponível no site da ATI (pois já a testei, instalando através do comando "chmod" e tive muitos problemas). Em resumo, por esse método que descreverei é "tiro na queda" e possivelmente nada dará errado.

Primeiramente instale o module-assistant e os pacotes build-essential e linux-headers:

# apt-get install module-assistant build-essential linux-headers-`uname -r`

O "build-essential" é o mesmo pacote de compiladores e bibliotecas disponível no Ubuntu. Ele instalará o GCC, G++ e os demais integrantes do kit básico de compilação. O pacote "linux-headers" inclui os headers do kernel, que inclui os arquivos necessários para o compilador. O module-assistant é um gerador de módulos para o kernel, que é capaz de baixar os pacotes com o código-fonte e manipular os módulos, tudo de forma automatizada. Para que ele funcione, é necessário que edite o arquivo /etc/apt/sources.list e inclua a linha com os repositórios deb-src, como em:

deb-src http://ftp.br.debian.org/debian/ lenny main contrib non-free

Para isso, no terminal como root digite:

# gedit /etc/apt/sources.list

... e certifique se essa linha deb-src existe. Caso contrário, inclua.

Agora, desde que tenha realizado todos os passos anteriores (sem exceção), instale o driver pelo comando:

# m-a a-i fglrx

No final da instalação, será reclamado sobre um erro de dependência de pacotes, mas o apt se encarregará de baixar e concluir a instalação automaticamente. Serão aproximadamente 30 MB a mais a serem baixados (bastará digitar "s" e "enter").

Instalação concluída. Falta apenas carregar o módulo e chamar o "aticonfig --initial " para que ele ajuste a configuração do X:

# modprobe fglrx
# aticonfig --initial


Se por acaso algo der errado, basta recuperar o backup do arquivo de configuração do X:

# cp /etc/X11/xorg.conf.original-0 /etc/X11/xorg.conf

Em caso de problemas mais sérios com a configuração, você pode começar tudo de novo, fazendo com que o sistema reconstrua a configuração do X usando o comando:

# dpkg-reconfigure -phigh xserver-xorg

Para testar tudo, reinicie e a seguir rode no terminal comum o comando:

fglrxinfo | grep render

Veja que a saída será algo similar a "OpenGL renderer string: ATI Radeon blablabla".

Pronto, procedimento finalizado!

Agora, você pode aproveitar e instalar o Compiz para obter aqueles famosos efeitos de desktop, como alternar entre as áreas de trabalho através de um cubo em 3D, ter transparência nas janelas etc. Rode o comando:

# apt-get install compiz fusion-icon

E inicie o Compiz Fusion Icon através do menu Aplicações > Ferramentas do Sistema.

Obs.: Caso deseje instalar um driver mais atual, como 9.3 disponível no site ATI.com (mesmo com minha advertência de que já tentei e obtive graves problemas tendo que reinstalar o sistema), baixe o driver e rode como root através dos comandos:

# chmod +x ati-driver-installer-9-1-x86.x86_64.run
# ./ati-driver-installer-9-1-x86.x86_64.run


Depois é só seguir com a instalação gráfica, que será intuitiva. Por fim, rode no terminal comum o comando:

# aticonfig --initial

... para atualizar o xorg.conf.

Se encontrar problemas com a aceleração 3D, leia esse artigo:
É isso. =)

Outras dicas deste autor

Instalando drivers de placas de vídeo ATI no Ubuntu Linux

Instalando pacotes txz no Slackware 12.2

Leitura recomendada

TELBOX Controlador B2K - kb2kskype no Ubuntu

Webcam no Ubuntu 7.10 utilizando driver binário spca5xx

Problemas com a resolução do monitor na instalação Red Hat 9

Fazendo o scanner GOTEC funcionar no Mandriva One e superior

Driver BROADCOM WIFI 43XX

  

Comentários
[1] Comentário enviado por chagalrpg em 14/05/2009 - 18:00h

Isso funcionaria no Ubuntu 9.04 Jaunty?

[2] Comentário enviado por pinduvoz em 15/05/2009 - 06:16h

No Ubuntu a melhor opção é usar o Gerenciador de Drivers Restritos.

Ele pode ser acessado pelo Menu, em "Sistema > Configurações > Drivers de Hardware", se não me engano.

[3] Comentário enviado por augustouser em 15/05/2009 - 21:21h

chagalrpg,

O Pinduvoz tem razão. Tenta pelo prórpio gerenciador do sistema. Se bem que quando testei e tentei fazer dessa maneira, há algumas semanas, não funcionou. No Jaunty realmente tem muita gente relatando problemas com o driver ATI. Acho que o grande problema é que nessa nova versão do Ubuntu eliminou-se o suporte a várias placas antigas...
Pelo procedimento acima provavelmente funcionaria, já que nos repositórios tem a versão 8.6 do driver. Mas o comando pra chamar o fglrx deve ser outro... não posso te ajudar.

De qualquer forma, veja se seguindo o processo do proprio wiki vc não consegue encontrar a resposta. Veja se sua placa está aqui: http://wiki.cchtml.com/index.php/9.4

Depois siga o procedimento, que é padrão, por aqui: http://wiki.cchtml.com/index.php/Ubuntu_Jaunty_Installation_Guide#Restricted_Drivers_Manager

... ou por aqui: http://www.vivaolinux.com.br/dica/Instalando-drivers-de-placas-de-video-ATI-no-Ubuntu-Linux <-- Neste caso, só testei no 8.04 e 8.10. Faça por sua conta e risco!

[4] Comentário enviado por augustouser em 15/05/2009 - 21:49h

Melhor! Abre o synaptic, habilita "todos" em relação à lista de pacotes de será exibida pela sua pesquisa e procura por "fglrx". Deve aparecer o driver dos repositórios. Boa sorte!

[5] Comentário enviado por mox em 20/05/2009 - 05:26h

Caro Augusto,
Sou iniciante no Debian, e estou seguindo o seu tutorial e neste ponto aconteceu um erro.

apos o comando:
#modprobe fglrx

veio a seguinte mensagem
FATAL: Error inserting fglrx (/lib/modules/2.6.26-2.686/misc/fglrx.ko): Cannot allocate memory


O que faço?

Grato
Baloomox

[6] Comentário enviado por augustouser em 21/05/2009 - 00:35h

Aconteceu em uma outra máquina que testei o procedimento, Mozart. Mas funcionou mesmo assim...
Não sei o teor desse erro.

[7] Comentário enviado por ozeric em 07/09/2009 - 16:48h

ola amigos eu tentei dar o comando # m-a a-i fglrx e nao deu certo disse que faltava o contrib mais eu fiz exactamente como esta postado sera que poderiam dar uma ajuda ?

obrigado!!!

[8] Comentário enviado por zelongatto em 18/03/2010 - 13:38h

Perfeito cara.. Me ajudou muito.. Funcionou perfeito aqui
Obrigado
Abraço

*ozeric: poderia postar como esta seu sources.list pode ser erro em alguma linha ou a linha estar comentada (#).*

falow



Contribuir com comentário