Compilando kernel 3.16.1 no Fedora 20

Publicado por Daniel Lara Souza em 20/08/2014

[ Hits: 5.468 ]

Blog: http://danniel-lara.blogspot.com/

 


Compilando kernel 3.16.1 no Fedora 20



Um dica rápida sobre como compilar o kernel atual (até esse momento) no Fedora 20.

Baixe a versão do kernel, nessa dica, foi usada a versão 3.16.1, a atual nesta data:

# wget https://www.kernel.org/pub/linux/kernel/v3.x/linux-3.16.1.tar.xz

Instale o GCC, etc, para compilar o kernel:

# yum install gcc make ctags ncurses-devel -y

Descompacte o arquivos:

# tar -xvf linux-3.16.1.tar.xz

Acesse o seu diretório:

# cd linux-3.16.1

Copie o seu config para esse diretório:

# cp /boot/config-`uname -r`* .config

E vamos ao processo de compilar:

# make defconfig
# make
# make modules_install install

Atualize o seu GRUB:

# grup2-mkconfig

E reinicie o Fedora:

# reboot
Linux: Compilando kernel 3.16.1 no Fedora 20

Pronto, seu Fedora já está usando a última versão do kernel.
Linux: Compilando kernel 3.16.1 no Fedora 20

Guia de referência para a dica:
Outras dicas deste autor

Tetris no Ubuntu 12.04

ImapCopy - Migrando servidores de e-mails

Terminus no Fedora 30

Joomla! 3.0.3 no CentOS 6.3

Razor-QT no Ubuntu 12.04 LTS

Leitura recomendada

Problemas em diretório com milhares de arquivos [Resolvido]

Instalando kernel 2.6.7 no Slackware 10

Instalando Kernel 4.x no CentOS 7

pf-Kernel 3.17 - Acelere o Linux Mint, Ubuntu e Debian

Compilando kernel 3.0.4 no Debian Squeeze com processador de 2 núcleos

  

Comentários
[1] Comentário enviado por Vinny_Z em 26/08/2014 - 14:40h

Olá, tudo certo?

Cara, fiz exatamente da maneira como foi mostrado, e acontece, que o novo kernel não reconhece nem minhas saídas de áudio, e nem minha interface de rede...
Foi algo que eu fiz de errado talvez?
Abraço

[2] Comentário enviado por danniel-lara em 27/08/2014 - 11:29h


[1] Comentário enviado por Vinny_Z em 26/08/2014 - 14:40h:

Olá, tudo certo?

Cara, fiz exatamente da maneira como foi mostrado, e acontece, que o novo kernel não reconhece nem minhas saídas de áudio, e nem minha interface de rede...
Foi algo que eu fiz de errado talvez?
Abraço


de uma verificada se ele não carregou os modulos



Contribuir com comentário