Turbine o seu SUSE instalando o apt-get com um repositório de mais de 5.000 pacotes

Turbine agora mesmo seu SUSE instalando e configurando o apt-get. Tenha a sua disposição mais de 5.000 pacotes para esta super distribuição.

[ Hits: 105.434 ]

Por: Thiago Vieira em 14/01/2004


Introdução



Antes de começarmos é bom sabermos o conceito do apt-get. Traduzindo o significado da sua sigla nós obtemos: Ferramenta de Empacotamento Avançada (Advanced Packaging Tool). O apt-get é um programa criado pelo projeto Debian para facilitar a vida do usuário quando o assunto é atualizar, instalar e remover programas. Quem aqui nunca se viu perdido em uma lista interminável de dependências? Ou procurando servidores para baixar um determinado pacote? O apt-get faz tudo isso para você e muito mais =]! Você pode também atualizar todo o seu sistema com um simples comando. Para maiores informações sobre o apt-get, consulte:

Agora vem a pergunta: "O SUSE não tem um apt-get já de fábrica?"
Não. A SUSE desenvolveu o Yast, que é um excelente facilitador de tarefas de administração, muito prático e útil, mantém seu sistema atualizado e muitas coisas mais. Agora você deve estar se perguntando, se já existe o Yast, porque eu deveria instalar o apt-get?

O Yast é um excelente programa, mas quando se trata de instalar novos pacotes que não estejam nos CDs de instalação, ele leva uma surra do apt-get.

    Próxima página

Páginas do artigo
   1. Introdução
   2. Instalando e configurando
Outros artigos deste autor

Ilegalidade em Editais de Concurso que cobrem Conhecimento em Software Específico e Proprietário

Fedora Core analisado por um usuário básico

A origem do nome Fedora

Leitura recomendada

Elastix - Identificação de chamadas pelo nome do chamador

Instalando antivírus LinuxShield no SuSE e OpenSuSE

Configurando Zabbix 2.4.1 no CentOS 6.2

A Inteligência Artificial que escreve programas

Kingfisher Quota Manager - Instalação e configuração

  
Comentários
[1] Comentário enviado por meinside em 14/01/2004 - 19:55h

ae parabens pelo artigo faiper

[2] Comentário enviado por removido em 14/01/2004 - 20:28h

kara é o seguinte: no meu cl9 o apt-get busca updates no ftp da conectiva. só q o ftp da conectiva é muito lento, já o ftp da unicamp é rápido, mas o apt não funciona com ele na source list. o q eu posso fazer?

[3] Comentário enviado por faiper em 14/01/2004 - 21:22h

Mandei um e-mail para vc jeancv =] O ftp tem que ser proprio para ser utilizado pelo apt-get =]

[4] Comentário enviado por faiper em 15/01/2004 - 01:01h

Foi relatado problemas com o packman-i686 Retirem ele e o conf fica tudo beleza !!! Depois testem novamente =] Ou Confiram alguma mudança na pagina do apt4get

[5] Comentário enviado por faiper em 15/01/2004 - 01:04h

Foi relatado problemas com o packman-i686 Retirem ele e o conf fica tudo beleza !!! Depois testem novamente =] Ou Confiram alguma mudança na pagina do apt4get

[6] Comentário enviado por kalashinikov em 15/01/2004 - 01:08h

2 perguntas:

1) Com o aptget no Suse, dá para, caso eu migre ele pro kernel 2.6 tenho condições de através do APt atualizar o kernel automaticamente também? tipo sai uma versão estável nova, eu tenho que compilar ou ele faz sozinho?

[7] Comentário enviado por kalashinikov em 15/01/2004 - 01:11h

2 perguntas:

1) Com o aptget no Suse, dá para, caso eu migre ele pro kernel 2.6 tenho condições de através do APt atualizar o kernel automaticamente também? tipo sai uma versão estável nova, eu tenho que compilar ou ele faz sozinho?

[8] Comentário enviado por caduardo em 15/01/2004 - 09:39h

Show de Bola.!

[9] Comentário enviado por caixadecebola em 26/04/2004 - 20:41h

tipo.. eu instalei o apt funcionou certinho.. so que ele nao acha os pacotes que eu mando procurar... a sources.list ta igual a que voce botou no artigo... tentei ate instalar esse wesnoth so de teste mas nem achou :(
parabens pelo artigo!!

[10] Comentário enviado por faiper em 27/04/2004 - 01:01h

Caixa de Cebola,

Faz tempo que eu escrevi esse artigo tenta atualizar a source.litst, vc pode pegar a atualização do source.list aqui http://linux01.gwdg.de/apt4rpm/

Se ainda assim não funcionar me procura no IRC ou me manda um e-mail



[11] Comentário enviado por crayon em 01/03/2005 - 17:49h

Cara, parabens pelo artigo. O apt-get é um senhor aplicativo.


[12] Comentário enviado por kuiava em 04/03/2005 - 10:06h

seguinte: instalei o apt e ele funcionou certinho...mas a questão é se existe um aplicativo tipo o DSELECT no debian para visualizar o pacotes que estão disponiveis para instalação...?

[13] Comentário enviado por dkz666 em 14/04/2005 - 22:12h

kuiava... eu uso o synaptic como GUI, e o recomendo.

apt-get install synaptic

[14] Comentário enviado por PCMasterPB em 16/10/2005 - 23:13h

Estava lendo isso na página http://linux01.gwdg.de/apt4rpm/ :

Is it necessary to execute a configuration tool after the apt-rpm has installed packages?
Depends on the distribution you're using. In case of SuSE it might be that /sbin/SuSEconfig needs to be executed after a succesfull update.

Pelo que entendi qdo eu usar o apt no suse eu preciso usar o comando SuSEconfig para que o sistema seja realmente atualizado, correto?

E aproveitando alguém sabe como configuro o sources.list pro suse 9.3 pro ? Um repositório que eu achei é ftp://ftp.gwdg.de/pub/linux/suse/apt/SuSE/9.3-i386/base/ como coloco ele no sources.list? rpm ftp://ftp.gwdg.de/pub/linux/suse/apt/SuSE/9.3-i386/base/ ? Desculpem a ignorância é que eu nunca usei o apt, mas gostaria de testá-lo ok! Agradeço qualquer ajuda.

[15] Comentário enviado por alexactis em 03/11/2005 - 23:25h

Olá Ao execultar o apt-get Install OpenOffice_org para meu suse 9.2 aparece o seguinte erro:

OpenOffice_org-en-help = 1.1.3-16 is needed by OpenOffice_org-en-help-1.1.3-16.2
OpenOffice_org-ar = 1.1.3-16 is needed by OpenOffice_org-ar-1.1.3-16.2
Sera que vocês poderiam me dar uma luz? Sou novato no linux.

Obrigado e parabens pelo artigo

[16] Comentário enviado por alexactis em 06/11/2005 - 01:15h

Possuo o SuSE 10.0, como eu poderia implantar o apt-get nele? ele tem algum programa tipo o apt nesta verssão?

maiis uma vez parabens pelo artigo.


[17] Comentário enviado por kleber_romano em 14/11/2005 - 17:43h

Segui as dicas adaptando-as ao suse 10, e consegui até fazer o download dos pacotes e das dependências porém o apt não consegue instalá-las reclamando que os pacotes não seriam "autênticos", miajuda por favor!


O artigo é ótimo!

[18] Comentário enviado por Journeyman em 28/12/2005 - 14:32h

olá, venho por meio desta, responder as duas questões acima.
Basta vc baixar os pacotes referidos nesse tutorial e editar seu /etc/apt/sources.list, adicionar as fontes tb como manda o artigo, e, nessas fontes, substituir o 9.0 por 10.0... fiz isso e funciona muito bem!
Para quem não entendeu, vai um exemplo:

a primeira linha das fontes:
rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/9.0-i386 update

substitui apenas o 9.0 por 10.0, como podem ver abaixo:

rpm ftp://ftp.gwdg.de/pub/linux/suse/apt SuSE/10.0-i386 update

abraços

[19] Comentário enviado por ludolfs em 13/02/2006 - 19:33h

consegui instalar os pacotes lua e apt-lib só que quando vou instalar o apt-0.5.15cn6-rb3.i586.rpm aprece a dependência libreadline.so.4, e não consigo achar ela para instalar, o que eu faço.

[20] Comentário enviado por ludolfs em 14/02/2006 - 09:14h

Pessoal estou com o suse 9.2 e queria saber os pacotes certinhos paa instalar pois o apt 0.5 aparece outros e quando executo aparece uma dependência de arquivo, por favor, socorro!!!

[21] Comentário enviado por neffaw em 19/03/2006 - 16:17h

Muito bom este seu artigo parabéns

[22] Comentário enviado por rafaelmatjas em 17/05/2006 - 13:13h

Olá amigo ludolfs...

Entre no sitio www.pbone.net e procure por apt, localize o pacote para sua distro, faça o download da mesma. Quando você for instalar, vai precisar de uma dependencia, que seria o libreadline.so.4, copie este nome e procure no mesmo sitio que te passei, quando você instalar o libreadline, vc instala o apt. Depois disso tudo já vai estar funcionando, depois é so configurar para ele procurar nos repositorios do SuSE 10.

Abraços

[23] Comentário enviado por FelipeAbella em 21/08/2006 - 17:16h

Uso Suse 10.1, uso o yast pra instalar pacotes, mas acho muito lento, tentei o smart, mas ele não aceita cd(eu acho), ai nao tem como usar os 5 cds nele, e eu nao tenho internet no pc, no apt-get tem como usar CD-ROM??? eu usava no debian, no Suse tem o mesmo recurso né?

[24] Comentário enviado por removido em 16/09/2006 - 19:24h

Pessoal,

Tentei instalar o APT no SuSe 10.0, mas aparece uma mensagem de erro.

linux:/home/pivato # rpm -i lua-5.0.2-rb1.i586.rpm
linux:/home/pivato # rpm -i apt-libs-0.5.15cnc6-rb5.i586.rpm
warning: apt-libs-0.5.15cnc6-rb5.i586.rpm: V3 DSA signature: NOKEY, key ID 8c9b4b0d
linux:/home/pivato # rpm -i apt-0.5.15cnc6-rb5.i586.rpm
warning: apt-0.5.15cnc6-rb5.i586.rpm: V3 DSA signature: NOKEY, key ID 8c9b4b0d
error: Failed dependencies:
libreadline.so.4 is needed by apt-0.5.15cnc6-rb5

Podem me ajudar? O meu kernel é o 2.6.13-15.12-default.

Obrigado

[25] Comentário enviado por slgarcia_64bit em 26/10/2006 - 23:59h

Pessoal,

Muito bom o artigo.

Só quero acrescentar que para usuários do SUSE 10.1 64bit o caminho para conseguir os pacotes são:

ftp://ftp.gwdg.de/pub/linux/suse/apt/SuSE/10.0-x86_64/

Abraços

[26] Comentário enviado por thomas135 em 01/11/2006 - 02:37h

ae galera como ke eu consigo os sites ke eu coloko no soucers.list?

aonde eu posso pega uns?

obrigado =)

[27] Comentário enviado por removido em 15/11/2006 - 11:32h

omg :D tem como instalar no slackware também?

[28] Comentário enviado por andreuebe em 01/09/2008 - 14:08h

Parabens! Era o que faltava no meu Suse!

Abs

Andre

[29] Comentário enviado por tigonesuselinux em 30/10/2008 - 00:54h

Amigo, os links que você citou são versões que meu Suse não instalou....não sie pq!!!

Mas caso alguem tenha o mesmo problema, achei links que instalaram perfeitamente aqui:

http://www.portugal-a-programar.org/forum/index.php?topic=5836.0

o.O

[]`s

[30] Comentário enviado por arieldll em 31/12/2009 - 15:35h

agora já tem o zypper
zypper... :D não precisa mais, e o melhor. ele corrige até dependencias


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts