Instalar o driver para ATI Technologies Inc RS482 [Radeon Xpress 200M]

A maioria dos aplicativos 3D necessitam de um desempenho da placa gráfica, sendo ela on-board ou off-board, tais como: Blender, jogos e até mesmo alguns protetores de tela 3D. Este artigo descreve a instalação do driver proprietário da placa de vídeo ATI Radeon Xpress 200M mais atual (8.42.3).

[ Hits: 25.846 ]

Por: Mikael Ritlay em 26/11/2007


Introdução



Caros usuários do Viva o Linux,

Veremos a partir de agora como devemos proceder para instalar o driver da placa de vídeo ATI Technologies Inc RS482 [Radeon Xpress 200M] ou similar na versão 8.42.3, datado em 26 de outubro de 2007. Muitos aplicativos 3D exigem o desempenho máximo da placa gráfica, tais como: Blender (modelagem 3D), jogos em 3D (warzone) e até mesmo alguns protetores de tela 3D. Além disso podemos utilizar dois monitores para as mais diversas aplicações e a mais comum é ligar em um datashow para apresentações.

Instalando o driver

Primeiramente iremos identificar sua placa de vídeo com o seguinte comando no terminal:

$ sudo lspci

Procure a sessão VGA e veja qual o modelo da sua placa, deverá aparecer algo do tipo:

01:05.0 VGA compatible controller: ATI Technologies Inc RS482 [Radeon Xpress 200M]

Feito isso, agora vamos ao que interessa. Vamos baixar o driver em questão:

https://a248.e.akamai.net/.../ati-driver-installer-8.42.3-x86.x86_64.run

Salve o arquivo baixado em um diretório, agora vamos instalar os pacotes e bibliotecas necessárias:

$ sudo apt-get update
$ sudo apt-get install module-assistant build-essential fakeroot dh-make debhelper debconf libstdc++5 linux-headers-generic


Em seguida, ainda no terminal, entre no diretório onde o driver baixado foi salvo para criarmos os pacotes .deb:

$ sudo bash ati-driver-installer-8.42.3-x86.x86_64.run --buildpkg Ubuntu/feisty

Vamos habilitar os módulos restritos, abra o arquivo /etc/default/linux-restricted-modules-common com seu editor de texto como root, por exemplo:

Ubuntu/Gnome:

$ gksu gedit /etc/default/linux-restricted-modules-common

Kubuntu/KDE:

$ kdesu kate /etc/default/linux-restricted-modules-common

Agora adicione "fglrx" no campo "DISABLED_MODULES", de modo que fique assim:

DISABLED_MODULES="fglrx"

Instalando os pacotes .deb criados:

$ sudo dpkg -i xorg-driver-fglrx_8.42.3-*.deb \
fglrx-kernel-source_8.42.3-*.deb \
fglrx-amdcccle_8.42.3-*.deb


Nota: Se você tem um PC com 64 bits e ao fazer a instalação causa um erro do tipo "Errors were encountered while processing: fglrx-amdcccle", isso ocorre porque o pacote de dependência amdccle é para bibliotecas de 32 bits. Você pode resolver isso com o seguinte comando:

$ sudo apt-get install -f

Remova qualquer versão anterior dos módulos fglrx:

$ sudo rm /usr/src/fglrx-kernel*.deb

Compile os módulos kernel:

$ sudo module-assistant prepare
$ sudo module-assistant update

$ sudo module-assistant build fglrx
$ sudo module-assistant install fglrx
$ sudo depmod -a


Isso é necessário, pois algumas vezes este arquivo é escrito por outros pacotes, e por isso não há aceleração 3D. Agora crie a seguinte pasta:

$ sudo mkdir /lib/modules/$(uname -r)/volatile

Crie um link simbólico:

$ sudo ln -s /lib/modules/$(uname -r)/misc/fglrx.ko /lib/modules/$(uname -r)/volatile/fglrx.ko

Atenção: Você tem que recompilar o módulo do kernel depois de cada atualização do kernel. Agora reinicie sua máquina:

$ sudo shutdown -r now

Na página seguinte vamos para a configuração.

    Próxima página

Páginas do artigo
   1. Introdução
   2. Configurando o driver
Outros artigos deste autor
Nenhum artigo encontrado.
Leitura recomendada

Trazendo toda a usabilidade do GNOME 2 para o GNOME 3 do Ubuntu 11.10

VMware VCenter Converter - Convertendo Máquinas Físicas em Virtuais

Criando Redes Locais Virtuais (VLANs) com Linux

OpenVPN para clientes Windows no Debian Squeeze

Instalação da impressora HP LaserJet M1005 no Ubuntu 7.10

  
Comentários
[1] Comentário enviado por lestatwa em 26/11/2007 - 16:56h

<script>alert("Viva o Linux!!")</script>

[2] Comentário enviado por gesousa em 27/11/2007 - 06:01h

Detalhe se for instalar para o Ubuntu Gutsy AMD64
há um bug que deve ser corrigido antes...

extraia os arquivos...

./ati-driver-installer-8.42.3-x86.x86_64.run --extract

pegue o arquivo e extraia o conteudo para dentro da pasta do driver
http://www.michaellarabel.com/downloads/fglrx-8.42-ubuntu+debian-2.tar.bz2

construa o pacote para o Gusty
./ati-installer.sh 8.42.3 --buildpkg Ubuntu/gutsy
depois e so seguir os passos do artigo...

[3] Comentário enviado por mikaelrna em 27/11/2007 - 19:05h

Valeu pela dica gesousa!!!!
Viva o Linux

[4] Comentário enviado por giovanildo em 24/05/2008 - 05:27h

a minha placa eh ati radeon xpress 200 onboard, to empancando neste comando sudo module-assistant build fglrx aparece o seguinte na tela:

Construção do pacote fglrx-kernel-source falhou ! Como você │
│ deseja proceder ? │
│ │
│ VIEW Examinar o arquivo de log de construção │
│ CONTINUE Pular e continuar com a próxima operação │
│ STOP Parar de processar os comandos de construção

Se puderem me ajudar agradeceria muito

[5] Comentário enviado por ProfRobson em 21/10/2008 - 22:25h

e para instalar a radeon 9250 no ubuntu 8.04?

[6] Comentário enviado por mikaelrna em 27/10/2008 - 21:20h

caro robliu

vc ja tentou usar o envy disponivel em: http://albertomilone.com/nvidia_scripts1.html

pois ele baixa e instala o driver automaticamente

isso vale pra vc tbm giovanildo

[7] Comentário enviado por markusslima em 24/11/2009 - 08:07h

Estou com um problema ou dúvida:

$ sudo bash ati-driver-installer-8.42.3-x86.x86_64.run --buildpkg Ubuntu/feisty

Quando executo este comando acho que era para ele criar os pacotes .deb no mesmo diretório, ou não?
Se sim não sei qual o problema, baixei várias versões e nenhuma deu certo
eu fico parado no mesmo local.

por favor me ajudem.

grato!!!!

[8] Comentário enviado por abelfrancia em 17/09/2011 - 23:15h

Fala galera, tentei fazer segundo dito logo acima, mas não deu certo, copiei o resultado do comando:

$ sudo bash ati-driver-installer-8.42.3-x86.x86_64.run --buildpkg Ubuntu/feisty


Em relação ao:

$ sudo apt-get install module-assistant build-essential fakeroot dh-make debhelper debconf libstdc++5 linux-headers-generic

Diz que está tudo atualizado e que não achou o libstdc++5, vi no Synaptics que estou com o ++6.


Poderiam me ajudar?? =)



==================================================
ATI Technologies Linux Driver Installer/Packager
==================================================
Generating package: Ubuntu/feisty
Package build failed!
Package build utility output:
dpkg-buildpackage: set CFLAGS to default value: -g -O2
dpkg-buildpackage: set CPPFLAGS to default value:
dpkg-buildpackage: set LDFLAGS to default value: -Wl,-Bsymbolic-functions
dpkg-buildpackage: set FFLAGS to default value: -g -O2
dpkg-buildpackage: set CXXFLAGS to default value: -g -O2
dpkg-buildpackage: source package fglrx-installer
dpkg-buildpackage: source version 8.42.3-1
dpkg-buildpackage: source changed by ATI Technologies Inc. <http://ati.amd.com/support/driver.html>
debian/rules build
dpkg-buildpackage: host architecture i386
echo "Using architecture: i386"
Using architecture: i386
if [ -f /tmp/fglrx.gPGAPN/debian/control.template ]; then \
cat /tmp/fglrx.gPGAPN/debian/control.template > /tmp/fglrx.gPGAPN/debian/control; \
fi
for i in preinst postinst postrm shlibs atieventsd.init ; do \
if [ -f /tmp/fglrx.gPGAPN/debian/driver.$i ]; then \
sed -e "s/#PKGNAME#/xorg-driver-fglrx/" \
-e "s/#DISTRO#/feisty/" /tmp/fglrx.gPGAPN/debian/driver.$i > \
/tmp/fglrx.gPGAPN/debian/xorg-driver-fglrx.$i; \
fi; \
done
if [ -f /tmp/fglrx.gPGAPN/debian/10fglrx.template ]; then \
sed -e "s|#XMODDIR#|usr/lib|" -e "s|#XMODDIR32#|usr/lib32|" \
/tmp/fglrx.gPGAPN/debian/10fglrx.template > /tmp/fglrx.gPGAPN/debian/10fglrx; \
fi
if [ -f /tmp/fglrx.gPGAPN/debian/fglrx.default ]; then \
mv /tmp/fglrx.gPGAPN/debian/fglrx.default /tmp/fglrx.gPGAPN/debian/fglrx; \
fi
dh_testdir
dh_testdir
# move licenses away from binary dir
if [ ! -d usr/share/doc/fglrx ]; then \
mkdir -p usr/share/doc/fglrx; \
mv usr/X11R6/bin/LICENSE.* usr/share/doc/fglrx; \
fi
# set executable on user apps
find usr/X11R6/bin -type f | xargs chmod a+x
# remove exec bit from files that don't deserve it
find usr/X11R6/include \
usr/X11R6/lib \
usr/X11R6/lib64 \
usr/share usr/src -type f | xargs chmod -x
find: `usr/X11R6/lib64': No such file or directory
find lib -not -name "*.sh" -type f | xargs chmod -x
find lib -name "*.sh" -type f | xargs chmod +x
dh_testdir
debian/rules binary
echo "Using architecture: i386"
Using architecture: i386
if [ -f /tmp/fglrx.gPGAPN/debian/control.template ]; then \
cat /tmp/fglrx.gPGAPN/debian/control.template > /tmp/fglrx.gPGAPN/debian/control; \
fi
for i in preinst postinst postrm shlibs atieventsd.init ; do \
if [ -f /tmp/fglrx.gPGAPN/debian/driver.$i ]; then \
sed -e "s/#PKGNAME#/xorg-driver-fglrx/" \
-e "s/#DISTRO#/feisty/" /tmp/fglrx.gPGAPN/debian/driver.$i > \
/tmp/fglrx.gPGAPN/debian/xorg-driver-fglrx.$i; \
fi; \
done
if [ -f /tmp/fglrx.gPGAPN/debian/10fglrx.template ]; then \
sed -e "s|#XMODDIR#|usr/lib|" -e "s|#XMODDIR32#|usr/lib32|" \
/tmp/fglrx.gPGAPN/debian/10fglrx.template > /tmp/fglrx.gPGAPN/debian/10fglrx; \
fi
if [ -f /tmp/fglrx.gPGAPN/debian/fglrx.default ]; then \
mv /tmp/fglrx.gPGAPN/debian/fglrx.default /tmp/fglrx.gPGAPN/debian/fglrx; \
fi
dh_testdir
dh_testdir
# move licenses away from binary dir
if [ ! -d usr/share/doc/fglrx ]; then \
mkdir -p usr/share/doc/fglrx; \
mv usr/X11R6/bin/LICENSE.* usr/share/doc/fglrx; \
fi
# set executable on user apps
find usr/X11R6/bin -type f | xargs chmod a+x
# remove exec bit from files that don't deserve it
find usr/X11R6/include \
usr/X11R6/lib \
usr/X11R6/lib64 \
usr/share usr/src -type f | xargs chmod -x
find: `usr/X11R6/lib64': No such file or directory
find lib -not -name "*.sh" -type f | xargs chmod -x
find lib -name "*.sh" -type f | xargs chmod +x
dh_testdir
dh_testdir
dh_testroot
dh_clean -k
dh_clean: Compatibility levels before 5 are deprecated.
rm -f /tmp/fglrx.gPGAPN/debian/control
sed -e 's/#XSERVER#/xorg/g' debian/control.template > /tmp/fglrx.gPGAPN/debian/control
dh_testdir
dh_testroot
dh_clean -k
dh_clean: Compatibility levels before 5 are deprecated.
dh_installdirs
dh_installdirs: Compatibility levels before 5 are deprecated.
# Create the directories to install into
dh_installdirs -pxorg-driver-fglrx \
usr/lib \
usr/sbin \
usr/lib \
usr/lib/xorg/modules \
usr/lib/xorg/modules/drivers \
usr/lib/xorg/modules/linux \
etc/acpi \
etc/acpi/events \
etc/default \
etc/X11/Xsession.d
dh_installdirs: Compatibility levels before 5 are deprecated.
dh_installdirs -A -pxorg-driver-fglrx \
usr/bin \
usr/sbin \
usr/share \
usr/share/applnk \
usr/share/gnome \
usr/share/gnome/apps \
usr/share/icons \
usr/share/pixmaps
dh_installdirs: Compatibility levels before 5 are deprecated.
dh_installdirs -pxorg-driver-fglrx-dev \
usr/include \
usr/lib
dh_installdirs: Compatibility levels before 5 are deprecated.
dh_installdirs -pfglrx-kernel-source \
usr/src/modules/fglrx \
usr/src/modules/fglrx/debian
dh_installdirs: Compatibility levels before 5 are deprecated.
dh_install
dh_install: Compatibility levels before 5 are deprecated.
# Driver package
dh_install -pxorg-driver-fglrx "usr/X11R6/bin/fgl*" "usr/bin"
dh_install: Compatibility levels before 5 are deprecated.
dh_install -pxorg-driver-fglrx "usr/X11R6/bin/aticonfig" "usr/bin"
dh_install: Compatibility levels before 5 are deprecated.
dh_install -pxorg-driver-fglrx "usr/sbin/atieventsd" "usr/sbin"
dh_install: Compatibility levels before 5 are deprecated.
dh_installman -pxorg-driver-fglrx "usr/share/man/man8/atieventsd.8"
dh_installman: Compatibility levels before 5 are deprecated.
dh_install -pxorg-driver-fglrx "usr/X11R6/lib/*.so*" "usr/lib"
dh_install: Compatibility levels before 5 are deprecated.
dh_install -pxorg-driver-fglrx "usr/X11R6/lib/modules/dri" "usr/lib"
dh_install: Compatibility levels before 5 are deprecated.
dh_install -pxorg-driver-fglrx "usr/X11R6/lib/modules/linux" "usr/lib/xorg/modules"
dh_install: Compatibility levels before 5 are deprecated.
dh_install -pxorg-driver-fglrx "usr/X11R6/lib/modules/drivers" "usr/lib/xorg/modules"
dh_install: Compatibility levels before 5 are deprecated.
dh_install -pxorg-driver-fglrx "usr/X11R6/lib/modules/*.so" "usr/lib/xorg/modules"
dh_install: Compatibility levels before 5 are deprecated.
dh_install -pxorg-driver-fglrx "usr/X11R6/lib/modules/*.a" "usr/lib/xorg/modules"
dh_install: Compatibility levels before 5 are deprecated.
dh_install -pxorg-driver-fglrx "etc/ati" "etc"
dh_install: Compatibility levels before 5 are deprecated.
dh_install -pxorg-driver-fglrx "debian/10fglrx" "etc/X11/Xsession.d"
dh_install: Compatibility levels before 5 are deprecated.
dh_install -pxorg-driver-fglrx "debian/fglrx-powermode.sh" "etc/acpi"
dh_install: Compatibility levels before 5 are deprecated.
dh_install -pxorg-driver-fglrx "debian/fglrx-*-aticonfig" "etc/acpi/events"
dh_install: Compatibility levels before 5 are deprecated.
dh_install -pxorg-driver-fglrx "debian/fglrx" "etc/default"
dh_install: Compatibility levels before 5 are deprecated.
dh_installinit -pxorg-driver-fglrx --name="atieventsd"
Duplicate specification "O=s" for option "O"
dh_installinit: Compatibility levels before 5 are deprecated.
# Driver dev package
dh_install -pxorg-driver-fglrx-dev "usr/X11R6/lib/*.a" "usr/lib"
dh_install: Compatibility levels before 5 are deprecated.
dh_install -pxorg-driver-fglrx-dev "usr/X11R6/include/*" "usr/include"
dh_install: Compatibility levels before 5 are deprecated.
dh_install -pxorg-driver-fglrx-dev "usr/include/*" "usr/include"
dh_install: Compatibility levels before 5 are deprecated.
# Kernel source package
dh_install -pfglrx-kernel-source \
lib/modules/fglrx/build_mod/*.c \
lib/modules/fglrx/build_mod/*.h \
lib/modules/fglrx/build_mod/*.sh \
lib/modules/fglrx/build_mod/lib* \
lib/modules/fglrx/build_mod/2.6.x/Makefile \
usr/src/modules/fglrx
dh_install: Compatibility levels before 5 are deprecated.
dh_install -pfglrx-kernel-source "debian/changelog" "usr/src/modules/fglrx/debian"
dh_install: Compatibility levels before 5 are deprecated.
dh_install -pfglrx-kernel-source \
debian/copyright \
debian/compat \
module/rules \
module/control.template \
module/dirs.template \
module/postinst \
usr/src/modules/fglrx/debian
dh_install: Compatibility levels before 5 are deprecated.
(cd debian/fglrx-kernel-source/usr/src \
&& chown -R root:src modules \
&& tar -jcf fglrx.tar.bz2 modules \
&& rm -rf modules)
# control panel package
dh_install -A -pfglrx-amdcccle "usr/X11R6/bin/amdcccle" "usr/bin"
dh_install: Compatibility levels before 5 are deprecated.
dh_install -A -pfglrx-amdcccle "usr/share/icons/*.xpm" "usr/share/icons"
dh_install: Compatibility levels before 5 are deprecated.
dh_install -A -pfglrx-amdcccle "usr/share/icons/*.xpm" "usr/share/pixmaps"
dh_install: Compatibility levels before 5 are deprecated.
dh_install -A -pfglrx-amdcccle "debian/amdcccle.desktop" "usr/share/applications"
dh_install: Compatibility levels before 5 are deprecated.
dh_install -A -pfglrx-amdcccle "debian/amdcccle.kdelnk" "usr/share/applnk"
dh_install: Compatibility levels before 5 are deprecated.
dh_install -A -pfglrx-amdcccle "usr/share/ati" "usr/share"
dh_install: Compatibility levels before 5 are deprecated.
dh_desktop -pfglrx-amdcccle
dh_desktop: This program is deprecated, and does nothing anymore.
dh_desktop: Compatibility levels before 5 are deprecated.
# start the install
dh_installdocs
dh_installdocs: Compatibility levels before 5 are deprecated.
dh_installdocs -pxorg-driver-fglrx usr/share/doc/fglrx/*
dh_installdocs: Compatibility levels before 5 are deprecated.
#dh_installchangelogs
dh_link
dh_link: Compatibility levels before 5 are deprecated.
dh_strip
dh_strip: Compatibility levels before 5 are deprecated.
dh_compress
dh_compress: Compatibility levels before 5 are deprecated.
dh_makeshlibs
dh_makeshlibs: Compatibility levels before 5 are deprecated.
dh_installdeb
dh_installdeb: Compatibility levels before 5 are deprecated.
LD_PRELOAD= dh_shlibdeps
dh_shlibdeps: Compatibility levels before 5 are deprecated.
dpkg-shlibdeps: warning: symbol _XReadPad used by debian/xorg-driver-fglrx/usr/lib/libGL.so.1.2 found in none of the libraries.
dpkg-shlibdeps: warning: symbol XFree used by debian/xorg-driver-fglrx/usr/lib/libGL.so.1.2 found in none of the libraries.
dpkg-shlibdeps: warning: symbol XSetErrorHandler used by debian/xorg-driver-fglrx/usr/lib/libGL.so.1.2 found in none of the libraries.
dpkg-shlibdeps: warning: symbol dlsym used by debian/xorg-driver-fglrx/usr/lib/libGL.so.1.2 found in none of the libraries.
dpkg-shlibdeps: warning: symbol XGetErrorDatabaseText used by debian/xorg-driver-fglrx/usr/lib/libGL.so.1.2 found in none of the libraries.
dpkg-shlibdeps: warning: symbol dlclose used by debian/xorg-driver-fglrx/usr/lib/libGL.so.1.2 found in none of the libraries.
dpkg-shlibdeps: warning: symbol XMaxRequestSize used by debian/xorg-driver-fglrx/usr/lib/libGL.so.1.2 found in none of the libraries.
dpkg-shlibdeps: warning: symbol XCreateGC used by debian/xorg-driver-fglrx/usr/lib/libGL.so.1.2 found in none of the libraries.
dpkg-shlibdeps: warning: symbol XFreeFontInfo used by debian/xorg-driver-fglrx/usr/lib/libGL.so.1.2 found in none of the libraries.
dpkg-shlibdeps: warning: symbol XEHeadOfExtensionList used by debian/xorg-driver-fglrx/usr/lib/libGL.so.1.2 found in none of the libraries.
dpkg-shlibdeps: warning: 22 other similar warnings have been skipped (use -v to see them all).
dpkg-shlibdeps: warning: debian/xorg-driver-fglrx/usr/sbin/atieventsd contains an unresolvable reference to symbol XauFileName: it's probably a plugin.
dpkg-shlibdeps: error: couldn't find library libfglrx_gamma.so.1 needed by debian/xorg-driver-fglrx/usr/bin/fglrx_xgamma (ELF format: 'elf32-i386'; RPATH: '').
Note: libraries are not searched in other binary packages that do not have any shlibs or symbols file.
To help dpkg-shlibdeps find private libraries, you might need to set LD_LIBRARY_PATH.
dh_shlibdeps: dpkg-shlibdeps -Tdebian/xorg-driver-fglrx.substvars debian/xorg-driver-fglrx/usr/bin/fglrx_xgamma debian/xorg-driver-fglrx/usr/bin/aticonfig debian/xorg-driver-fglrx/usr/bin/fglrxinfo debian/xorg-driver-fglrx/usr/bin/fgl_glxgears debian/xorg-driver-fglrx/usr/sbin/atieventsd debian/xorg-driver-fglrx/usr/lib/libfglrx_gamma.so.1.0 debian/xorg-driver-fglrx/usr/lib/libGL.so.1.2 debian/xorg-driver-fglrx/usr/lib/libfglrx_tvout.so.1.0 debian/xorg-driver-fglrx/usr/lib/libfglrx_pp.so.1.0 debian/xorg-driver-fglrx/usr/lib/libfglrx_dm.so.1.0 debian/xorg-driver-fglrx/usr/lib/xorg/modules/linux/libfglrxdrm.so debian/xorg-driver-fglrx/usr/lib/xorg/modules/glesx.so debian/xorg-driver-fglrx/usr/lib/xorg/modules/drivers/fglrx_drv.so debian/xorg-driver-fglrx/usr/lib/dri/fglrx_dri.so returned exit code 2
make: *** [binary] Error 9
dpkg-buildpackage: error: debian/rules binary gave error exit status 2
Removing temporary directory: fglrx-install.BHToQq

[9] Comentário enviado por mikaelrna em 29/09/2011 - 14:20h

Caro abelfrancia,

Esse artigo deve estar desatualizado e no proprio site da AMD deve ter o mais atualizado, caso sua distribuição seja ubuntu ele ira detectar e instalar automaticamente.

Peço que verifique nesta pagina http://wiki.cchtml.com/index.php/Main_Page que contem varias informações sobre a instalação de drivers para diversas distribuições.

Qualquer coisa estamos aqui!!


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts