Instalando Adobe Flash 10 em distros amd64 (Ubuntu, Mandriva, Fedora)

A última versão do Adobe Flash Player 10 acaba com os problemas de noframe que as versões anteriores para Linux tinham. Mas novamente a Adobe não lançou uma versão para sistemas 64 bits. Segue um passo a passo de como instalar a última versão do Adobe Flash Player 10 em uma distro AMD 64.

[ Hits: 62.081 ]

Por: Erico Schuch em 05/08/2008 | Blog: http://eschuch.blogspot.com


Instalar ou atualizar?



Primeiro você tem que saber se sua distro atual possui o Adobe Flash 9, outro flash player ou nenhum flash instalado.

Para isso, abra o Firefox e digite no endereço about:plugins. Procure por Flash. Se você encontrar algo como:

Nome do arquivo: npwrapper.libflashplayer.so
Shockwave Flash 9

Você possui o Adobe Flash 9 e deve ser atualizado para o 10. Para isso pule para o tópico "Atualizando para Flash 10" adiante neste artigo.

Caso encontre outra coisa, como Gnash ou outro flash player ou até mesmo não encontre nada, vá para o próximo tópico.

Removendo outros flash players

Se você possui algum FlashPlayer que não seja o Adobe Flash Player 9, então ele deve ser removido. Para verificar, abra o Firefox, digite no endereço about:plugins e procure por flash. Deverá aparecer algo como Gnash ou qualquer outra coisa que não seja Flash 9. Abra o seu gerenciador de pacotes e digite os nomes que podem ser seu flash. O mais comum é o Gnash, mas pode ser qualquer outro. Procure por ele e remova.

Reinicie o Firefox e abra páginas como youtube ou outros sites com flash e veja se o Firefox pede para instalar o plugin. Se isso acontecer, ótimo!

Instalando Flash 10

Sem rodeios, abra a página:
e baixe "Download Plugin for Linux (TAR.GZ, 3.71 MB)".

Após baixar o arquivo, abra um shell, vire root, vá até a pasta onde salvou o arquivo e execute:

# tar -zxvf flashplayer10_install_linux*
# mkdir /var/lib/flash
# mv install_flash_player_10_linux/libflashplayer.so /var/lib/flash/
# nspluginwrapper /var/lib/flash/libflashplayer.so


Feche e abra novamente o Firefox, digite no endereço about:plugins e procure por flash. Agora deve aparecer algo tipo "Shockwave Flash 10."

Pronto! Seu Adobe Flash Player 10 está instalado. Abra a página da Tim ou Oi e não sofra mais com isso.

Se tiver algum erro, vá para o último tópico do artigo "Considerações finais" e veja alguns problemas que podem ocorrer e como resolver.

    Próxima página

Páginas do artigo
   1. Instalar ou atualizar?
   2. Atualizando para Flash 10
   3. Considerações Finais
Outros artigos deste autor
Nenhum artigo encontrado.
Leitura recomendada

Codificação e decodificação entre ASCII, hexadecimal e unicode

Entenda o XML - Parte 2

Google AdSense: Técnicas de otimização dos anúncios

Instalando plugin do Java no Firefox 0.8

Proteja seu website ou página html com encriptaçâo

  
Comentários
[1] Comentário enviado por albfneto em 05/08/2008 - 08:21h

Hoje eu testei. não instalou.aa mensagens de erro:

nspluginwrapper /var/lib/flash/libflashplayer.so
nspluginwrapper: no appropriate viewer found for /var/lib/flash/libflashplayer.so

Your architecture, \'x86_64\', is not supported by the
Adobe Flash Player installer.

[2] Comentário enviado por grandmaster em 06/08/2008 - 10:30h

:D
Rápido e prático.

Renato de Castro Henriques
CobiT Foundation 4.1 Certified ID: 90391725
http://www.renato.henriques.nom.br

[3] Comentário enviado por Érico Schuch em 07/08/2008 - 20:31h

albfneto: O artigo trata da configuração do novo Flash 10 para máquinas AMD, que está en versão de desenvolvimento ainda. Essa versão, segundo a própria Adobe, termina com as diferenças de ports entre Flash para Linux, Windows e Mac OsX. A principal diferença é com os windowless, como o site da Tim e Oi, que ao abrir o site inicial, ficava todo desconfigurado. Muito obrigado pelo comentário.

grandmaster: Obrigado pelo comentário. Tento sempre manter a praticidade, voltada para usuários que estão iniciando no Linux.

Qualquer dúvida, ou se descobrirem algo legal, manda o link ;)

[4] Comentário enviado por Erick92 em 08/08/2008 - 20:28h

Valeu mesmo cara!!!
Tava de saco cheio já, tinha hora que funcionava normal, mas tinha vez que ficava difícil...

[5] Comentário enviado por Érico Schuch em 08/08/2008 - 23:01h

Ola Erick92, obrigado pelo comentário !
Mas lembre-se que o Flash 10 é beta (ou alfa, pois na minha opinião, o flash 9 deveria ser beta ;).
Note: No meu caso, acabo de verificar uma quantidade de quebras maiores com a distro Mandriva 2009.
Volta e meia, principalmente quanto assisto vídeos da Globo, o Firefox faz CABUM (core dump).

[6] Comentário enviado por jaft em 06/01/2009 - 08:49h

Para Mandriva 64bits, baixe o arquivo http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-10.0.d21.1.linux-x86_64.so.tar....
descompacte e use o comando como root: ex.
xxxxxx]# mv libflashplayer.so /usr/lib64/mozilla/plugins
Onde, xxxxx é o diretório onde vc descompactou o arquivo libflashplayer.so
Feche e abra o firefox, só isso... Sem complicação.


[7] Comentário enviado por jansen.kurumin em 29/01/2009 - 17:08h

No meu atualizaei ofirefox e jah vei com o flash segue dicas

#apt-get upgrade

[8] Comentário enviado por helio2007 em 02/05/2009 - 18:13h

Olá amigos!

TENHO UM AMD 64 X2 COM HARDY HERON 8.04

TENHO UMA DICA QUE COLHI NUM BLOG AMERICANO QUE ALÉM DE SER EXTREMAMENTE FÁCIL, FUNCIONOU PERFEITAMENTE!!!!

TUDO O QUE PRECISA É DIGITAR NUM TERMINAL:

wget http://queleimporta.com/downloads/flash10_x64_en.sh && sudo chmod +x flash10_x64_en.sh && sudo sh ./flash10_x64_en.sh


Por segurança tudo o que estiver em seu computador com a intenção de utilizar o flash será desinstalado e o FLASH rodando lindamente vai entrar em ação....

ele simplesmente Rodará todo site que tiver flash player em extensões SWF e FLV


abraços á todos e curtam esta DICA!!!!

Hélio

[9] Comentário enviado por proxy101 em 31/10/2009 - 20:36h

Instalei o Ubuntu 9.10 amd64 e estou tentando instalar o Flash Player. Segui os passos deste artigo e obtive o seguinte:

[email protected]:/var/lib/flash# nspluginwrapper libflashplayer.so
nspluginwrapper, configuration tool. Version 1.2.2

usage: nspluginwrapper [flags] [command [plugin(s)]]

-h --help print this message
-v --verbose flag: set verbose mode
-a --auto flag: set automatic mode for plugins discovery
-n --native flag: allow native plugin(s) to be wrapped
-l --list list plugins currently installed
-u --update [FILE(S)] update plugin(s) currently installed
-i --install [FILE(S)] install plugin(s)
-r --remove [FILE(S)] remove plugin(s)

[email protected]:/var/lib/flash#

Creio que esta mensagem esteja dizendo que a sintaxe do comando nspluginwrapper está incorreta.
Gostaria que alguém, por gentileza, me ajude a resolver isso.

Desde já, obrigado a todos.

Germano.

[RESOLVIDO]

Axei a solução em http://ovigia.wordpress.com/2008/11/17/ja-bomba-o-flash10-64bit/

Apenas copiei o arquivo libflashplayer.so para o diretório ~/.mozilla/plugins e os vídeos do YouTube funcionaram.

[10] Comentário enviado por gpr.ppg.br em 26/08/2010 - 00:41h

tem mais dicas para ubuntu64 ?


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts