erro no squid [RESOLVIDO]

1. erro no squid [RESOLVIDO]

Douglas Giorgio Fim
douglas.giorgio

(usa FreeBSD)

Enviado em 19/02/2011 - 15:05h

estou tendo um erro muito estranho no squid e não sei o que é

==================================================

Shutting down Squid in 30 seconds:
Creating swap directories: /usr/sbin/squid -z
Starting Squid: /usr/sbin/squid -F
2011/02/19 17:08:48| ERROR: '0.0.0.0/0.0.0.0' needs to be replaced by the term 'all'.
2011/02/19 17:08:48| SECURITY NOTICE: Overriding config setting. Using 'all' instead.
2011/02/19 17:08:48| WARNING: (B) '::/0' is a subnetwork of (A) '::/0'
2011/02/19 17:08:48| WARNING: because of this '::/0' is ignored to keep splay tree searching predictable
2011/02/19 17:08:48| WARNING: You should probably remove '::/0' from the ACL named 'all'
2011/02/19 17:08:48| WARNING: Netmasks are deprecated. Please use CIDR masks instead.
2011/02/19 17:08:48| WARNING: IPv4 netmasks are particularly nasty when used to compare IPv6 to IPv4 ranges.
2011/02/19 17:08:48| WARNING: For now we will assume you meant to write /32





2. MELHOR RESPOSTA

Renato Carneiro Pacheco
renato_pacheco

(usa Debian)

Enviado em 21/02/2011 - 10:13h

Velho, é só remover essa linha:

acl all src 0.0.0.0/0.0.0.0

Ela não é mais necessária para a sua versão do squid, pois é algo q se tornou redundante.

3. squid.conf

Douglas Giorgio Fim
douglas.giorgio

(usa FreeBSD)

Enviado em 19/02/2011 - 15:23h

http_port 8080 transparent
visible_hostname VM-Slack-Server

acl all src 0.0.0.0/0.0.0.0
acl manager proto cache_object
acl localhost src 127.0.0.1/255.255.255.255
acl SSL_ports port 433 563
acl Safe_ports port 21 80 443 563 70 210 280 488 59 777 901 1025-65535
acl purge method PURGE
acl CONNECT method CONNECT

http_access allow manager localhost
http_access deny manager
http_access allow purge localhost
http_access deny purge
http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports

acl site dstdomain -i "/etc/squid/dominios_bloqueados"
always_direct allow site

acl rede1 src 192.168.2.0/24
http_access allow localhost
http_access allow rede1

http_access deny all



4. Re: erro no squid [RESOLVIDO]

Fabio Soares Schmidt
fs.schmidt

(usa Debian)

Enviado em 19/02/2011 - 20:19h

acl all src 0.0.0.0/0.0.0.0

troque para acl all src 0.0.0.0

e na sua acl localhost deixa somente 127.0.0.1, sem a mascara...


5. Re: erro no squid [RESOLVIDO]

Douglas Giorgio Fim
douglas.giorgio

(usa FreeBSD)

Enviado em 19/02/2011 - 21:13h

agr apareceu isso

========================

Shutting down Squid in 30 seconds:
Creating swap directories: /usr/sbin/squid -z
Starting Squid: /usr/sbin/squid -F
2011/02/19 23:16:40| WARNING: (A) '0.0.0.0' is a subnetwork of (B) '::/0'
2011/02/19 23:16:40| WARNING: because of this '0.0.0.0' is ignored to keep splay tree searching predictable
2011/02/19 23:16:40| WARNING: You should probably remove '0.0.0.0' from the ACL named 'all'



6. Re: erro no squid [RESOLVIDO]

Douglas Giorgio Fim
douglas.giorgio

(usa FreeBSD)

Enviado em 21/02/2011 - 22:51h

removi essa linha, e iniciou, sem erro =)

vlw


7. Nao entendi

Lucas Fernando De Oliveira
Snakiler

(usa Debian)

Enviado em 29/05/2012 - 17:13h

Voce removeu essa linha, qual linha?


8. Re: erro no squid [RESOLVIDO]

Fabiano Augusto Machado Rocha
farochasp

(usa Ubuntu)

Enviado em 16/08/2012 - 14:58h

[quote]douglas.giorgio escreveu:

http_port 8080 transparent
visible_hostname VM-Slack-Server

###acl all src 0.0.0.0/0.0.0.0###
acl manager proto cache_object
acl localhost src 127.0.0.1 ###/255.255.255.255###
acl SSL_ports port 433 563


galera sou novato, e agradeço pelas informações...

no meu caso eu removi as informações entre ###, e funcionou perfeitamente.


valeu!!!