Linux slogan
Visite também: BR-Linux.org · Dicas-L · Doode · NoticiasLinux · SoftwareLivre.org · UnderLinux



» Screenshot
Linux: slackware 10.1 + kde + gxine
Por favs
» Login
Login:
Senha:

Se você ainda não possui uma conta, clique aqui.

Esqueci minha senha


Comunidades

Lan Acer Aspire 4553 [RESOLVIDO]

[1] Enviado em 15/03/2011 - 09:47h Lan Acer Aspire 4553 [RESOLVIDO]
Linux user: Claiton Tadeu Bulhões Junior
tux0333

(usa Slackware)


Ola bom dia, sou iniciante no Linux e optei pelo slackware (sei que é loucura mas estou disposto a aprender batendo cabeça)

Eu instalei o Slack 13.1 no meu Notebook Acer Aspire 4553 e nao estou conseguindo configurar a Internet nele. Acredito que seja problema de driver pois nem a luzinha da LAN acende, entao achei um driver para ele que esta em tar.gz

Seguindo os passos para instalar o pacote ele mandou eu usaro "make install" mas qunado uso ele fala que nao consegue encontraro arquivo de configuraçao.

Fui ler sobre o assunto e parece que é pq nao tenho instalado o pacote no Slack . Eu ja baixei uma fonte do kernel que tem ele mas nao sei fazer o make funcionar no console, nao sei c tem q criar um link ou vinculo.

Se alguem puder me ajudar agradeço, ou fazendo o make funcionar ou me dando informações de como configurar para funcionar a LAN no meu notebook.

Agradeço desde já

 

  


[2] Enviado em 15/03/2011 - 10:03h Re: Lan Acer Aspire 4553 [RESOLVIDO]
Linux user: Alan Souza
alan-souza

(usa Slackware)


Você verificou realmente se o seu adaptador de rede não foi mesmo identificado?

# iwconfig

Se não foi é necessário fazer a instalação e o carregamento do módulo de seu adaptador!

# lspci

Posta a saída aqui!

 

[3] Enviado em 15/03/2011 - 11:37h Re: Lan Acer Aspire 4553 [RESOLVIDO]
Linux user: Claiton Tadeu Bulhões Junior
tux0333

(usa Slackware)


Opa, obrigado pela resposta ... eu digitei o lspci e apareceu isso aqui.

Entao eu


00:00.0 Host bridge: Advanced Micro Devices [AMD] RS780 Host Bridge Alternate
00:01.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (int gfx)
00:04.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 0)
00:06.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 2)
00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [AHCI mode]
00:12.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:12.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:13.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 41)
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)
00:14.3 ISA bridge: ATI Technologies Inc SB700/SB800 LPC host controller (rev 40)
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge (rev 40)
00:14.5 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI2 Controller
00:16.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:16.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:18.0 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Link Control
01:05.0 VGA compatible controller: ATI Technologies Inc M880G [Mobility Radeon HD 4200]
01:05.1 Audio device: ATI Technologies Inc RS880 Audio Device [Radeon HD 4200]
02:00.0 Ethernet controller: Attansic Technology Corp. Device 1073 (rev c0)
03:00.0 Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)



Aparentemente ele detecto a placa né? como faço pra fazer ela funcionar tem alguma ideia ?

 

[4] Enviado em 15/03/2011 - 13:51h Re: Lan Acer Aspire 4553 [RESOLVIDO]
Linux user: Ciro Souza
cirofsouza

(usa Slackware)


Tenta usar o comando

iwconfig

e verifica se ele detecta sua placa informando que existe uma placa de wireless. Ele vai identificar sua placa de rede wireless como wlan0 ou wlan1 ou outro numero. Entao tente usar o comando:

ifconfig wlanX up

Voce deve sustituir o X de wlanX pelo numero da placa identificada anteriormente. Se tudo estiver certo sua placa funciona de primeira. Aí é so configurar o resto - IP, DNS, Gateway, etc, etc, etc.

P.S.: Todos os comandos so funcionam como root (use o comando su e coloque a senha do root que dá o mesmo efeito).


 

[5] Enviado em 15/03/2011 - 18:45h Re: Lan Acer Aspire 4553 [RESOLVIDO]
Linux user: Claiton Tadeu Bulhões Junior
tux0333

(usa Slackware)


Certo o Wireless ele detecto bonitinho ai quando digitei o # ifconfig wlanX up ele nao fez nada ...


Eu queria configurar a LAN ... a Ethernet pq em casa uso conexao atraves de cabo crossover e to sem roteador por enquanto ... alguma ideia de como fazer detectar o eth?

 

[6] Enviado em 16/03/2011 - 00:38h Re: Lan Acer Aspire 4553 [RESOLVIDO]
Linux user: Alan Souza
alan-souza

(usa Slackware)


Olá amigo, desculpe-me a demora, pois eu estava para a faculdade!

Bem... Creio que este adaptador seu use chipset Atheros!

Então, vamos aos passos:

Faça o download do driver do site da própria Atheros:

http://partner.atheros.com/Download.aspx?id=162

Faça um download em um diretório separadi e sem nada dentro dele, de preferência!

Após o download:
Acesse a pasta;

$ tar zxvf AR81Family-Linux-v1.0.1.9.tar.gz
$ cd src
$ make
$ su
# make install
# cp atl1e.ko /lib/modules/`uname -r`/kernel/drivers/net/atl1e/
# modprobe atl1e
# depmod -a

Verifique agora com o comando ifconfig ou iwconfig se seu adaptador é reconhecido! Ele deve estar no formato ethX, onde X é o número de interface rede que pode variar de 0 até um número finito.

Se ela foi reconhecida:

Agora você precisa colocar o módulo do driver para iniciar junto com o sistema, pois, senão, você terá que carregá-lo manualmente toda vez que carregar o sistema.

Abra o arquivo rc.local que se encontra dentro de "/etc/rc.d/rc.local".

No terminal mesmo:

# nano /etc/rc.d/rc.local

Agora adicione a linha, no final do arquivo:

/sbin/modprobe atl1e

Para salvar e sair dê:

CTRL+O e <ENTER>
CTRL+X

Senão, reporta ai mais informações!

Boa Sorte!

 

[7] Enviado em 16/03/2011 - 00:50h Re: Lan Acer Aspire 4553 [RESOLVIDO]
Linux user: Claiton Tadeu Bulhões Junior
tux0333

(usa Slackware)


Opa obrigado mais uam vez, desculpa a insistencia mas relamente não to conseguindo sozinho.

Fiz tudo ao chegar no

# make install

Apareceu a seguitne mensagem:

Makefile:105 *** Linus kernel source not configured - missing autoconf.h. Stop.

E agora ?

 

[8] Enviado em 16/03/2011 - 01:01h Re: Lan Acer Aspire 4553 [RESOLVIDO]
Linux user: Alan Souza
alan-souza

(usa Slackware)


Perdão! Eu já reformulei a resposta!

 

[9] Enviado em 16/03/2011 - 11:35h Re: Lan Acer Aspire 4553 [RESOLVIDO]
Linux user: Claiton Tadeu Bulhões Junior
tux0333

(usa Slackware)


Fiz tudo novamente

Quando chego a parte de digitar o $ make apareceu de novo a mesma mensagem.

Makefile:105 *** Linux kernel source not configured - missing autoconf.h. Stop.


 

[10] Enviado em 16/03/2011 - 13:31h Re: Lan Acer Aspire 4553 [RESOLVIDO]
Linux user: Alan Souza
alan-souza

(usa Slackware)


Olá amigo você está com o Kernel Source instalado?

Ele via no diretório k da pasta Slackware do CD do próprio Slackware!

Mas, você pode usar o comando:

# slackpkg install k

ou

# slackpkg install kernel-source

Para fazer a instalação!

 

[11] Enviado em 16/03/2011 - 18:46h Re: Lan Acer Aspire 4553 [RESOLVIDO]
Linux user: Claiton Tadeu Bulhões Junior
tux0333

(usa Slackware)


Não deu certo ... rodei seu comando ai como era primeira vez que executava tive q tirar o Mirror do comentario. fiz isso direcionando ao DVD Slack64 e cnsegui dar o update tb ... mas na hora de instalar ele fala q nao conseguiu achar o mirror.

Entao pesquisei no google e achie uma maneira de instalar q e copiar os arquivos para a pasta /home/teste e rodar dentro dela o #pkgtool e instalar "from current". Fiz isso certinho com o kernel-source normal ...

Tentei rodar de novo o #Make e continua mesma mensagem para configurar o autoconf.h

Agora eu to vendo no # pkgtool q eu ja tenho o kernel-source instalado assim como o # make ... entao acho q o problema e configura o make no autoconf.h . Vc sabe como fazer isso ? pq eu nao sei =/

 

[12] Enviado em 17/03/2011 - 00:34h Re: Lan Acer Aspire 4553 [RESOLVIDO]
Linux user: Alan Souza
alan-souza

(usa Slackware)


Você fez alguma configuração em seu Kernel, recompilou ele ou instalou outra versão do Kernel?

 

  
<< Primeira | Anterior Próxima | Última >>
Responsável pelo site: Fábio Berbert de Paula - Conteúdo distribuído sob licença GNU FDL
Site hospedado por:

Viva o Linux

A maior comunidade Linux da América Latina! Artigos, dicas, tutoriais, fórum, scripts e muito mais. Ideal para quem busca auto-ajuda em Linux.