Instalando o adaptador DWA-110 no Ubuntu

Publicado por Hugo Leonardo Campos Ferreira em 27/06/2008

[ Hits: 20.214 ]

 


Instalando o adaptador DWA-110 no Ubuntu

Resolvi escrever esta dica porque não encontrei nenhum material na Internet do tipo "Siga-me e obtenha sucesso". Apesar disso, não foi nada difícil instalar este adaptador wireless USB no Ubuntu.

Para instalá-lo vamos precisar do ndiswrapper. Em poucas palavras, este programa "converte" um driver do Windows para que o Linux consiga usar.

Veja como foi fácil:
  1. Abra o Synaptic (Sistema / Administração / Gerenciador de Pacotes Synaptic)
  2. Pesquise por ndiswrapper
  3. Selecione o pacote ndisgtk e automaticamente suas dependências serão marcadas (por isso amo o apt) :-)
  4. Clique em "Aplicar"

Após instalar, vá no menu Sistema / Administração / Windows Wireless Drivers:
  1. Clique no botão "Instalar Novo Driver"
  2. Supondo que você comprou o adaptador junto com o CD de instalação, insira o CD no drive
  3. Localize o arquivo do driver (dr71wu.inf) no CD (está em cdrom/driver/drivers/winxp_2k_9x/dr71wu.inf)
  4. Clique em "Instalar"
  5. Sinta-se emocionado ao ver que o led indicador de atividade do adaptador acendeu (sinal que ele já está funcionando)

Foi só isto. Ridículo, não? E você aí, achando que era bicho de 9 cabeças...

Isto foi testado no Ubuntu 8.04 32 bits e funcionou de primeira. Não sei qual será o resultado em outras distros ou mesmo no Ubuntu 64.

Qualquer coisa, se alguém por acaso não tiver o CD e não conseguir baixá-lo no site do fabricante, mande-me um e-mail que na medida do possível encaminho o driver.

Um abraço!

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

SM56 Motorola com driver Smartlink

Emuladores para ajudar em aulas

Instalando placa de rede HP NC382T (chipset Broadcom BCM 5709) no Debian Lenny

Driver SmartLink corrigido para kernels 2.6.12 em diante

Instalando o modem LG I56N (smartlink) no OpenSUSE 10.2


Comentários
[1] Comentário enviado por josir em 28/06/2008 - 09:40h

Valeu Hugo! Vc poderia postar a versão do firmware ou outras informações de hardware que vc tiver disponível ?

Estou atualizando o Wiki do Ubuntu e vou fazer referência ao seu post.

[2] Comentário enviado por hugonardo em 29/06/2008 - 19:39h

Olá Josir! Tudo bom?

Estão ai algumas informações adicionais sobre o hardware:

Marca: D-Link
Modelo: DWA-110 Wireless G USB Adapter
Firmware Ver.: 1.00
H/W Ver.: A1
USB 2.0/1.1 Compatível

Depois manda o link do Wiki que vou querer conferir!

Abraços.

[3] Comentário enviado por josir em 30/06/2008 - 10:59h

Valeu Hugo. Segue o link:

https://help.ubuntu.com/community/HardwareSupportComponentsWirelessNetworkCardsDlink

Estamos cadastrando todas as placas compatíveis.
Um abraço,
Josir.

[4] Comentário enviado por josir em 30/06/2008 - 11:00h

Valeu Hugo. Segue o link:

https://help.ubuntu.com/community/HardwareSupportComponentsWirelessNetworkCardsDlink

Estamos cadastrando todas as placas compatíveis.
Um abraço,
Josir.

[5] Comentário enviado por RPCC em 31/07/2008 - 15:03h

kraa, no ubuntu 8,04 LTS 64 bits instalaaa + u led nao liga =\

no Synaptic aparece instalado com Hardware presente !

+ nao funfa :(

[6] Comentário enviado por hugonardo em 31/07/2008 - 17:38h

É verdade, percebi isto também, quando , sem querer, instalei o Ubuntu 7.10 64 no meu PC e tentei instalar o driver. O nsdiswrapper instala, mas o driver... Nda nda nda...
Então, voltei pro bom e velho 32 bits msm.

[7] Comentário enviado por PCC em 01/08/2008 - 02:14h

nao tem como da um --force-archtecture ?

[8] Comentário enviado por lostgamex em 13/08/2008 - 21:12h

Amigo, instalei adptador usb d-link dwa -110, instalei o drive do winxp com o ndisgtk, detecta a rede que uso com wep, mas não acessa a internet . pode me ajudar não tenho como
logar pela placa de rede, uso somente wireless. Sou um novo usuario do linux. Socorro.

Há proposito uso o ubuntu 8.04 32 bits

[9] Comentário enviado por hugonardo em 19/10/2008 - 11:43h

lostgamex, não entendi seu problema. Seria um "conecta mas não navega"? Neste caso pode ser algum problema com a configuração de seu roteador.

Weslei, perdão kra, perdi seu email e não consegui enviar o driver. O Gmail chia por ter anexos binários.
Alguém cenhece alguma maneira para enviar esse driver?

Ha! PCC, não sei se tem como dar um --force-architecture. Na verdade não tive mto esforço pra fazer o driver funcionar no sistema 32 bits e no meu pc um sistema 64bits não me traria benefício algum, só dor de cabeça. Então não pesquisei a respeito.

[10] Comentário enviado por josir em 28/08/2009 - 08:40h

Só para constar pessoal: no Ubuntu 9.04 o DWA-110 funciona plug-and-play. É conectar na USB que o Ubuntu reconhece na hora.

[11] Comentário enviado por claudiosilvahp em 07/11/2009 - 15:00h

Muito obrigado cara...

[12] Comentário enviado por fbugnon em 15/01/2012 - 11:43h

Pra facilitar para quem for fazer a instalação, abaixo os links diretos para baixar os drivers do site da Dlink (H/W ver A1 e B1):

DRIVER_DWA-110_A1_v1.50.zip
ftp://ftp.dlinkla.com/pub/drivers/DWA-110/DRIVER_DWA-110_A1_v1.50.zip

DRIVER_DWA-110_B1_2.00.zip
ftp://ftp.dlinkla.com/pub/drivers/DWA-110/DRIVER_DWA-110_B1_2.00.zip

[13] Comentário enviado por clediolima em 26/03/2014 - 13:24h

Instalei no Ubuntu 13.10 da seguinte forma:

Passo 1: Instale o modules-assistant pela Central de Programas do Ubuntu;

Passo 2: Baixe o pacote rt73-source no endereço abaixo:

http://packages.ubuntu.com/lucid/all/rt73-source/download

Passo 3: Abra o arquivo que você baixou com a Central de Programas do Ubuntu.

Passo 4: Reinicie o pc e insira o adptador wireless. Vai reconhecer de primeira!!!



Contribuir com comentário