Linux slogan
Visite também: BR-Linux.org · Dicas-L · Doode · NoticiasLinux · SoftwareLivre.org · UnderLinux



» Screenshot
» Login
Login:
Senha:

Se você ainda não possui uma conta, clique aqui.

Esqueci minha senha


Dica

3G VIVO ZTE MF626 Ubuntu 9.04
Linux user
Publicado por João Marcelo Faustino em 22/06/2009

Login: kvix, 66111 pontos
[ Hits: 64969 ]

3G VIVO ZTE MF626 Ubuntu 9.04

Olá senhores,

Após apanhar muito tentando instalar o 3G da Vivo em meu netbook Acer Aspire One A110, consegui uma solução bem simples e gostaria de compartilhar com todos.

1) Utilizei a versão para netbook do Ubuntu 9.04 (acredito que sirva para todas as instalações Ubuntu 8.04, 8.10 e 9.04).

2) $ sudo apt-get update

3) $ sudo apt-get upgrade

4) Baixe e instale a atualização do kernel que pode ser conseguido no endereço abaixo:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.29.4/

* No meu caso estou utilizando a versão de 32 bits

Instale os 3 pacotes na ordem abaixo:
  • linux-headers-2.6.29-02062904_2.6.29-02062904_all.deb
  • linux-headers-2.6.29-02062904-generic_2.6.29-02062904_i386.deb
  • linux-image-2.6.29-02062904-generic_2.6.29-02062904_i386.deb

5) Instale o pacote vivo-1.0.0B03.i386.deb (fornecido dentro do próprio modem) para instalar o discador vivo 3g (versão completamente igual a utilizada pelo Windows).

6) Ocorrerá um erro na tentativa de instalação do pacote vivo-1.0.0B03.i386.deb devido a uma diferença entre o kernel utilizado no pacote da vivo e o kernel que você acabou de atualizar. Ignore e termine a instalação...

7) Reinicie o computador.

8) Plugue o modem vivo 3g zte mf626 (neste momento seu modem deverá ser reconhecido e abrirá uma tela para configurar a conexão - CANCELE).

9) Entre na aba INTERNET e execute o programa VIVO CONNECTION MANAGER.

10) Clique em connect.

PRONTO!!!!

Espero ter ajudado...


Outras dicas deste autor
Nenhuma dica encontrada.

Leitura recomendada
   Dica Linux recomendada Usando apelidos no Opera
   Dica Linux recomendada ADSL no Slackware 10.2
   Dica Linux recomendada Configurar Modem 3G Vivo Huewai e156 no Metamorphose Linux
   Dica Linux recomendada VOL Mobile - Versão pelo Google
   Dica Linux recomendada Instalando Modem 3G no Ubuntu 12.10 e Linux Mint 14

Comentários
[1] Comentário enviado por hcavjr em 23/06/2009 - 22:56h:

Não consigo acessar nenhum arquivo dentro do modem. Onde posso encontrar o arquivo vivo-1.0.0B03.i386.deb para download?
Por acaso o zte mf626 da vivo deveria ter vindo com cartão de memória?


[2] Comentário enviado por kvix em 24/06/2009 - 13:51h:

Não vem c/ cartão de memória não... Na verdde ele tem uma mini memória interna que traz de fábrica os arquivos de instalação... de qualquer forma, estou disponibilizando no site de minha empresa todos os arquivos necessários na instalação do vivo 3g...

segue o link abaixo

http://www.kvix.com.br/downloads/vivo-1.0.0B03.i386.deb

http://www.kvix.com.br/downloads/linux-headers-2.6.29-02062904_2.6.29-02062904_all.deb

http://www.kvix.com.br/downloads/linux-headers-2.6.29-02062904-generic_2.6.29-02062904_i386.deb

http://www.kvix.com.br/downloads/linux-image-2.6.29-02062904-generic_2.6.29-02062904_i386.deb

Mais uma vez, espero ter ajudado!


[3] Comentário enviado por adamfoerster em 25/06/2009 - 00:27h:

Tenho o mesmo modem mas eh da Brasil Telecom. Sabe qual o procedimento?
Uma outra duvida, esses arquivos linux-header nao sao do kernel do linux?
Fazendo isso eu nao perco as atualizacoes de seguranca automaticas do ubuntu?
Voce experimentou alguma incompatibilidade depois de instalar esse kernel?

Se puder responder uma ou mais dessas questoes ficarei muito agradecido.


[4] Comentário enviado por hcavjr em 25/06/2009 - 01:32h:

Segui os procedimentos que você descreveu.
Ao instalar o pacote da Vivo deu erro ao compilar o driver, mas rebutei e conectei o modem que foi detectado como vc disse.
Ao executar o ZMC ele demora um tempo, acende o led verde do modem e abre o painel, igual ao do Windows.
Porém ele fica inicializando e não libera para clicar no botão Conectar.
Fiz um teste com o kppp (estou usando o Kubuntu 9.04) e conectou. Mas sempre tenho que executar o ZMC primeiro para configurar.
Por acaso você tem alguma idéia para funcionar o ZMC inteiro?


[5] Comentário enviado por kvix em 25/06/2009 - 10:33h:

### IMPORTANTÍSSIMO ###

O pacote só vai funcionar se antes da instalção do ZMC-VIVO for atualizado o kernel p a versão informada acima...

O kernel, como podem verificar, eu retirei do próprio site do ubuntu...

No meu acer aspire one c/ ubuntu netbook 9.04 está funcionando tudo perfeitamente.. wireless, 3g, cabo, audio e vídeo... Não notei nehuma incompatibilidade...

hcavjr vc atualizou o kernel antes de instalar o zmc-vivo??? tive esse problema na primeira vez que instalei o pacote, mas após atualizar o kernel ele conectou direitinho...


[6] Comentário enviado por hcavjr em 25/06/2009 - 17:37h:

Sim atualizei. Segui passo a passo da forma que você descreveu.
O ZMC mostra a tela com o botão "Connet to Vivo?" e o status "Initializing...", mas não sai disso.
O modem é ativado (acende led verde), mas não mostra o sinal, rede e nem o SIM card.
Se eu cancelo o ZMC, o led verde continua aceso, então consigo conectar pelo kppp.
Parece que o ZMC fica aguardando alguma informação do modem sobre a rede, sinal, etc.
Já o kppp só se preocupa em conectar.



[7] Comentário enviado por kvix em 26/06/2009 - 08:37h:

Eu tive o mesmo problema que vc está relatando, a luz ficava verde porém o zmc informava a mensagem concting... e não saia disso...

fiz apenas a atualização do kernel (peguei isso em algum post sobre mf626 pelo google) e logo depois o zmc conectou perfeitamente... exatamente igual o windows....

tenta dar um uname -a e verifica se o seu kernel está assim 2.6.29-02062904-generic por favor...


[8] Comentário enviado por hcavjr em 28/06/2009 - 02:56h:

O kernel está certo.
Apareceu outro problema. O pacote da vivo não deve ter concluído a instalação corretamente e agora não instala nem atualiza mais nada.
Tentei remover, reinstalar, mas não adianta.
Vou reinstalar o Kubuntu para corrigir o problema.
Eita, o Linux tá cada vez mais parecido com o Windows... :-)


[9] Comentário enviado por kvix em 28/06/2009 - 12:00h:

tenta fazer no terminal:

dpkg -r zmc-vivo

que ele vai desinstalar o pacote e liberar o apt-get


[10] Comentário enviado por rafael-bahia em 02/07/2009 - 09:51h:

Sei que o titulo é bem claro que é no Ubuntu, meu problema é que estou usando o Insigne. Alguem sabe me dizer se o procedimento é o mesmo?


[11] Comentário enviado por yann em 08/07/2009 - 17:19h:

comprei um modem vivo ZTE

MF626, mas ele não instala de jeito nehum no sistema operacional linux. ja tentei de tudo. por favor me ajudem.


[12] Comentário enviado por ml em 22/07/2009 - 18:20h:

consegui configurar tudo conforme você disse, só que o firefox não detecta que a conexão está ativa. Eu conecto normal pelo programa da Vivo e o firefox não reconhece. Quando eu configuro para acessar pela conta configurada no ubuntu mesmo, acesso normalmente a internet, o firefox funciona.

Você saberia me informar como eu poderia configurar os programas que acessam a internet para que eu possa utilizar a conexão efetuada pelo vivo connection manager e não pela rede configurada no ubuntu através daquele assistente.

Interessante que na primeira vez que eu conectei pelo programa o firefox reconheceu, mas depois não reconheceu mais, mesmo eu colocando só o programa como conexão padrão (sem configurar nenhuma outra banda larga móvel, nem mesmo a da vivo).



[13] Comentário enviado por ml em 22/07/2009 - 18:22h:

Obs: Ele não fica no modo offline, sempre desmarco aquela seleção.


[14] Comentário enviado por sergiogurgel em 02/08/2009 - 09:13h:

Eu fiz isso mas minhas tela ficou cheio de "riscos". Desconfigurou minha tela.
Aconteceu contigo?


[15] Comentário enviado por netocba em 06/08/2009 - 19:57h:

Amigo uma dica nem precisa de tudo isso

e so vc pegar um arquivo que tem no ubuntu 7.10, 8.04, 8.10 chamado , wdial.conf , ai vc coloca como estava na distrubuicao anterior... no mesmo caminho ex: /etc/ppp ---> wdial.conf , ai vc edita ele e coloca as informacoes de sua operadora , no caso a minha foi BRT , ai e so vc reiniciar que ele levantara discando e conectando...


fiz assim e funcionou qualquer duvida

netto_cba@hotmail.com

t mais..


[16] Comentário enviado por carlosaugusto em 26/08/2009 - 17:42h:

Olá amigos,

Estou com um ZTE MF626 - VIVO no Ubuntu 9.04

Fiz todos esses procedimentos, muito boa as dicas,
mas no entanto eu não consigo navega,

Até consigo conectar no Skype e baixa no BitTorrent.

Mas a navegação pelo Mozilla ou Opera não vai.
nem ao menos o Pidgin.

Alguém sabe o que eu posso fazer?

Obrigado desde já.


[17] Comentário enviado por diegowalisson em 01/09/2009 - 15:46h:

Galera, depois de instalar os pacotes do novo kernel e o pacote da vivo, reinicie a máquina e dê boot por este kernel. Aí espete o modem, logo aparecerá na área de trabalho o ícone ZTEMODEM, botão direito do mouse nele e ejete o modem. Pronto! É so abrir o Vivo Conection Manager e conectar numa boa.
OBS: Se não ejetar o modem, ele não conecta. Me parece que só assim ele é reconhecido como modem e não como um pen-drive.


[18] Comentário enviado por andreuebe em 11/09/2009 - 19:47h:

Carlos Augusto

Verifique se o seu arquivo de DNS /etc/resolv.conf está com o DNS da Vivo:

nameserver 200.220.227.56
nameserver 200.142.130.10


Abs

Andre


[19] Comentário enviado por andreuebe em 11/09/2009 - 19:52h:

Tive o mesmo problema que o hcavjr.

Em vez de usar o programa da vivo (que continua "travando" no "connect"):

- Acessei com o botão direito o icone de conexão no lado direito da barra de tarefa superior
- Fui em "Editar conexões"
- Fui na aba "Banda Larga Movel"
- Editei
- Cliquei na opção "Conectar Automaticamente"
- E na opção "Disponível para todos os usuários".

Finalizando este processo, a luz verde começou a piscar mostrando a transferencia de dados.

Abs

Andre Uebe


[20] Comentário enviado por hcavjr em 17/09/2009 - 01:24h:

andreuebe, eu também tentei fazer a conexão pelo networkmanager, mas ele conecta e 3 a 4 segundos depois desconecta.
Parece que ele fica aguardando alguma informação do pppd que nunca vem e cancela.

Então usei a dupla usb_modeswitch (esse faz o eject automático para reconhecer o modem) + pppd e criei uma regrinha no udev para automatizar o processo de conexão.
Funcionou quase perfeitamente se não fosse por dois problemas.

Às vezes, assim que o modem é detectado e o pppd começa a tentar se comunicar com ele, o modem fica em loop respondendo com +ZUSIMR:2 a cada 2 segundos e não aceita os comandos do pppd (os comandos AT que o chat envia). Só consegui contornar removendo o modem e conectando de novo.

Outro problema é que eventualmente (às vezes demora 20 minutos, às vezes 3 horas) o modem continua piscando mas para de responder. Quando isso acontece, passa mais uns 2 minutos os dispositivos /dev/ttyUSB? somem e o modem desliga sozinho. Aí só removendo o modem e conectando de novo.

Vou tentar atualizar para o kernel 2.6.31 e ver no que dá.


[21] Comentário enviado por hcavjr em 17/09/2009 - 01:42h:

Maravilha, funcionou...
Agora vamos ver se não surgirá nenhuma surpresa.

Instalei o kernel 2.6.31 na mesma sequencia de pacotes que o João Marcelo descreveu aqui.
Reiniciei, conectei o modem que foi detectado como pendrive.
Ejetei e foi detectado como modem (esse processo pode ser substituido pelo usb_modeswitch ou um simple eject).
Aí criei a conexão pelo ícone do networkmanager.


[22] Comentário enviado por alex_camargo em 04/10/2009 - 22:52h:

Olá, sou novo no forum e após varias tentativas consegui fazer meu modem 3g da vivo conectar no Ubuntu 8.01. Mas o problema que o navegador não reconhece a conexão. Se alguem puder me ajudar.. Ja dei uma olhada nos arquivos

wvdial.conf - resolv.conf

e tudo parece normal.

O estranhho que a primeira vez consegui navega numa boa, mas apos reiniciar o pc, conecta mas não navega. (ja verifiquei o modo Offline)

Valeu!


[23] Comentário enviado por alex_camargo em 05/10/2009 - 16:36h:

Consegui, após várias tentativas. O que acontece é que o arquivo wvdial.conf que vem no modem só funciona como "root". Agora da pra conectar e navegar. O problema é que só funciona logado como "root", é perigoso, mas esse é o único jeito que consegui navegar..

Valeu!


[24] Comentário enviado por @ngelux em 13/10/2009 - 11:16h:

Mano, muito bom instalei no meu ubutu 9.04 e ficou show... vlw!!!!!!!!!!!!!!!!!


[25] Comentário enviado por hcavjr em 11/11/2009 - 02:21h:

Se alguém perceber que o modem desliga sozinho depois de algum tempo de uso, é porque o modem fica enviando mensagens em outra porta USB e quando a fila enche, ele se desliga. Para evitar isso, é só deixar um "tail" pendurado na porta. Estou usando a ttyUSB2 para conectar o pppd e a ttyUSB1 para controle, então:

tail -f /dev/ttyUSB1

Também dá para interpretar as mensagens recebidas nessa porta. Por exemplo, fiz um script que fica lendo esta porta e quando detecta um NO CARRIER, ele chama novamente o pppd para reconectar.
E também é por aí que dá para tratar as mensagens SMS.


[26] Comentário enviado por le_videira em 15/11/2009 - 11:41h:

Eu instalei, mas não consegui conectar.

Espetei o moden, ejetei, ai blz... configurei uma conexão, quando tentei conectar ele pediu uma senha... depois pediu senha do ficheiro padrão, que eu não sei qual é...

Quando eu tentei outra alternativa, o moden simplesmente sumiu...

Tentei desinstalar, dica acima, mas o terminal disse que para isso eu preciso ser um superusuario

O que eu faço?

P.S.: Sou iniciante


[27] Comentário enviado por cbastos em 02/12/2009 - 14:46h:

perfeito!! o único porém é o fato de alguns modens da vivo não trazerem o vivo-1.0.0B03.i386.deb e sim um pacote LinuxUI com um script para instalar o ZMC. Neste caso, não instalem este pacote, e baixem o vivo-1.0.0B03.i386.deb conforme o link disponibilizado pelo kvix em
http://www.kvix.com.br/downloads/vivo-1.0.0B03.i386.deb


[28] Comentário enviado por Cr1sthoffer em 22/05/2010 - 12:16h:

Não existe mais nos Kernels do Ubuntu o 2.6.29-4. atualizei para o Kernel 2.6.29-6 e não funcionou, oque faço?



Contribuir com comentário


  
Para executar esta ação você precisa estar logado no site, caso contrário, tudo o que for digitado será perdido.
Responsável pelo site: Fábio Berbert de Paula - Conteúdo distribuído sob licença GNU FDL
Site hospedado por:

Viva o Linux

A maior comunidade Linux da América Latina! Artigos, dicas, tutoriais, fórum, scripts e muito mais. Ideal para quem busca auto-ajuda em Linux.