Linux slogan
Visite também: BR-Linux.org · Dicas-L · SoftwareLivre.org · UnderLinux

Linux banner
Linux banner
Linux banner
Linux banner


» Screenshot
Linux: Tentando Travar
Por alvesfox


Artigo

Configurando servidor MikroTik com Hotspot e páginas de aviso (atraso e bloqueio)
Linux user
MR. RG
03/07/2008
Bem pessoal, aqui estou para demonstrar como criar um servidor hotspot no MikroTik com páginas de aviso por atraso e bloqueio. Como o MikroTik vem se difundindo aos poucos, precisamos saber cada vez mais sobre suas configurações, que são diversas. Críticas construtivas serão bem vindas.
Por: Raniel Guimaraes
[ Hits: 427284 ]
Conceito: 10.0   2 voto(s)2 voto(s)2 voto(s)2 voto(s)2 voto(s) + quero dar nota ao artigo

Introdução

Tipologia da rede do MikroTik

Aqui usarei o seguinte:

ISP:
192.168.50.20/24

REDE:
192.168.1.1

MikroTik versão:
2.9.50

Note: Podem ser em outras também.

Configurando os IPs, route e dns do MikroTik

Esta parte creio que todos já sabem, mas vamos dar um refresh, pois há alguns que estão começando agora.

Como costumo fazer, renomeio as interfaces:

/interface set ether1 name=internet comment="conexão com a internet"
/interface set ether2 name=network comment="conexão com os clientes"


Configurar os IPs:

/ip address add address=192.168.50.20/24 interface=internet
/ip address add address=192.168.1.1/24 interface=network


Configurar os DNS:

/ip dns set primary-dns=192.168.50.1
/ip dns static add name=192.168.1.1 address=192.168.1.1


Compartilhando a internet com a rede local

Esta etapa todos já sabem de cór:

/ip firewall nat add chain=src-nat src-address=192.168.1.0/24 action=masquerade

    Próxima página >>




Páginas do artigo

Outros artigos deste autor

Leitura recomendada

Comentários
[1] Comentário enviado por removido em 04/07/2008 - 18:29h:

Boa :D


[2] Comentário enviado por mattana em 17/07/2008 - 16:58h:

Duvida: se usuário final quizer dividir usa conexao eu posso até liberar para que cada perfil aceite 2 ou mais usuários por mac, porem ai que vem o problema, cada usuário logado terá uma velocidade estipulada no perfil.

Algo para resolver esse problema? eu posso cadastrar os usuário no mikrotik normal sem usar o hotspot e redirecionar ele para uma pagina interna tambm?


[3] Comentário enviado por MR. RG em 18/07/2008 - 08:04h:

mattana,
Poderá sim, no entanto, você terá que criar uma rede diferente, pois se colocar o ip que estiver na rede do servidor hotspot, ele irá redirecionar.


[4] Comentário enviado por compactornet em 19/10/2008 - 22:28h:

Cara eu instalei o mk na maquina virtual e estava configurando quando na hora de Configurar o perfil do servidor deu erro ele diz assim ( no such argument (rate-limite) )
O que eu faço agora pra mim terminar de configurar o mk ?
Qualquer coisa posta aqui ou me mandar por email=pronacapi@hotmail.com ou jardeldesousa@gmail.com
vlw...


[5] Comentário enviado por Mr. RG em 20/10/2008 - 07:36h:

Você não deve setar o rate limit no servidor e sim no perfil da aba users.

/ip hotspot profile add name="config" hotspot-address=192.168.1.1 dns-name="192.168.1.1" html-directory=hotspot http-proxy=0.0.0.0:0 smtp-server=0.0.0.0 login-by=mac,http-chap split-user-domain=no use-radius=no

/ip hotspot add name=servidor-hotspot profile=config interface=network

Leia com mais calma o post que conseguirá fazer.


[6] Comentário enviado por compactornet em 20/10/2008 - 20:28h:

Cara essas configurações ai tambem pega na versao 2.9.27 ?


[7] Comentário enviado por Mr. RG em 20/10/2008 - 20:48h:

Estas confs foram feita sobre o mikrotik 2.9.50, mas podem ser feitas em outras também, pois elas seguem o mesmo padrão.


[8] Comentário enviado por compactornet em 21/10/2008 - 12:50h:

Cara onde eu encontro esse filezilla client e como eu conecto ele no mikrotik ?


[9] Comentário enviado por Mr. RG em 21/10/2008 - 15:46h:

https://www.ohloh.net/projects/filezilla/download?filename=FileZilla_3.1.4.1_win32-setup.exe

Coloque o admin em usuario e a senha, a porta não é preciso especificar a não ser que você tenha alterado no mikrotik.


[10] Comentário enviado por bigben em 04/11/2008 - 14:13h:

Como eu faria o mesmo com o usuário sendo autenticado/gerenciado pelo RADIUS?


[11] Comentário enviado por rubsom em 12/11/2008 - 21:27h:

Pessoal, aki com a 2.9.27, fiz e refiz, tudo de acordo com o texto.

no entanto.

em liberado ele acessa.
em aviso ele acessa.
em bloqueado ele não navega.

mas não exibe as mensagens aviso.html e bloqueio.html

o que pode ser?


[12] Comentário enviado por MR. RG em 13/11/2008 - 00:27h:

Isto acontece porque os avisos são abertos em uma pop-up. Para que os avisos abram na mesma página, você deve alterar as configurações de javascript da página "radvert.html"


[13] Comentário enviado por rubsom em 13/11/2008 - 13:01h:

mas aki nem na popup ele abriu.

ele abre uma popup, mas com os dados da conta. a Welcome User


[14] Comentário enviado por MR. RG em 13/11/2008 - 22:39h:

Refaça a configuração observando passo - a - passo.


[15] Comentário enviado por compactornet em 17/11/2008 - 01:07h:

>>>>>>>>>>>


[16] Comentário enviado por compactornet em 17/11/2008 - 01:08h:

Essa configuração só funciona se o meu mk tiver hotspot ou posso fazer de uma forma que não precisa usar o hotspot? por que fiquei sabendo que o hotspot precisa de uma parte da minha banda para funcionar e como eu só tenho 1 mega para 40 clientes não vai dar para dividir a banda com o hotspot.


[17] Comentário enviado por compactornet em 06/12/2008 - 20:18h:

aff...
niquem responde minha pergunta...
pq ???


[18] Comentário enviado por Mr. rg em 06/12/2008 - 23:05h:

Filho, para mandar aviso sem ser pelo hotspot, você teria que ter um segundo servidor rodando a apache ou outro.


[19] Comentário enviado por compactornet em 10/12/2008 - 01:12h:

Me fala mais sobre esse segundo servidor,agora fiquei enteresado.


[20] Comentário enviado por bosquenet em 17/04/2009 - 06:50h:

Oie, Bom dia!
Aumentei a velocidade do meu link para 4megas. Como e aonde devo alterar este parâmetro
no servidor? Para que a velocidade de entrada seja 4Megas.

Obrigado


[21] Comentário enviado por Mr. RG em 18/04/2009 - 21:00h:

Se você não estiver fazendo controle de entrada da interface de internet, não precisa mexer em nada. Caso esteja fazendo controle, altere as configs que controlam a entrada, mas creio que não esteja fazendo. Por isso não é necessário mexer em nada, a não ser aumentar um pouco de velocidade dos clientes, hehehe
:D


[22] Comentário enviado por fabiozero em 15/05/2009 - 14:54h:

gostaria saber como faço para criar uma tela de bloqueio no mk para avisar o cliente q ele sera suspenso ate o acerto de débito, pois tenho visto q é possivel realizar este procedimento no mk, se alguem sour como, favor me ajudem, pois eu preciso muito


[23] Comentário enviado por removido em 04/06/2009 - 08:26h:

estou testando um hotpost na bancada...ele já autentica tudo direitinho para um usuário no profile default então criei uma pagina de avicom isso estou com dois problemas no hotspot:
1)o usuário teste não está sendo direcionado para a pagina aviso.html e continua navegando
2) não sei porque mas se eu sair da internet e vor entrar novamente ele não pede senha mesmo limpando o cache continuo logado com o usuario teste...tem como pedir login toda vez que o navegadoer for fechado pois por exemplo posso querer usar outro usuário com mais privilégios e etc...
so para testes: aviso.html e joguei dentro do pasta hotspot depois fui no terminal e digitei as regras:


/ip hotspot user profile add name="Aviso" address-pool=hs-pool-4 idle-timeout=5m keepalive-timeout=2m status-autorefresh=1m shared-users=1 transparent-proxy=no open-status-page=always advertise=yes advertise-url=aviso.html advertise-interval=20m advertise-timeout=15s


ip hotspot user add name=teste profile="Aviso" server=hotspot1 password=teste

1)o usuário teste não está sendo direcionado para a pagina aviso.html e continua navegando
2) não sei porque mas se eu sair da internet e vor entrar novamente ele não pede senha mesmo limpando o cache continuo logado com o usuario teste...tem como pedir login toda vez que o navegadoer for fechado pois por exemplo posso querer usar outro usuário com mais privilégios e etc...

OBS.: não marquei o proxy na regra pois uso webproxy com hotspot ..mas mesmo marcando dá na mesma o problema.


[24] Comentário enviado por faroots em 05/06/2009 - 15:49h:

Caro amigo MR. RG, me ajude, sou novato em MK, entendo um pouco de linux! Seguinte:
link 192.168.1.0/24
rede 192.168.1.0/24
Configurei o hotSpot, tudo funcionando perfeito, no cabo, tudo ok, pede login senha, autentico numa boa, agora quando coloco na rede wireless, não funciona
ele entra na pagina principal do hotspot mas da um erro de usuario e senha quando tento logar, meu AP ligado no servidor MK está com firmware WAPPRO,
configurados como AP e em bridge, e na mesma faixa da interface (rede 192.168.1.0/24), pode me ajudar?
abraço


[25] Comentário enviado por Mr. RG em 15/06/2009 - 17:41h:

Meu caro, neste caso, a wireless, se for conectada por um cabo que vai para a mesma placa onde o hotspot está configurado, tem que ficar em modo de operação bridge. Caso a wireless seje uma placa diferente(wlan por exemplo), crie uma bridge e configure o hotspot sobre esta bridge.


[26] Comentário enviado por rogervany em 29/08/2009 - 01:59h:

Boa Noite



Sou novo na forum e gostaria de saber como faço pra ver o tuto para emviar avisos pelo hotspot
mikrotik

obrigado pessoal>


[27] Comentário enviado por call em 11/12/2009 - 05:51h:

Olá amigo professor estou tendo problemas em routear minha net com mk,uso uma rb 433ah e tenho net cabomais aqui no recife.gostaria por gentileza que alguém me ajuda-se,bom o problema é o seguinte tenho net fornecida pela operadora cabomais aqui no recife no escritorio e estou tentando sem sucesso routear utilizando mikrotik v3,22 em uma rb 433ah para q eu possa enviar para meu ap a 3 km,a cabomais manda seu sinal por meio de cabo q é conectado a um cable modem esse que é conectado ao pc,não preciso altenticar e o modem ñ é routeado e nem routeia,ou seja,recebo um ip válido direto para meu pc e com esse ip consigo navegar,sei q á filtro de mac pois somente consigo navegar no pc q a net foi instalada,mais sei q é possível routear mais ñ sei como ,alguem poderia me encinar como fazer esse procedimento,desde já agradeço ,um abraço á todos


[28] Comentário enviado por nanio em 06/02/2010 - 22:13h:

amigo, onde baixo o mk?


[29] Comentário enviado por pmjrj em 07/02/2010 - 13:29h:

Preciso de uma ajuda: Comprei uma Router Board RB 750 com Mikrotik, ja consegui dominar a criação de usuarios no Hotspot, perfil de velocidade etc.. (tudo pelo winbox), mas estou cego como fazer os avisos de atraso e bloqueio total, pois aqui so vejo explicações assim por exemplo: ( /ip hotspot user profile add name="Bloqueado" address-pool=pool idle-timeout=5m keepalive-timeout=2m status-autorefresh=1m shared-users=1 incoming-filter="input" outgoing-filter="output" transparent-proxy=yes open-status-page=always advertise=yes advertise-url=bloqueio.html advertise-interval=1s advertise-timeout=never ) onde coloco isso no winbox? la é interface grafica, perdoe minha ignorancia, pois estou acostumado a usar o BRAZILFW e la estes procedimentos de aviso e bloqueio sao muito faceis usando um addon chamado Easy Captive, mas aqui no mikrotik é muito dificil, porem preciso substituir o BFW pela RB750, por favor me ajudem e mais uma vez perdoe minha ignorancia.


[30] Comentário enviado por binoanb em 20/03/2010 - 23:18h:

Amigo você saber autenticar usuário e senha pelo terminal apenas, sem navegador?

É porque estou com uma máquina instalando linux sem interface gráfica e estou com dificuldade de autênticação para acessar a internet por ela e atualizar o sistema. Ou seja, autenticar pelo hotspot no terminal.

Obrigado.


[31] Comentário enviado por capanga157 em 24/03/2010 - 03:04h:

Qual versão vc utiliza???
Uso a versão 3.25 numa RB 433AH e tem dado um [*****] no hotspot.
Não sei bem o que e já fiz tudo que foi tipo de configuração e anda travando. Sempre usei Shid cache e thunder cache no servidor linux (ubuntu) e junto à RB.



[32] Comentário enviado por hugosenna em 02/04/2010 - 22:47h:

"128k/80k (down/up)"

nao seria ao contrario ? pois no Mk mostra na ordem rate limite (TX/rX) . onde TX seria o UPload e RX o download. entao o correto nao seria "128k/80k (up/down)" ?


[33] Comentário enviado por setalink em 08/04/2010 - 11:30h:

Bom dia gostaria de perguntar aos amigos pq depois que eu configurei a tela de avido e bloqueio no meu MK
quando eu bloqueio para teste em minha máquina me dá este aviso

(internal error (failed to add filter-in rule: jumps to builtin chains not allowed (6))

caso alguém tenha a regra correta favor enviar para deltaprov@bol.com.br


[34] Comentário enviado por setalink em 10/04/2010 - 02:25h:

bom dia a todos, consegui colocar a pagina de aviso e a de bloqueio sendo que a de bloqueio aparece mais não bloqueia o que poderia ser. grato se alguém puder me ajudar


[35] Comentário enviado por ubiratan1234 em 26/04/2010 - 22:47h:

Amigos, estou com um probleminha no meu mikrotik e não sei se isso é assim mesmo, estou amarrando IP e MAC no DHCP SERVER e libero no hotspot, porém meus clientes ao ser logado é atribuido um IP diferente do que amarrei. alguém poderá me ajudar nesta questão, até porque antes os IPs ficavam iguais e depois de 8 dias de uso atribuem diferentes mas, na mesma faixa.


[36] Comentário enviado por samorphy em 18/06/2010 - 10:04h:

Problemas de ip diferentes é uma mania que todos tem de deixar o ip ser atribuido no hotspot e no dhcp, aconselho deixar apenas o dhcp dar ip, deixando "none" no address poll do seu server do hotspot e em cada user profile que você criou, assim o ip será sempre o mesmo em cada local que você conferir.


[37] Comentário enviado por fabiozero em 30/06/2010 - 10:54h:

to com um problema, pois to tentando instalar um hotspot na versão 2.9.27, mas nao funciona de jeito nenhum, qdo termino de criar o hotspot a conexao cai e nao consigo mais acessar o servidor pelo winbox, se vc puder me dar uma ajuda eu te agradeço, pois estou precisando muito colocar esse hotspot para funcionar.me chama pelo msn: fabionunescorretor#windowslive.com.

Desde já eu te agradeço


[38] Comentário enviado por leanfar em 16/03/2011 - 20:33h:

Olá Reniel!

Desculpe ressucitar o tópico, mas preciso de uma ajuda...

Eu fiz os passos que vc postou aqui mas quando tento acessar a minha página que criei usando um editor de html sempre ocorre o erro 404.

Vc sabe o q pode ser?

Editor html = iWeb (apple)
Versão MK = 4.11


[39] Comentário enviado por rafaelalmeida em 29/08/2011 - 16:13h:

Muito bom! Vale lembrar que a configuração via interface web também é bem simples!! e funciona bem!


[40] Comentário enviado por dennercn em 21/10/2011 - 14:58h:

Boa tarde.

Preciso de ajuda, quando um cliente loga na rede todos que entram fica logado na mesma USER que a pessoa, o que eu fasso para controlar isso


[41] Comentário enviado por instmergulho em 28/12/2011 - 10:18h:

olha só tenho 1 enorme duvida! naum sou muito enterado no SO mk! mais comprei uma router board 433AH e naum tou conseguindo confg. o ip do meu modem he 192.168.254.254 e sei ki he /24
alguem pode me dar uma força!!:???????


[42] Comentário enviado por McLouds em 04/05/2012 - 19:42h:

Parabéns!
Depois de 3 dias assitindo inúmeros vídeos imprestáveis, com este artigo consegui configurar o hostpot!
Parabéns mesmo!



Contribuir com comentário


  
Para executar esta ação você precisa estar logado no site, caso contrário, tudo o que for digitado será perdido.
Responsável pelo site: Fábio Berbert de Paula - Conteúdo distribuído sob licença GNU FDL
Site hospedado por:

Viva o Linux

A maior comunidade Linux da América Latina! Artigos, dicas, tutoriais, fórum, scripts e muito mais. Ideal para quem busca auto-ajuda em Linux.